aboutsummaryrefslogtreecommitdiff
path: root/editors/gedit/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'editors/gedit/Makefile')
-rw-r--r--editors/gedit/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/editors/gedit/Makefile b/editors/gedit/Makefile
index 66bd11e69dab..1c6e705d9d95 100644
--- a/editors/gedit/Makefile
+++ b/editors/gedit/Makefile
@@ -32,4 +32,11 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
MAN1= gedit.1
+post-extract:
+ @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+ @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+ 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
+ s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
+
.include <bsd.port.mk>