aboutsummaryrefslogtreecommitdiff
path: root/editors/gedit/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'editors/gedit/Makefile')
-rw-r--r--editors/gedit/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/editors/gedit/Makefile b/editors/gedit/Makefile
index eb0e40160a84..12d47a32eea4 100644
--- a/editors/gedit/Makefile
+++ b/editors/gedit/Makefile
@@ -19,7 +19,7 @@ RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:${PORTSDIR}/misc/iso-co
USES= desktop-file-utils gettext gmake libtool:keepla pathfix \
pkgconfig tar:bzip2
-USE_XORG= sm
+USE_XORG= ice sm
INSTALLS_OMF= yes
INSTALL_TARGET= install-strip
USE_LDCONFIG= yes
@@ -45,4 +45,8 @@ CONFIGURE_ARGS+=--disable-python
PLIST_SUB+= PYTHON="@comment "
.endif
+post-patch:
+ ${REINPLACE_CMD} '/EGG_SMCLIENT_LIBS =/s/$$/ -lICE/' \
+ ${WRKSRC}/gedit/smclient/Makefile.in
+
.include <bsd.port.post.mk>