aboutsummaryrefslogtreecommitdiff
path: root/editors/ghex2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'editors/ghex2/Makefile')
-rw-r--r--editors/ghex2/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/editors/ghex2/Makefile b/editors/ghex2/Makefile
index 6f1c8d1c8a82..7e5171fb2843 100644
--- a/editors/ghex2/Makefile
+++ b/editors/ghex2/Makefile
@@ -6,11 +6,10 @@
#
PORTNAME= ghex2
-PORTVERSION= 2.2.1
-PORTREVISION= 2
+PORTVERSION= 2.4.0.1
CATEGORIES= editors gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME:S/2$//}/2.2
+MASTER_SITE_SUBDIR= sources/${PORTNAME:S/2$//}/2.4
DISTNAME= ${PORTNAME:S/2$//}-${PORTVERSION}
DIST_SUBDIR= gnome2
@@ -20,10 +19,11 @@ COMMENT= GNOME 2 hex editor
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
+USE_REINPLACE= yes
USE_GNOME= gnomeprefix gnomehack gail libgnomeprintui libgnomeui
USE_LIBTOOL= yes
-USE_REINPLACE= yes
+INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib"
+ LDFLAGS="-L${LOCALBASE}/lib"
.include <bsd.port.mk>