aboutsummaryrefslogtreecommitdiff
path: root/editors/gmanedit/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'editors/gmanedit/Makefile')
-rw-r--r--editors/gmanedit/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/editors/gmanedit/Makefile b/editors/gmanedit/Makefile
index 4c2f73ac4427..5db734dde6e4 100644
--- a/editors/gmanedit/Makefile
+++ b/editors/gmanedit/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gmanedit
PORTVERSION= 0.3.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= editors gnome
MASTER_SITES= http://gmanedit.sourceforge.net/files/ \
${MASTER_SITE_SOURCEFORGE}
@@ -28,9 +28,12 @@ ALL_TARGET= clean all
post-extract:
@${RM} -rf ${WRKSRC}/config.cache
+ @${FIND} ${WRKSRC} -name Makefile | ${XARGS} ${RM} -f
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
- s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+ s|DATADIRNAME=lib|DATADIRNAME=share|g ; \
+ s|PACKAGE_PIXMAPS_DIR=".*/pixmaps|PACKAGE_PIXMAPS_DIR="${PREFIX}/share/pixmaps|g' \
+ ${WRKSRC}/configure
.include <bsd.port.mk>