aboutsummaryrefslogtreecommitdiff
path: root/editors/gwrite/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'editors/gwrite/Makefile')
-rw-r--r--editors/gwrite/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/editors/gwrite/Makefile b/editors/gwrite/Makefile
new file mode 100644
index 000000000000..4525a3da53f3
--- /dev/null
+++ b/editors/gwrite/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: gwrite
+# Date created: 07 Mar 2010
+# Whom: Ju Pengfei <jupengfei@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gwrite
+PORTVERSION= 0.3.0
+CATEGORIES= editors python
+MASTER_SITES= GOOGLE_CODE
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= jupengfei@gmail.com
+COMMENT= A simple HTML format editor
+
+BUILD_DEPENDS= pygtk-demo:${PORTSDIR}/x11-toolkits/py-gtk2 \
+ ${PYTHON_PKGNAMEPREFIX}distutils-extra>=2.15:${PORTSDIR}/devel/py-distutils-extra \
+ ${PYTHON_SITELIBDIR}/webkit/__init__.py:${PORTSDIR}/www/py-webkitgtk \
+ ${PYTHON_SITELIBDIR}/jswebkit.so:${PORTSDIR}/www/py-jswebkit \
+ ${LOCALBASE}/bin/intltool-update:${PORTSDIR}/textproc/intltool
+RUN_DEPENDS= ${BUILD_DEPENDS} \
+ ${LOCALBASE}/share/icons/gnome/index.theme:${PORTSDIR}/misc/gnome-icon-theme \
+ ${LOCALBASE}/share/icons/Tango/index.theme:${PORTSDIR}/x11-themes/icons-tango \
+ wvHtml:${PORTSDIR}/textproc/wv
+
+PROJECTHOST= gwrite
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+PYDISTUTILS_NOEGGINFO= yes
+
+.include <bsd.port.mk>