aboutsummaryrefslogtreecommitdiff
path: root/editors/hte/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'editors/hte/Makefile')
-rw-r--r--editors/hte/Makefile16
1 files changed, 3 insertions, 13 deletions
diff --git a/editors/hte/Makefile b/editors/hte/Makefile
index 4d675910a877..ef340b43f9be 100644
--- a/editors/hte/Makefile
+++ b/editors/hte/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= hte
-PORTVERSION= 0.9.4
+PORTVERSION= 2.0
CATEGORIES= editors
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -16,6 +16,7 @@ DISTNAME= ht-${PORTVERSION}
MAINTAINER= mva@sysfault.org
COMMENT= A file editor/viewer/analyzer for executables
+USE_GCC= 4.1+
USE_BZIP2= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
@@ -24,21 +25,12 @@ PLIST_FILES= bin/ht
.include <bsd.port.pre.mk>
-.if ${ARCH} == "ia64"
-BROKEN= does not build on ia64
-.endif
-
-.if ${OSVERSION} < 400000
-LIB_DEPENDS+= ncurses.5:${PORTSDIR}/devel/ncurses
-.endif
-
.if defined(WITHOUT_X11)
PKGNAMESUFFIX= -nox11
CONFIGURE_ARGS=--disable-x11-textmode
.else
USE_XLIB= yes
-CPPFLAGS= -I${X11BASE}/include
-LDFLAGS= -L${X11BASE}/lib
+CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include" LDFLAGS="-L${X11BASE}/lib"
.endif
.if !defined(NOPORTDOCS)
@@ -52,8 +44,6 @@ post-patch:
${WRKSRC}/configure
@${REINPLACE_CMD} -e \
's|typedef unsigned int uint;||g' ${WRKSRC}/global.h
- @${REINPLACE_CMD} -e \
- 's|uint |UINT |g' ${WRKSRC}/htdata.h
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/ht ${PREFIX}/bin