aboutsummaryrefslogtreecommitdiff
path: root/editors/joe/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'editors/joe/Makefile')
-rw-r--r--editors/joe/Makefile25
1 files changed, 10 insertions, 15 deletions
diff --git a/editors/joe/Makefile b/editors/joe/Makefile
index 6d9b39068ea4..5e7896147448 100644
--- a/editors/joe/Makefile
+++ b/editors/joe/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= joe
-PORTVERSION= 4.2
-PORTREVISION= 1
+PORTVERSION= 4.5
PORTEPOCH= 1
CATEGORIES?= editors
MASTER_SITES= SF/joe-editor/JOE%20sources/joe-${PORTVERSION}
@@ -12,31 +11,27 @@ MAINTAINER= juergen.gotteswinter@googlemail.com
COMMENT= Joe's Own Editor
LICENSE= GPLv2
-
-
-OPTIONS_DEFINE= ASPELL DOCS
+LICENSE_FILE= ${WRKSRC}/COPYING
CONFLICTS= joe-2.*
-USES= gmake iconv ncurses
+USES= gmake iconv localbase ncurses
GNU_CONFIGURE= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LIBS+= -L${LOCALBASE}/lib ${ICONV_LIB}
+CONFIGURE_ENV= SPELL=aspell
+LIBS+= ${ICONV_LIB}
ALL_TARGET= ${PORTNAME}
-.include <bsd.port.options.mk>
+OPTIONS_DEFINE= ASPELL DOCS
-.if ${PORT_OPTIONS:MASPELL}
-RUN_DEPENDS= aspell:textproc/aspell
-.endif
+ASPELL_RUN_DEPENDS= aspell:textproc/aspell
post-patch:
${REINPLACE_CMD} -e 's|docs/README.old docs/man.md ||' ${WRKSRC}/Makefile.in
post-install:
- for rc in jmacsrc joerc jpicorc jstarrc rjoerc; do \
- ${MV} ${STAGEDIR}${ETCDIR}/$${rc} ${STAGEDIR}${ETCDIR}/$${rc}.sample ; \
- done
+.for rc in ftyperc jmacsrc joerc jpicorc jstarrc rjoerc
+ ${MV} ${STAGEDIR}${ETCDIR}/${rc} ${STAGEDIR}${ETCDIR}/${rc}.sample
+.endfor
.include <bsd.port.mk>