aboutsummaryrefslogtreecommitdiff
path: root/editors/kate/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'editors/kate/Makefile')
-rw-r--r--editors/kate/Makefile11
1 files changed, 2 insertions, 9 deletions
diff --git a/editors/kate/Makefile b/editors/kate/Makefile
index 09969261df0a..cc84964cea20 100644
--- a/editors/kate/Makefile
+++ b/editors/kate/Makefile
@@ -3,18 +3,14 @@
PORTNAME= kate
PORTVERSION= ${KDE4_VERSION}
-PORTREVISION= 1
CATEGORIES= editors kde
-MASTER_SITES= ${MASTER_SITE_KDE}
-MASTER_SITE_SUBDIR= ${KDE4_BRANCH}/${PORTVERSION}/src
+MASTER_SITES= KDE/${KDE4_BRANCH}/${PORTVERSION}/src
DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= Basic editor framework for the KDE system
-LIB_DEPENDS= qjson.0:${PORTSDIR}/devel/qjson
-
-CONFLICTS= kdebase-4.[0-6].* kdelibs-4.[0-6].* kdesdk-4.[0-6].*
+LIB_DEPENDS= libqjson.so:${PORTSDIR}/devel/qjson
USE_XZ= yes
USE_KDE4= kdelibs kdeprefix kdehier automoc4 kactivities
@@ -24,10 +20,7 @@ USE_QT4= dbus gui script sql webkit xml \
moc_build qmake_build rcc_build uic_build
USE_LDCONFIG= yes
-MAN1= kate.1
-
# editors/kate-plugin-pate installs pate
CMAKE_ARGS+= -DBUILD_pate=off
-NO_STAGE= yes
.include <bsd.port.mk>