aboutsummaryrefslogtreecommitdiff
path: root/editors/kate/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'editors/kate/Makefile')
-rw-r--r--editors/kate/Makefile21
1 files changed, 9 insertions, 12 deletions
diff --git a/editors/kate/Makefile b/editors/kate/Makefile
index 35f96d50d632..eadabf80fc2e 100644
--- a/editors/kate/Makefile
+++ b/editors/kate/Makefile
@@ -6,31 +6,28 @@ PORTVERSION= ${KDE4_VERSION}
CATEGORIES= editors kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= ${KDE4_BRANCH}/${PORTVERSION}/src
-DIST_SUBDIR= KDE
+DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= Basic editor framework for the KDE system
+LIB_DEPENDS= qjson.0:${PORTSDIR}/devel/qjson
+
CONFLICTS= kdebase-4.[0-6].* kdelibs-4.[0-6].* kdesdk-4.[0-6].*
-USE_XZ= yes
+USE_XZ= yes
USE_GETTEXT= yes
-USE_KDE4= kdelibs kdeprefix kdehier automoc4 sharedmime
+USE_KDE4= kdelibs kdeprefix kdehier automoc4 kactivities
USES= cmake:outsource
USE_PERL5_BUILD= yes
-USE_QT4= dbus gui qt3support script sql xml \
+USE_QT4= dbus gui script sql webkit xml \
moc_build qmake_build rcc_build uic_build
USE_LDCONFIG= yes
MAKE_JOBS_SAFE= yes
-MAN1= kate.1
-
-post-patch:
- # Prevent updating MIME during build.
- ${REINPLACE_CMD} -e '/^update_xdg_mimetypes/ d; /SharedMimeInfo/ d' \
- ${PATCH_WRKSRC}/kate/plugins/snippets_tng/CMakeLists.txt
+MAN1= kate.1
-post-install:
- @-update-mime-database ${KDE4_PREFIX}/share/mime
+# editors/kate-plugin-pate installs pate
+CMAKE_ARGS+= -DBUILD_pate=off
.include <bsd.port.mk>