aboutsummaryrefslogtreecommitdiff
path: root/editors/lfhex/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'editors/lfhex/Makefile')
-rw-r--r--editors/lfhex/Makefile13
1 files changed, 10 insertions, 3 deletions
diff --git a/editors/lfhex/Makefile b/editors/lfhex/Makefile
index 40c6d4176943..1261a742b0fa 100644
--- a/editors/lfhex/Makefile
+++ b/editors/lfhex/Makefile
@@ -8,21 +8,28 @@
PORTNAME= lfhex
PORTVERSION= 0.3.2
+PORTREVISION= 1
CATEGORIES= editors
-MASTER_SITES= ftp://typedef.dnsalias.org/pub/lfhex/
+MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= arved
-MAINTAINER= kde@freebsd.org
+MAINTAINER= ports@freebsd.org
+COMMENT= "Large file hex editor"
LIB_DEPENDS= gnugetopt:${PORTSDIR}/devel/libgnugetopt
USE_REINPLACE= yes
-USE_QT_VER= 2
+USE_QT_VER= 3
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-qt-moc=${MOC}
USE_GMAKE= yes
+CONFIGURE_ENV= CXXFLAGS="${PTHREAD_CFLAGS}"
post-patch:
@${REINPLACE_CMD} -e "s,%%LOCALBASE%%,${LOCALBASE},g ; \
s,%%X11BASE%%,${X11BASE},g" ${WRKSRC}/src/Makefile.in
+post-configure:
+ ${REINPLACE_CMD} -e "s,LFLAGS =,LFLAGS = ${PTHREAD_LIBS}," ${WRKSRC}/src/Makefile
+
.include <bsd.port.mk>