aboutsummaryrefslogtreecommitdiff
path: root/editors/libreoffice/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'editors/libreoffice/Makefile')
-rw-r--r--editors/libreoffice/Makefile13
1 files changed, 1 insertions, 12 deletions
diff --git a/editors/libreoffice/Makefile b/editors/libreoffice/Makefile
index 0d63198123c7..021cfff8be50 100644
--- a/editors/libreoffice/Makefile
+++ b/editors/libreoffice/Makefile
@@ -412,14 +412,6 @@ post-configure:
post-install:
@${RM} -f ${PLISTF} ${PLISTD}
- @${MKDIR} ${LODESTDIR}/${PREFIX}/share/applications
-.for component in writer printeradmin math javafilter base calc startcenter draw impress
- @cd ${LODESTDIR}/${PREFIX}/share/applications; ${CP} ../../lib/${PORTNAME}/share/xdg/${component}.desktop ${component}.desktop;
-.endfor
- @cd ${WRKSRC}/sysui/desktop/; ${PAX} -rw icons/hicolor ${LODESTDIR}/${PREFIX}/share
- # allow make deinstall/reinstall
- @${RM} -f ${LODESTDIR}/${PREFIX}/share/icons/hicolor/*/apps/libreoffice-*.png
- @for img in ${LODESTDIR}/${PREFIX}/share/icons/hicolor/*/apps/*.png; do ${MV} $$img `dirname $$img`/libreoffice-$${img##*/}; done
@for dir in ${EMPTYDIRS}; do ${TOUCH} ${LODESTDIR}/${PREFIX}/lib/$$dir/.keep; done
@cd ${LODESTDIR}/${PREFIX}/lib && ${FIND} -H -s * -type f -o -type l | \
@@ -427,7 +419,7 @@ post-install:
@cd ${LODESTDIR}/${PREFIX}/lib && ${FIND} -d * -type d | \
${SED} -e 's|^|@dirrm lib/|' >> ${PLISTD}
-.for subdir in share/applications share/icons
+.for subdir in share/application-registry share/applications share/icons share/mime share/mime-info share/mimelnk
@cd ${LODESTDIR}/${PREFIX}/${subdir} && ${FIND} -H -s * -type f -o -type l | \
${SED} -e 's|^|${subdir}/|' >> ${PLISTF}
@cd ${LODESTDIR}/${PREFIX}/${subdir} && ${FIND} -d * -type d | \
@@ -435,9 +427,6 @@ post-install:
@${ECHO_CMD} "@unexec ${RMDIR} %D/${subdir} 2>/dev/null || ${TRUE}" >> ${PLISTD}
.endfor
- @cd ${LODESTDIR}/${PREFIX}/share/icons && ${FIND} -H -s * -type f -o -type l | \
- ${SED} -e 's|^|share/icons/|' >> ${PLISTF}
-
@cd ${LODESTDIR}/${PREFIX}/bin && ${FIND} -H -s * -type f -o -type l | \
${SED} -e 's|^|bin/|' >> ${PLISTF}