aboutsummaryrefslogtreecommitdiff
path: root/editors/libreoffice/files/patch-desktop_Library__sofficeapp.mk
diff options
context:
space:
mode:
Diffstat (limited to 'editors/libreoffice/files/patch-desktop_Library__sofficeapp.mk')
-rw-r--r--editors/libreoffice/files/patch-desktop_Library__sofficeapp.mk20
1 files changed, 20 insertions, 0 deletions
diff --git a/editors/libreoffice/files/patch-desktop_Library__sofficeapp.mk b/editors/libreoffice/files/patch-desktop_Library__sofficeapp.mk
new file mode 100644
index 000000000000..843b7e200e09
--- /dev/null
+++ b/editors/libreoffice/files/patch-desktop_Library__sofficeapp.mk
@@ -0,0 +1,20 @@
+--- desktop/Library_sofficeapp.mk.orig 2015-08-22 06:41:35 UTC
++++ desktop/Library_sofficeapp.mk
+@@ -104,7 +104,16 @@ $(eval $(call gb_Library_add_libs,soffic
+ -lpthread \
+ ))
+ else
+-ifeq ($(OS),LINUX)
++ifeq ($(OS),FREEBSD)
++$(eval $(call gb_Library_use_static_libraries,sofficeapp,\
++ glxtest \
++))
++
++$(eval $(call gb_Library_add_libs,sofficeapp,\
++ -lGL \
++ -lX11 \
++))
++else ifeq ($(OS),LINUX)
+ $(eval $(call gb_Library_use_static_libraries,sofficeapp,\
+ glxtest \
+ ))