aboutsummaryrefslogtreecommitdiff
path: root/editors/libreoffice/files/patch-vcl_Executable__mtfdemo.mk
diff options
context:
space:
mode:
Diffstat (limited to 'editors/libreoffice/files/patch-vcl_Executable__mtfdemo.mk')
-rw-r--r--editors/libreoffice/files/patch-vcl_Executable__mtfdemo.mk20
1 files changed, 20 insertions, 0 deletions
diff --git a/editors/libreoffice/files/patch-vcl_Executable__mtfdemo.mk b/editors/libreoffice/files/patch-vcl_Executable__mtfdemo.mk
new file mode 100644
index 000000000000..525df9da36eb
--- /dev/null
+++ b/editors/libreoffice/files/patch-vcl_Executable__mtfdemo.mk
@@ -0,0 +1,20 @@
+--- vcl/Executable_mtfdemo.mk.orig 2015-08-22 06:41:35 UTC
++++ vcl/Executable_mtfdemo.mk
+@@ -40,7 +40,16 @@ $(eval $(call gb_Executable_use_static_l
+ vclmain \
+ ))
+
+-ifeq ($(OS),LINUX)
++ifeq ($(OS),FREEBSD)
++$(eval $(call gb_Executable_add_libs,mtfdemo,\
++ -lGL \
++ -lX11 \
++))
++
++$(eval $(call gb_Executable_use_static_libraries,mtfdemo,\
++ glxtest \
++))
++else ifeq ($(OS),LINUX)
+ $(eval $(call gb_Executable_add_libs,mtfdemo,\
+ -lm \
+ -ldl \