aboutsummaryrefslogtreecommitdiff
path: root/editors/libreoffice/files
diff options
context:
space:
mode:
Diffstat (limited to 'editors/libreoffice/files')
-rw-r--r--editors/libreoffice/files/patch-bin__build-ooo11
-rw-r--r--editors/libreoffice/files/patch-bin__ooinstall11
-rw-r--r--editors/libreoffice/files/patch-build__libreoffice__configure.in11
-rw-r--r--editors/libreoffice/files/patch-build__libreoffice__oox__util__makefile.mk10
-rw-r--r--editors/libreoffice/files/patch-build__libreoffice__scripts__soffice.sh11
-rw-r--r--editors/libreoffice/files/patch-build__libreoffice__solenv__bin__ooinstall11
6 files changed, 65 insertions, 0 deletions
diff --git a/editors/libreoffice/files/patch-bin__build-ooo b/editors/libreoffice/files/patch-bin__build-ooo
new file mode 100644
index 000000000000..af172980320b
--- /dev/null
+++ b/editors/libreoffice/files/patch-bin__build-ooo
@@ -0,0 +1,11 @@
+--- ./bin/build-ooo.orig 2010-11-11 15:41:38.000000000 +0100
++++ ./bin/build-ooo 2010-12-20 12:58:30.590567445 +0100
+@@ -11,7 +11,7 @@
+
+ export TARFILE_LOCATION
+
+-if test "z$BUILD_WIN32" = "z" -a "z`uname -s`" != "zSunOS" -a "z`uname -s`" != "zDarwin" -a "z`uname -s`" != "zOpenBSD"; then
++if test "z$BUILD_WIN32" = "z" -a "z`uname -s`" != "zSunOS" -a "z`uname -s`" != "zDarwin" -a "z`uname -s`" != "zOpenBSD" -a "z`uname -s`" != "zFreeBSD"; then
+ if ! test -f /proc/cpuinfo; then
+ echo "Looks like proc isn't mounted - this means almost certain"
+ echo "Java related weird build failure: please check /proc"
diff --git a/editors/libreoffice/files/patch-bin__ooinstall b/editors/libreoffice/files/patch-bin__ooinstall
new file mode 100644
index 000000000000..b9f224a8d09f
--- /dev/null
+++ b/editors/libreoffice/files/patch-bin__ooinstall
@@ -0,0 +1,11 @@
+--- ./bin/ooinstall.orig 2010-11-30 21:15:58.000000000 +0100
++++ ./bin/ooinstall 2010-12-20 12:58:30.609567023 +0100
+@@ -31,7 +31,7 @@
+ return 0;
+ }
+
+-( $^O =~ /openbsd/i ) || ( $^O =~ /darwin/i ) || ( -f "/proc/meminfo" ) || die "The installer cannot work without javaldx running, which requires /proc to be mounted";
++( $^O =~ /freebsd/i) || ( $^O =~ /openbsd/i ) || ( $^O =~ /darwin/i ) || ( -f "/proc/meminfo" ) || die "The installer cannot work without javaldx running, which requires /proc to be mounted";
+
+ suck_setup ("./setup") || suck_setup ("bin/setup") || die "can't find bin/setup";
+
diff --git a/editors/libreoffice/files/patch-build__libreoffice__configure.in b/editors/libreoffice/files/patch-build__libreoffice__configure.in
new file mode 100644
index 000000000000..0a507d2d8d29
--- /dev/null
+++ b/editors/libreoffice/files/patch-build__libreoffice__configure.in
@@ -0,0 +1,11 @@
+--- ./build/libreoffice/configure.in.orig 2010-12-17 23:08:36.000000000 +0100
++++ ./build/libreoffice/configure.in 2010-12-20 14:42:55.766436619 +0100
+@@ -2022,7 +2022,7 @@
+ dnl ===================================================================
+ AC_MSG_CHECKING([for GNU tar])
+ for a in $GNUTAR gtar gnutar tar; do
+- $a --version 2> /dev/null | grep GNU 2>&1 > /dev/null
++ $a --version 2> /dev/null | grep bsdtar 2>&1 > /dev/null
+ if test $? -eq 0; then
+ GNUTAR=$a
+ break
diff --git a/editors/libreoffice/files/patch-build__libreoffice__oox__util__makefile.mk b/editors/libreoffice/files/patch-build__libreoffice__oox__util__makefile.mk
new file mode 100644
index 000000000000..3daefd59fbbb
--- /dev/null
+++ b/editors/libreoffice/files/patch-build__libreoffice__oox__util__makefile.mk
@@ -0,0 +1,10 @@
+--- ./build/libreoffice/oox/util/makefile.mk.orig 2010-11-11 16:18:11.000000000 +0100
++++ ./build/libreoffice/oox/util/makefile.mk 2010-12-20 12:58:30.627567313 +0100
+@@ -79,6 +79,7 @@
+ $(MSFILTERLIB) \
+ $(UNOTOOLSLIB) \
+ $(XMLOFFLIB) \
++ -lcrypto \
+ $(TOOLSLIB)
+
+ # link openssl, copied this bit from ucb/source/ucp/webdav/makefile.mk
diff --git a/editors/libreoffice/files/patch-build__libreoffice__scripts__soffice.sh b/editors/libreoffice/files/patch-build__libreoffice__scripts__soffice.sh
new file mode 100644
index 000000000000..83b92e28bddc
--- /dev/null
+++ b/editors/libreoffice/files/patch-build__libreoffice__scripts__soffice.sh
@@ -0,0 +1,11 @@
+--- build/libreoffice/desktop/scripts/soffice.sh.orig 2010-12-12 21:12:42.000000000 +0100
++++ build/libreoffice/desktop/scripts/soffice.sh 2011-01-30 09:50:00.890272369 +0100
+@@ -64,7 +64,7 @@
+
+ # this is a temporary hack until we can live with the default search paths
+ case "`uname -s`" in
+-OpenBSD)
++OpenBSD|FreeBSD)
+ sd_prog1="$sd_prog/../basis-link/program"
+ sd_prog2="$sd_prog/../basis-link/ure-link/lib"
+ LD_LIBRARY_PATH=$sd_prog1:$sd_prog2${LD_LIBRARY_PATH:+:$LD_LIBRARY_PATH}
diff --git a/editors/libreoffice/files/patch-build__libreoffice__solenv__bin__ooinstall b/editors/libreoffice/files/patch-build__libreoffice__solenv__bin__ooinstall
new file mode 100644
index 000000000000..1ced95766ecb
--- /dev/null
+++ b/editors/libreoffice/files/patch-build__libreoffice__solenv__bin__ooinstall
@@ -0,0 +1,11 @@
+--- ./build/libreoffice/solenv/bin/ooinstall.orig 2010-11-30 21:17:23.000000000 +0100
++++ ./build/libreoffice/solenv/bin/ooinstall 2010-12-20 12:58:30.630567408 +0100
+@@ -14,7 +14,7 @@
+ $path = '';
+ $do_link = 0;
+
+-( $^O =~ /openbsd/i ) || ( $^O =~ /darwin/i ) || ( -f "/proc/meminfo" ) || die "The installer cannot work without javaldx running, which requires /proc to be mounted";
++( $^O =~ /freebsd/i ) || ( $^O =~ /openbsd/i ) || ( $^O =~ /darwin/i ) || ( -f "/proc/meminfo" ) || die "The installer cannot work without javaldx running, which requires /proc to be mounted";
+
+ # Workaround for system Mozilla
+ if ( $ENV{'SYSTEM_MOZILLA'} eq 'YES' ) {