aboutsummaryrefslogtreecommitdiff
path: root/editors/libreoffice/files
diff options
context:
space:
mode:
Diffstat (limited to 'editors/libreoffice/files')
-rw-r--r--editors/libreoffice/files/patch-Makefile.in15
-rw-r--r--editors/libreoffice/files/patch-bin_distro-install-desktop-integration21
-rw-r--r--editors/libreoffice/files/patch-configure50
-rw-r--r--editors/libreoffice/files/patch-libreofficekit_source_gtk_lokdocview.cxx18
-rw-r--r--editors/libreoffice/files/patch-sal_osl_unx_system.cxx12
-rw-r--r--editors/libreoffice/files/patch-sal_osl_unx_thread.cxx22
-rw-r--r--editors/libreoffice/files/patch-sc_source_filter_inc_orcusinterface.hxx40
-rw-r--r--editors/libreoffice/files/patch-sc_source_filter_orcus_interface.cxx59
-rw-r--r--editors/libreoffice/files/patch-sc_source_ui_docshell_datastream.cxx11
-rw-r--r--editors/libreoffice/files/patch-sfx2_source_control_emojiview.cxx26
-rw-r--r--editors/libreoffice/files/patch-shell_source_unix_exec_shellexec.cxx18
-rw-r--r--editors/libreoffice/files/patch-sysui_desktop_share_create_tree.sh20
-rw-r--r--editors/libreoffice/files/patch-vcl_CppunitTest__vcl__wmf__test.mk15
-rw-r--r--editors/libreoffice/files/patch-vcl_Executable__visualbackendtest.mk2
-rw-r--r--editors/libreoffice/files/patch-vcl_Library__vcl.mk20
-rw-r--r--editors/libreoffice/files/patch-vcl_source_app_svapp.cxx10
-rw-r--r--editors/libreoffice/files/patch-vcl_unx_gtk_fpicker_SalGtkFilePicker.cxx18
17 files changed, 99 insertions, 278 deletions
diff --git a/editors/libreoffice/files/patch-Makefile.in b/editors/libreoffice/files/patch-Makefile.in
index 4316ddc90a16..3d029c70cf22 100644
--- a/editors/libreoffice/files/patch-Makefile.in
+++ b/editors/libreoffice/files/patch-Makefile.in
@@ -1,6 +1,6 @@
---- Makefile.in.orig 2017-06-01 18:13:34 UTC
-+++ Makefile.in
-@@ -250,7 +250,7 @@ endif
+--- Makefile.in.orig 2018-02-21 20:11:59.625836000 -0500
++++ Makefile.in 2018-02-21 20:12:33.042717000 -0500
+@@ -254,7 +254,7 @@
#
# Bootstrap
#
@@ -9,3 +9,12 @@
#
# Build
+@@ -388,7 +388,7 @@
+ @exit 1
+ endif
+
+-distro-pack-install: install
++distro-pack-install: install-strip
+ $(SRCDIR)/bin/distro-install-clean-up
+ $(SRCDIR)/bin/distro-install-desktop-integration
+ $(SRCDIR)/bin/distro-install-sdk
diff --git a/editors/libreoffice/files/patch-bin_distro-install-desktop-integration b/editors/libreoffice/files/patch-bin_distro-install-desktop-integration
index 5b592beb80e5..c47689ddee3c 100644
--- a/editors/libreoffice/files/patch-bin_distro-install-desktop-integration
+++ b/editors/libreoffice/files/patch-bin_distro-install-desktop-integration
@@ -1,5 +1,5 @@
---- bin/distro-install-desktop-integration.orig 2017-05-03 16:46:29 UTC
-+++ bin/distro-install-desktop-integration
+--- bin/distro-install-desktop-integration.orig 2018-02-23 01:45:41.000000000 +0800
++++ bin/distro-install-desktop-integration 2018-03-16 09:45:26.157822000 +0800
@@ -99,7 +99,7 @@ cp -a workdir/CustomTarget/sysui/share/libreoffice/* "
cp -a "${SRCDIR?}"/sysui/desktop/share/create_tree.sh "$sysui_temp"
cd $sysui_temp
@@ -34,7 +34,7 @@
-e "s/\($INSTALLDIRNAME\)$PRODUCTVERSION_NODOT/\1/" \
-e "s/\($INSTALLDIRNAME\)$PRODUCTVERSION/\1/" \
-e "s/\($PRODUCTNAME\) $PRODUCTVERSION/\1/" \
-@@ -145,7 +145,7 @@ if test -f $DESTDIR/gid_Module_Root_Brand ; then
+@@ -144,7 +144,7 @@ if test -f $DESTDIR/gid_Module_Root_Brand ; then
$PREFIXDIR/share/mime/packages \
$PREFIXDIR/share/mime-info \
$PREFIXDIR/share/icons ; do
@@ -43,20 +43,25 @@
done
fi
-@@ -177,12 +177,12 @@ ln -sf $INSTALLDIR/program/soffice $DESTDIR$PREFIXDIR/
+@@ -172,16 +172,16 @@ test -f $DESTDIR/gid_Module_Optional_Xsltfiltersamples
+ # you cannot include this link directly into the package
+ # For example, the Novell package mark this symlink as %ghost
+ # and update it in %post and %postun
+-ln -sf $INSTALLDIR/program/soffice $DESTDIR$PREFIXDIR/bin/soffice
++ln -sf ../lib/libreoffice/program/soffice $DESTDIR$PREFIXDIR/bin/soffice
test -f $DESTDIR/gid_Module_Root_Brand && echo "$PREFIXDIR/bin/soffice" >>$DESTDIR/gid_Module_Root_Brand
# create bash completion
-mkdir -p $DESTDIR/usr/share/bash-completion/completions
--"${SRCDIR?}"/bin/generate-bash-completion bin/bash-completion.in $DESTDIR/usr/share/bash-completion/completions/$INSTALLDIRNAME.sh
+-"${SRCDIR?}"/bin/generate-bash-completion.py bin/bash-completion.in $DESTDIR/usr/share/bash-completion/completions/$INSTALLDIRNAME.sh
-test -f $DESTDIR/gid_Module_Root_Brand && echo "/usr/share/bash-completion/completions/$INSTALLDIRNAME.sh" >>$DESTDIR/gid_Module_Root_Brand
+mkdir -p $DESTDIR/${PREFIXDIR}/share/bash-completion/completions
-+"${SRCDIR?}"/bin/generate-bash-completion bin/bash-completion.in $DESTDIR${PREFIXDIR}/share/bash-completion/completions/$INSTALLDIRNAME.sh
++"${SRCDIR?}"/bin/generate-bash-completion.py bin/bash-completion.in $DESTDIR${PREFIXDIR}/share/bash-completion/completions/$INSTALLDIRNAME.sh
+test -f $DESTDIR/gid_Module_Root_Brand && echo "${PREFIXDIR}/share/bash-completion/completions/$INSTALLDIRNAME.sh" >>$DESTDIR/gid_Module_Root_Brand
if test "$WITH_COMPAT_OOWRAPPERS" = "TRUE" ; then
-- "${SRCDIR?}"/bin/generate-bash-completion --compat-oowrappers bin/bash-completion.in $DESTDIR/usr/share/bash-completion/completions/ooffice.sh
+- "${SRCDIR?}"/bin/generate-bash-completion.py --compat-oowrappers bin/bash-completion.in $DESTDIR/usr/share/bash-completion/completions/ooffice.sh
- test -f $DESTDIR/gid_Module_Root_Brand && echo "/usr/share/bash-completion/completions/ooffice.sh" >>$DESTDIR/gid_Module_Root_Brand
-+ "${SRCDIR?}"/bin/generate-bash-completion --compat-oowrappers bin/bash-completion.in $DESTDIR${PREFIXDIR}/share/bash-completion/completions/ooffice.sh
++ "${SRCDIR?}"/bin/generate-bash-completion.py --compat-oowrappers bin/bash-completion.in $DESTDIR${PREFIXDIR}/share/bash-completion/completions/ooffice.sh
+ test -f $DESTDIR/gid_Module_Root_Brand && echo "${PREFIXDIR}/share/bash-completion/completions/ooffice.sh" >>$DESTDIR/gid_Module_Root_Brand
fi
diff --git a/editors/libreoffice/files/patch-configure b/editors/libreoffice/files/patch-configure
index 8cd94acb1274..c14ddec5c59e 100644
--- a/editors/libreoffice/files/patch-configure
+++ b/editors/libreoffice/files/patch-configure
@@ -9,56 +9,6 @@
-@@ -30076,12 +30076,12 @@ if test -n "$ORCUS_CFLAGS"; then
- pkg_cv_ORCUS_CFLAGS="$ORCUS_CFLAGS"
- elif test -n "$PKG_CONFIG"; then
- if test -n "$PKG_CONFIG" && \
-- { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"liborcus-0.12 >= 0.12.0\""; } >&5
-- ($PKG_CONFIG --exists --print-errors "liborcus-0.12 >= 0.12.0") 2>&5
-+ { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"liborcus-0.13 >= 0.13.0\""; } >&5
-+ ($PKG_CONFIG --exists --print-errors "liborcus-0.13 >= 0.13.0") 2>&5
- ac_status=$?
- $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
- test $ac_status = 0; }; then
-- pkg_cv_ORCUS_CFLAGS=`$PKG_CONFIG --cflags "liborcus-0.12 >= 0.12.0" 2>/dev/null`
-+ pkg_cv_ORCUS_CFLAGS=`$PKG_CONFIG --cflags "liborcus-0.13 >= 0.13.0" 2>/dev/null`
- test "x$?" != "x0" && pkg_failed=yes
- else
- pkg_failed=yes
-@@ -30093,12 +30093,12 @@ if test -n "$ORCUS_LIBS"; then
- pkg_cv_ORCUS_LIBS="$ORCUS_LIBS"
- elif test -n "$PKG_CONFIG"; then
- if test -n "$PKG_CONFIG" && \
-- { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"liborcus-0.12 >= 0.12.0\""; } >&5
-- ($PKG_CONFIG --exists --print-errors "liborcus-0.12 >= 0.12.0") 2>&5
-+ { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"liborcus-0.13 >= 0.13.0\""; } >&5
-+ ($PKG_CONFIG --exists --print-errors "liborcus-0.13 >= 0.13.0") 2>&5
- ac_status=$?
- $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
- test $ac_status = 0; }; then
-- pkg_cv_ORCUS_LIBS=`$PKG_CONFIG --libs "liborcus-0.12 >= 0.12.0" 2>/dev/null`
-+ pkg_cv_ORCUS_LIBS=`$PKG_CONFIG --libs "liborcus-0.13 >= 0.13.0" 2>/dev/null`
- test "x$?" != "x0" && pkg_failed=yes
- else
- pkg_failed=yes
-@@ -30119,14 +30119,14 @@ else
- _pkg_short_errors_supported=no
- fi
- if test $_pkg_short_errors_supported = yes; then
-- ORCUS_PKG_ERRORS=`$PKG_CONFIG --short-errors --print-errors --cflags --libs "liborcus-0.12 >= 0.12.0" 2>&1`
-+ ORCUS_PKG_ERRORS=`$PKG_CONFIG --short-errors --print-errors --cflags --libs "liborcus-0.13 >= 0.13.0" 2>&1`
- else
-- ORCUS_PKG_ERRORS=`$PKG_CONFIG --print-errors --cflags --libs "liborcus-0.12 >= 0.12.0" 2>&1`
-+ ORCUS_PKG_ERRORS=`$PKG_CONFIG --print-errors --cflags --libs "liborcus-0.13 >= 0.13.0" 2>&1`
- fi
- # Put the nasty error message in config.log where it belongs
- echo "$ORCUS_PKG_ERRORS" >&5
-
-- as_fn_error $? "Package requirements (liborcus-0.12 >= 0.12.0) were not met:
-+ as_fn_error $? "Package requirements (liborcus-0.13 >= 0.13.0) were not met:
-
- $ORCUS_PKG_ERRORS
-
@@ -32542,7 +32542,7 @@ fi
diff --git a/editors/libreoffice/files/patch-libreofficekit_source_gtk_lokdocview.cxx b/editors/libreoffice/files/patch-libreofficekit_source_gtk_lokdocview.cxx
new file mode 100644
index 000000000000..f21dd1bbb5e7
--- /dev/null
+++ b/editors/libreoffice/files/patch-libreofficekit_source_gtk_lokdocview.cxx
@@ -0,0 +1,18 @@
+--- libreofficekit/source/gtk/lokdocview.cxx.orig 2018-01-31 18:56:05.312032000 +0300
++++ libreofficekit/source/gtk/lokdocview.cxx 2018-01-31 18:56:30.075522000 +0300
+@@ -3218,6 +3218,7 @@
+ G_TYPE_STRING);
+
+ /**
++ * LOKDocView::ruler:
+ * The key ruler related properties on change are reported by this.
+ *
+ * The payload format is:
+@@ -3244,6 +3245,7 @@
+ G_TYPE_STRING);
+
+ /**
++ * LOKDocView::invalidate-header:
+ * The column/row header is no more valid because of a column/row insertion
+ * or a similar event. Clients must query a new column/row header set.
+ *
diff --git a/editors/libreoffice/files/patch-sal_osl_unx_system.cxx b/editors/libreoffice/files/patch-sal_osl_unx_system.cxx
deleted file mode 100644
index 081fa2dd9acb..000000000000
--- a/editors/libreoffice/files/patch-sal_osl_unx_system.cxx
+++ /dev/null
@@ -1,12 +0,0 @@
---- sal/osl/unx/system.cxx.orig 2016-10-28 14:50:26 UTC
-+++ sal/osl/unx/system.cxx
-@@ -247,6 +247,9 @@ int macxp_resolveAlias(char *path, int b
- #endif /* NO_PTHREAD_RTL */
-
- #if defined(FREEBSD)
-+
-+#include <cmath>
-+
- char *fcvt(double value, int ndigit, int *decpt, int *sign)
- {
- static char ret[256];
diff --git a/editors/libreoffice/files/patch-sal_osl_unx_thread.cxx b/editors/libreoffice/files/patch-sal_osl_unx_thread.cxx
new file mode 100644
index 000000000000..56439e0d9c79
--- /dev/null
+++ b/editors/libreoffice/files/patch-sal_osl_unx_thread.cxx
@@ -0,0 +1,22 @@
+--- sal/osl/unx/thread.cxx.orig 2017-12-12 17:31:34.756103000 +0300
++++ sal/osl/unx/thread.cxx 2017-12-12 17:33:13.924729000 +0300
+@@ -45,6 +45,10 @@
+ #include <sys/syscall.h>
+ #endif
+
++#ifdef __FreeBSD_kernel__
++#include <pthread_np.h>
++#endif
++
+ /****************************************************************************
+ * @@@ TODO @@@
+ *
+@@ -545,7 +549,7 @@
+ if ( 0 != err )
+ SAL_WARN("sal.osl", "pthread_setname_np failed with errno " << err);
+ #elif defined __FreeBSD_kernel__
+- pthread_setname_np( pthread_self(), name );
++ pthread_set_name_np( pthread_self(), name );
+ #elif defined MACOSX || defined IOS
+ pthread_setname_np( name );
+ #else
diff --git a/editors/libreoffice/files/patch-sc_source_filter_inc_orcusinterface.hxx b/editors/libreoffice/files/patch-sc_source_filter_inc_orcusinterface.hxx
deleted file mode 100644
index af9219970592..000000000000
--- a/editors/libreoffice/files/patch-sc_source_filter_inc_orcusinterface.hxx
+++ /dev/null
@@ -1,40 +0,0 @@
---- sc/source/filter/inc/orcusinterface.hxx.orig 2017-10-25 14:25:39 UTC
-+++ sc/source/filter/inc/orcusinterface.hxx
-@@ -183,7 +183,8 @@ class ScOrcusSheetProperties : public orcus::spreadshe
-
- virtual void set_row_hidden(orcus::spreadsheet::row_t row, bool hidden) override;
-
-- virtual void set_merge_cell_range(const char* p_range, size_t n_range) override;
-+
-+ virtual void set_merge_cell_range(const orcus::spreadsheet::range_t& range) override;
- };
-
- class ScOrcusSheet : public orcus::spreadsheet::iface::import_sheet
-@@ -243,6 +244,8 @@ class ScOrcusSheet : public orcus::spreadsheet::iface:
- orcus::spreadsheet::row_t row, orcus::spreadsheet::col_t col, orcus::spreadsheet::formula_grammar_t grammar,
- const char* p, size_t n, const char* p_range, size_t n_range) override;
-
-+ virtual orcus::spreadsheet::range_size_t get_sheet_size() const override;
-+
- SCTAB getIndex() const { return mnTab; }
- };
-
-@@ -418,7 +421,7 @@ class ScOrcusStyles : public orcus::spreadsheet::iface
- // border
-
- virtual void set_border_count(size_t n) override;
-- virtual void set_border_style(orcus::spreadsheet::border_direction_t dir, const char* s, size_t n) override;
-+
- virtual void set_border_style(orcus::spreadsheet::border_direction_t dir, orcus::spreadsheet::border_style_t style) override;
- virtual void set_border_color(orcus::spreadsheet::border_direction_t dir,
- orcus::spreadsheet::color_elem_t alpha,
-@@ -508,7 +511,8 @@ class ScOrcusFactory : public orcus::spreadsheet::ifac
- public:
- ScOrcusFactory(ScDocument& rDoc);
-
-- virtual orcus::spreadsheet::iface::import_sheet* append_sheet(const char *sheet_name, size_t sheet_name_length) override;
-+ virtual orcus::spreadsheet::iface::import_sheet* append_sheet(
-+ orcus::spreadsheet::sheet_t sheet_index, const char *sheet_name, size_t sheet_name_length) override;
- virtual orcus::spreadsheet::iface::import_sheet* get_sheet(const char *sheet_name, size_t sheet_name_length) override;
- virtual orcus::spreadsheet::iface::import_sheet* get_sheet(orcus::spreadsheet::sheet_t sheet_index) override;
- virtual orcus::spreadsheet::iface::import_global_settings* get_global_settings() override;
diff --git a/editors/libreoffice/files/patch-sc_source_filter_orcus_interface.cxx b/editors/libreoffice/files/patch-sc_source_filter_orcus_interface.cxx
deleted file mode 100644
index 5c96e9920629..000000000000
--- a/editors/libreoffice/files/patch-sc_source_filter_orcus_interface.cxx
+++ /dev/null
@@ -1,59 +0,0 @@
---- sc/source/filter/orcus/interface.cxx.orig 2017-10-25 14:25:39 UTC
-+++ sc/source/filter/orcus/interface.cxx
-@@ -84,7 +84,8 @@ ScOrcusFactory::ScOrcusFactory(ScDocument& rDoc) :
- maStyles(rDoc),
- mnProgress(0) {}
-
--orcus::spreadsheet::iface::import_sheet* ScOrcusFactory::append_sheet(const char* sheet_name, size_t sheet_name_length)
-+orcus::spreadsheet::iface::import_sheet* ScOrcusFactory::append_sheet(
-+ orcus::spreadsheet::sheet_t /*sheet_index*/, const char* sheet_name, size_t sheet_name_length)
- {
- OUString aTabName(sheet_name, sheet_name_length, RTL_TEXTENCODING_UTF8);
- if (!maDoc.appendSheet(aTabName))
-@@ -296,7 +297,7 @@ void ScOrcusSheetProperties::set_row_hidden(os::row_t
- mrDoc.getDoc().SetRowHidden(row, row, mnTab, hidden);
- }
-
--void ScOrcusSheetProperties::set_merge_cell_range(const char* /*p_range*/, size_t /*n_range*/)
-+void ScOrcusSheetProperties::set_merge_cell_range(const orcus::spreadsheet::range_t& /*range*/)
- {
- }
-
-@@ -576,6 +577,9 @@ formula::FormulaGrammar::Grammar getCalcGrammarFromOrc
- case orcus::spreadsheet::formula_grammar_t::gnumeric:
- eGrammar = formula::FormulaGrammar::GRAM_ENGLISH_XL_A1;
- break;
-+ case orcus::spreadsheet::formula_grammar_t::xls_xml:
-+ eGrammar = formula::FormulaGrammar::GRAM_ENGLISH_XL_R1C1;
-+ break;
- case orcus::spreadsheet::formula_grammar_t::unknown:
- break;
- }
-@@ -693,6 +697,15 @@ void ScOrcusSheet::set_array_formula(
- {
- }
-
-+orcus::spreadsheet::range_size_t ScOrcusSheet::get_sheet_size() const
-+{
-+ orcus::spreadsheet::range_size_t ret;
-+ ret.rows = MAXROWCOUNT;
-+ ret.columns = MAXCOLCOUNT;
-+
-+ return ret;
-+}
-+
- ScOrcusSharedStrings::ScOrcusSharedStrings(ScOrcusFactory& rFactory) :
- mrFactory(rFactory) {}
-
-@@ -1281,11 +1294,6 @@ size_t ScOrcusStyles::commit_fill()
- void ScOrcusStyles::set_border_count(size_t /*n*/)
- {
- // needed at all?
--}
--
--void ScOrcusStyles::set_border_style(orcus::spreadsheet::border_direction_t /*dir*/, const char* /*s*/, size_t /*n*/)
--{
-- // implement later
- }
-
- void ScOrcusStyles::set_border_style(
diff --git a/editors/libreoffice/files/patch-sc_source_ui_docshell_datastream.cxx b/editors/libreoffice/files/patch-sc_source_ui_docshell_datastream.cxx
deleted file mode 100644
index 97288ff8514d..000000000000
--- a/editors/libreoffice/files/patch-sc_source_ui_docshell_datastream.cxx
+++ /dev/null
@@ -1,11 +0,0 @@
---- sc/source/ui/docshell/datastream.cxx.orig 2017-10-25 14:25:39 UTC
-+++ sc/source/ui/docshell/datastream.cxx
-@@ -84,7 +84,7 @@ class CSVHandler (public)
- static void begin_row() {}
- static void end_row() {}
-
-- void cell(const char* p, size_t n)
-+ void cell(const char* p, size_t n, bool /*transient*/)
- {
- if (mnCols >= mnColCount)
- return;
diff --git a/editors/libreoffice/files/patch-sfx2_source_control_emojiview.cxx b/editors/libreoffice/files/patch-sfx2_source_control_emojiview.cxx
deleted file mode 100644
index 7598b2b4208a..000000000000
--- a/editors/libreoffice/files/patch-sfx2_source_control_emojiview.cxx
+++ /dev/null
@@ -1,26 +0,0 @@
---- sfx2/source/control/emojiview.cxx.orig 2017-10-25 14:25:39 UTC
-+++ sfx2/source/control/emojiview.cxx
-@@ -104,12 +104,12 @@ void EmojiView::Populate()
- }
-
- // TODO::populate view using the orcus json parser
-- using node = orcus::json_document_tree::node;
-+ using node = orcus::json::node;
-
- // default json config
- orcus::json_config config;
-
-- orcus::json_document_tree aEmojiInfo;
-+ orcus::json::document_tree aEmojiInfo;
-
- // Load JSON string into a document tree.
- aEmojiInfo.load(msJSONData, config);
-@@ -122,7 +122,7 @@ void EmojiView::Populate()
- orcus::pstring key = *it;
- node value = root.child(key);
-
-- if(value.type() == orcus::json_node_t::object)
-+ if(value.type() == orcus::json::node_t::object)
- {
- // iterate each element to get the keys
- std::vector<orcus::pstring> aEmojiParams = value.keys();
diff --git a/editors/libreoffice/files/patch-shell_source_unix_exec_shellexec.cxx b/editors/libreoffice/files/patch-shell_source_unix_exec_shellexec.cxx
index a52189df87db..3c8a62b6a069 100644
--- a/editors/libreoffice/files/patch-shell_source_unix_exec_shellexec.cxx
+++ b/editors/libreoffice/files/patch-shell_source_unix_exec_shellexec.cxx
@@ -1,11 +1,11 @@
---- shell/source/unix/exec/shellexec.cxx.orig 2017-01-12 00:54:33 UTC
-+++ shell/source/unix/exec/shellexec.cxx
-@@ -157,7 +157,7 @@ void SAL_CALL ShellExec::execute( const
- if (std::getenv("LIBO_FLATPAK") != nullptr) {
- aBuffer.append("/app/bin/xdg-open");
- } else {
-- aBuffer.append("/usr/bin/xdg-open");
-+ aBuffer.append("%%LOCALBASE%%/bin/xdg-open");
- }
+--- shell/source/unix/exec/shellexec.cxx.orig 2017-12-08 02:26:19.000000000 +0300
++++ shell/source/unix/exec/shellexec.cxx 2017-12-12 15:51:21.551684000 +0300
+@@ -145,7 +145,7 @@
+ aBuffer.append("open --");
+ #else
+ // Just use xdg-open on non-Mac
+- aBuffer.append("/usr/bin/xdg-open");
++ aBuffer.append("%%LOCALBASE%%/bin/xdg-open");
#endif
aBuffer.append(" ");
+ escapeForShell(aBuffer, OUStringToOString(aURL, osl_getThreadTextEncoding()));
diff --git a/editors/libreoffice/files/patch-sysui_desktop_share_create_tree.sh b/editors/libreoffice/files/patch-sysui_desktop_share_create_tree.sh
new file mode 100644
index 000000000000..3d5edd0c410a
--- /dev/null
+++ b/editors/libreoffice/files/patch-sysui_desktop_share_create_tree.sh
@@ -0,0 +1,20 @@
+--- sysui/desktop/share/create_tree.sh.orig 2018-03-16 00:33:44.202900000 +0800
++++ sysui/desktop/share/create_tree.sh 2018-03-16 01:10:52.600520000 +0800
+@@ -58,7 +58,7 @@
+ office_root=${office_prefix}/${PREFIX}
+
+ #this symlink is needed to have the API boostrap functions running right
+-ln -sf "${office_root}/program/soffice" "${DESTDIR}/${PREFIXDIR}/bin/${PREFIX}"
++ln -sf "../lib/libreoffice/program/soffice" "${DESTDIR}/${PREFIXDIR}/bin/${PREFIX}"
+
+ if test "${PREFIX}" != libreoffice${PRODUCTVERSION} -a "${PREFIX}" != libreofficedev${PRODUCTVERSION} ; then
+ # compat symlinks
+@@ -74,7 +74,7 @@
+
+ mkdir -p "${DESTDIR}/${PREFIXDIR}/share/applications"
+ for i in `cat launcherlist`; do
+- ln -sf "${office_root}/share/xdg/${i}" "${DESTDIR}/${PREFIXDIR}/share/applications/${PREFIX}-${i}"
++ ln -sf "../../lib/libreoffice/share/xdg/${i}" "${DESTDIR}/${PREFIXDIR}/share/applications/${PREFIX}-${i}"
+ done
+
+ mkdir -p "${DESTDIR}/${PREFIXDIR}/share/appdata"
diff --git a/editors/libreoffice/files/patch-vcl_CppunitTest__vcl__wmf__test.mk b/editors/libreoffice/files/patch-vcl_CppunitTest__vcl__wmf__test.mk
deleted file mode 100644
index 7483c246197d..000000000000
--- a/editors/libreoffice/files/patch-vcl_CppunitTest__vcl__wmf__test.mk
+++ /dev/null
@@ -1,15 +0,0 @@
---- vcl/CppunitTest_vcl_wmf_test.mk.orig 2017-05-03 16:46:29 UTC
-+++ vcl/CppunitTest_vcl_wmf_test.mk
-@@ -131,10 +131,9 @@ $(eval $(call gb_CppunitTest_use_externals,vcl_wmf_tes
- ))
- endif
- else
--ifeq ($(OS),LINUX)
-+ifeq ($(OS), $(filter LINUX %BSD, $(OS)))
- $(eval $(call gb_CppunitTest_add_libs,vcl_wmf_test,\
-- -lm \
-- -ldl \
-+ -lm $(DLOPEN_LIBS) \
- -lpthread \
- -lGL \
- -lX11 \
diff --git a/editors/libreoffice/files/patch-vcl_Executable__visualbackendtest.mk b/editors/libreoffice/files/patch-vcl_Executable__visualbackendtest.mk
index ffacbf954b2d..201a39f53780 100644
--- a/editors/libreoffice/files/patch-vcl_Executable__visualbackendtest.mk
+++ b/editors/libreoffice/files/patch-vcl_Executable__visualbackendtest.mk
@@ -11,9 +11,7 @@
- -ldl \
+ -lm $(DLOPEN_LIBS) \
-lpthread \
-- -lGL \
- -lX11 \
-+ -lGL \
+ -lX11 \
))
diff --git a/editors/libreoffice/files/patch-vcl_Library__vcl.mk b/editors/libreoffice/files/patch-vcl_Library__vcl.mk
deleted file mode 100644
index b41d223e9afb..000000000000
--- a/editors/libreoffice/files/patch-vcl_Library__vcl.mk
+++ /dev/null
@@ -1,20 +0,0 @@
---- vcl/Library_vcl.mk.orig 2017-05-03 16:46:29 UTC
-+++ vcl/Library_vcl.mk
-@@ -643,13 +643,12 @@ else
- vcl/source/opengl/OpenGLHelper \
- vcl/source/window/openglwin \
- ))
--ifeq ($(OS),LINUX)
-+ifeq ($(OS), $(filter LINUX %BSD, $(OS)))
- $(eval $(call gb_Library_add_libs,vcl,\
-- -lm \
-- -ldl \
-+ -lm $(DLOPEN_LIBS) \
- -lpthread \
-- -lGL \
-- -lX11 \
-+ -lGL \
-+ -lX11 \
- ))
- endif
- endif
diff --git a/editors/libreoffice/files/patch-vcl_source_app_svapp.cxx b/editors/libreoffice/files/patch-vcl_source_app_svapp.cxx
index 663380e23759..0484b558c401 100644
--- a/editors/libreoffice/files/patch-vcl_source_app_svapp.cxx
+++ b/editors/libreoffice/files/patch-vcl_source_app_svapp.cxx
@@ -1,11 +1,11 @@
---- vcl/source/app/svapp.cxx.orig 2017-10-25 14:25:39 UTC
-+++ vcl/source/app/svapp.cxx
-@@ -1212,7 +1212,7 @@ OUString Application::GetHWOSConfInfo()
- aDetails.append( VclResId(SV_APP_DEFAULT).toString() );
+--- vcl/source/app/svapp.cxx.orig 2018-03-02 19:30:13.692825000 +0800
++++ vcl/source/app/svapp.cxx 2018-03-02 19:30:48.236688000 +0800
+@@ -1153,7 +1153,7 @@
+ aDetails.append( VclResId(SV_APP_DEFAULT) );
aDetails.append( "; " );
-#ifdef LINUX
+#if defined UNX && !defined MACOSX && !defined IOS && !defined ANDROID
// Only linux has different backends, so don't show blank for others.
- aDetails.append( VclResId(SV_APP_VCLBACKEND).toString() );
+ aDetails.append( SV_APP_VCLBACKEND );
aDetails.append( GetToolkitName() );
diff --git a/editors/libreoffice/files/patch-vcl_unx_gtk_fpicker_SalGtkFilePicker.cxx b/editors/libreoffice/files/patch-vcl_unx_gtk_fpicker_SalGtkFilePicker.cxx
deleted file mode 100644
index dc2ea8a099df..000000000000
--- a/editors/libreoffice/files/patch-vcl_unx_gtk_fpicker_SalGtkFilePicker.cxx
+++ /dev/null
@@ -1,18 +0,0 @@
---- vcl/unx/gtk/fpicker/SalGtkFilePicker.cxx.orig 2017-01-12 00:54:33 UTC
-+++ vcl/unx/gtk/fpicker/SalGtkFilePicker.cxx
-@@ -436,10 +436,13 @@ dialog_remove_buttons( GtkDialog *pDialo
- {
- g_return_if_fail( GTK_IS_DIALOG( pDialog ) );
-
--#if GTK_CHECK_VERSION(3,0,0)
- #if GTK_CHECK_VERSION(3,12,0)
-- dialog_remove_buttons(gtk_dialog_get_header_bar(pDialog));
-+ GtkWidget *pHeaderBar = gtk_dialog_get_header_bar( pDialog );
-+ if( pHeaderBar != nullptr )
-+ dialog_remove_buttons( pHeaderBar );
-+ else
- #endif
-+#if GTK_CHECK_VERSION(2,14,0)
- dialog_remove_buttons(gtk_dialog_get_action_area(pDialog));
- #else
- dialog_remove_buttons(pDialog->action_area);