aboutsummaryrefslogtreecommitdiff
path: root/editors/libreoffice6/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'editors/libreoffice6/Makefile')
-rw-r--r--editors/libreoffice6/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/editors/libreoffice6/Makefile b/editors/libreoffice6/Makefile
index 5bdef7e22e60..e3439973de12 100644
--- a/editors/libreoffice6/Makefile
+++ b/editors/libreoffice6/Makefile
@@ -120,10 +120,12 @@ USES= autoreconf:build bison compiler:c++14-lang cpe desktop-file-utils \
pkgconfig python shebangfix shared-mime-info ssl tar:xz xorg
OPTIONS_DEFINE= CUPS DOCS GNOME GTK3 I18N JAVA KF5 MMEDIA PGSQL QT5 SDK TEST WEBDAV
-OPTIONS_DEFAULT= CUPS MMEDIA
-OPTIONS_DEFAULT_FreeBSD_12= QT5
-OPTIONS_DEFAULT_FreeBSD_13= QT5
-OPTIONS_DEFAULT+= ${OPTIONS_DEFAULT_${OPSYS}_${OSREL:R}}
+OPTIONS_DEFAULT= CUPS MMEDIA QT5
+
+.if !defined(DEFAULT_VERSIONS) || ! ${DEFAULT_VERSIONS:Mssl=*}
+# Blocked by net/qt5-network: cannot use QT5 with default OpenSSL
+OPTIONS_EXCLUDE_FreeBSD_11+= QT5
+.endif
GTK3_DESC= GTK+ 3 GUI toolkit support (incomplete visual style)
I18N_DESC= Build i18n resources