aboutsummaryrefslogtreecommitdiff
path: root/editors/libreoffice
diff options
context:
space:
mode:
Diffstat (limited to 'editors/libreoffice')
-rw-r--r--editors/libreoffice/Makefile4
-rw-r--r--editors/libreoffice/files/patch-clone__extensions__sdext__source__pdfimport__xpdfwrapper__pdfioutdev_gpl.cxx11
-rw-r--r--editors/libreoffice/files/patch-clone__extensions__sdext__source__pdfimport__xpdfwrapper__pdfioutdev_gpl.hxx22
3 files changed, 35 insertions, 2 deletions
diff --git a/editors/libreoffice/Makefile b/editors/libreoffice/Makefile
index ae59ed24b2d1..5588e76ac2c5 100644
--- a/editors/libreoffice/Makefile
+++ b/editors/libreoffice/Makefile
@@ -7,7 +7,7 @@
PORTNAME= libreoffice
PORTVERSION= 3.4.3
-PORTREVISION= 1
+PORTREVISION= 2
LOVERSION= ${PORTVERSION}.2
CATEGORIES= editors
MASTER_SITES= http://ftp.osuosl.org/pub/tdf/libreoffice/src/${PORTVERSION}/ \
@@ -91,7 +91,7 @@ LIB_DEPENDS= cairo.2:${PORTSDIR}/graphics/cairo \
hunspell-1.3.0:${PORTSDIR}/textproc/hunspell \
mythes-1.2.0:${PORTSDIR}/textproc/mythes \
hyphen.2:${PORTSDIR}/textproc/hyphen \
- poppler.13:${PORTSDIR}/graphics/poppler \
+ poppler-glib.8:${PORTSDIR}/graphics/poppler-glib \
wpd-0.9.9:${PORTSDIR}/textproc/libwpd \
wpg-0.2.2:${PORTSDIR}/graphics/libwpg \
wps-0.2.2:${PORTSDIR}/textproc/libwps \
diff --git a/editors/libreoffice/files/patch-clone__extensions__sdext__source__pdfimport__xpdfwrapper__pdfioutdev_gpl.cxx b/editors/libreoffice/files/patch-clone__extensions__sdext__source__pdfimport__xpdfwrapper__pdfioutdev_gpl.cxx
new file mode 100644
index 000000000000..59a896b3d577
--- /dev/null
+++ b/editors/libreoffice/files/patch-clone__extensions__sdext__source__pdfimport__xpdfwrapper__pdfioutdev_gpl.cxx
@@ -0,0 +1,11 @@
+--- clone/extensions/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx.orig 2011-10-26 13:23:40.000000000 +0000
++++ clone/extensions/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx 2011-10-26 13:23:57.000000000 +0000
+@@ -489,7 +489,7 @@ void PDFOutDev::endPage()
+ printf("endPage\n");
+ }
+
+-void PDFOutDev::processLink(Link* link, Catalog*)
++void PDFOutDev::processLink(AnnotLink* link, Catalog*)
+ {
+ assert(link);
+
diff --git a/editors/libreoffice/files/patch-clone__extensions__sdext__source__pdfimport__xpdfwrapper__pdfioutdev_gpl.hxx b/editors/libreoffice/files/patch-clone__extensions__sdext__source__pdfimport__xpdfwrapper__pdfioutdev_gpl.hxx
new file mode 100644
index 000000000000..b891f3d08615
--- /dev/null
+++ b/editors/libreoffice/files/patch-clone__extensions__sdext__source__pdfimport__xpdfwrapper__pdfioutdev_gpl.hxx
@@ -0,0 +1,22 @@
+--- clone/extensions/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx.orig 2011-05-19 09:14:21.000000000 +0000
++++ clone/extensions/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx 2011-10-29 20:19:33.000000000 +0000
+@@ -65,7 +65,10 @@ class GfxPath;
+ class GfxFont;
+ class PDFDoc;
+ #ifndef SYSTEM_POPPLER
++#define POPPLER_CHECK_VERSION(major,minor,micro) (0)
+ typedef GString GooString;
++#else
++#include <glib/poppler-features.h>
+ #endif
+
+ namespace pdfi
+@@ -195,7 +198,7 @@ namespace pdfi
+ // virtual void cvtUserToDev(double ux, double uy, int *dx, int *dy);
+
+ //----- link borders
+- virtual void processLink(Link *link, Catalog *catalog);
++ virtual void processLink(AnnotLink *link, Catalog *catalog);
+
+ //----- save/restore graphics state
+ virtual void saveState(GfxState *state);