aboutsummaryrefslogtreecommitdiff
path: root/editors/nedit/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'editors/nedit/Makefile')
-rw-r--r--editors/nedit/Makefile18
1 files changed, 8 insertions, 10 deletions
diff --git a/editors/nedit/Makefile b/editors/nedit/Makefile
index 711e52d10b4d..637065fa401a 100644
--- a/editors/nedit/Makefile
+++ b/editors/nedit/Makefile
@@ -2,29 +2,27 @@
# $FreeBSD$
PORTNAME= nedit
-PORTVERSION= 5.6
-PORTREVISION= 1
+PORTVERSION= 5.7
CATEGORIES= editors
-MASTER_SITES= http://people.freebsd.org/~deischen/distfiles/ \
- SF/${PORTNAME}/${PORTNAME}-source \
- ftp://ftp.nluug.nl/pub/editors/NEdit/contrib/misc/
-DISTFILES= nedit-5.6a-src.tar.gz nedit.app-defaults
-EXTRACT_ONLY= nedit-5.6a-src.tar.gz
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-source
+DISTFILES= nedit-${PORTVERSION}-src.tar.gz \
+ nedit.app-defaults
+EXTRACT_ONLY= nedit-${PORTVERSION}-src.tar.gz
MAINTAINER= swills@FreeBSD.org
COMMENT= X11/Motif GUI text editor for programs and plain text files
LICENSE= GPLv1
-USES= motif perl5
+USES= motif perl5 xorg
USE_PERL5= build
ALL_TARGET= freebsd
PLIST_FILES= bin/nclient \
bin/nedit \
+ lib/X11/app-defaults/NEdit.ad \
man/man1/nclient.1.gz \
- man/man1/nedit.1.gz \
- lib/X11/app-defaults/NEdit.ad
+ man/man1/nedit.1.gz
post-extract:
${CP} ${DISTDIR}/nedit.app-defaults ${WRKSRC}/NEdit.ad