aboutsummaryrefslogtreecommitdiff
path: root/editors/ooo-build/files
diff options
context:
space:
mode:
Diffstat (limited to 'editors/ooo-build/files')
-rw-r--r--editors/ooo-build/files/cairo-patch45
-rw-r--r--editors/ooo-build/files/ooo-build-patch44
-rw-r--r--editors/ooo-build/files/ooo-build-patch-devel60
-rw-r--r--editors/ooo-build/files/patch-i18npool8
4 files changed, 157 insertions, 0 deletions
diff --git a/editors/ooo-build/files/cairo-patch b/editors/ooo-build/files/cairo-patch
new file mode 100644
index 000000000000..00085a0cd537
--- /dev/null
+++ b/editors/ooo-build/files/cairo-patch
@@ -0,0 +1,45 @@
+--- cairo/makefile.mk Wed Nov 2 14:03:55 2005
++++ cairo/makefile.mk Wed Nov 2 14:00:02 2005
+@@ -81,6 +81,7 @@
+
+ TARFILE_NAME=cairo-1.0.2
+
++PATCH_FILE_NAME=$(TARFILE_NAME).patch
+ CONFIGURE_DIR=
+
+ CONFIGURE_ACTION=./configure
+
+--- /dev/null Wed Nov 2 14:36:58 2005
++++ cairo/cairo-1.0.2.patch Wed Nov 2 14:01:33 2005
+@@ -0,0 +1,31 @@
++*** misc/cairo-1.0.2/ltmain.sh 2004-08-26 08:00:15.000000000 +0200
++--- misc/build/cairo-1.0.2/ltmain.sh 2005-05-09 19:55:51.745319024 +0200
++***************
++*** 2994,3006 ****
++ ;;
++
++ freebsd-aout)
++! major=".$current"
++! versuffix=".$current.$revision";
++ ;;
++
++ freebsd-elf)
++! major=".$current"
++! versuffix=".$current";
++ ;;
++
++ irix | nonstopux)
++--- 2994,3006 ----
++ ;;
++
++ freebsd-aout)
++! major=.`expr $current - $age`
++! versuffix="$major.$age.$revision"
++ ;;
++
++ freebsd-elf)
++! major=.`expr $current - $age`
++! versuffix="$major.$age.$revision"
++ ;;
++
++ irix | nonstopux)
diff --git a/editors/ooo-build/files/ooo-build-patch b/editors/ooo-build/files/ooo-build-patch
new file mode 100644
index 000000000000..ed9a2dc3c6e8
--- /dev/null
+++ b/editors/ooo-build/files/ooo-build-patch
@@ -0,0 +1,44 @@
+gnu patch is gpatch for FreeBSD.
+--- patches/apply.pl Tue Nov 1 00:07:02 2005
++++ patches/apply.pl Tue Nov 1 00:07:32 2005
+@@ -473,7 +473,7 @@
+ my $ver_line;
+ my $is_old = 1;
+
+- open ($Patch, "patch --version|") || die "Can't run patch: $!";
++ open ($Patch, "gpatch --version|") || die "Can't run patch: $!";
+ $ver_line = <$Patch>;
+ $ver_line =~ m/\s+(\d+)\.(\d+)\.(\d+)/ || die "Can't get patch version\n";
+ if ($1 >= 2 && $2 >= 5 && $3 >= 9) {
+@@ -597,7 +597,7 @@
+ $applied_patches = $dest_dir.'/applied_patches';
+
+ $opts = join ' ', @arguments;
+- $base_cmd = "patch -l -p0 $opts -d $dest_dir";
++ $base_cmd = "gpatch -l -p0 $opts -d $dest_dir";
+ if (is_old_patch_version()) {
+ $base_cmd = 'sed \'s/^\(@.*\)\r$/\1/\' | ' . $base_cmd;
+ }
+
+--- patches/OOO_2_0/apply.orig Wed Nov 30 01:16:48 2005
++++ patches/OOO_2_0/apply Sun Dec 4 11:54:05 2005
+@@ -57,6 +57,8 @@
+ Gentoo64: GentooBase, 64bit
+ # Win32
+ Win32 : Win32Common, NovellOnly, NovellOnlyWin32
++# FreeBSD
++FreeBSD : LinuxCommon, NotDebian
+
+ # -------- [ Tag [ >= <tag> etc. ], ] patch sets --------
+
+@@ -495,7 +497,7 @@
+ # Fix missing __cxa_guard_acquire/__cxa_guard_release - #34676 (for FC3)
+ sal-cxa-guard.diff
+ # do not pack any potential .orig files with ppds
+-psprint_config-no-orig.diff
++#psprint_config-no-orig.diff #don't apply for FBSD patch (workaround)
+ # Fix ODK Java bits
+ odk-java-wizpanel.diff
+ # add possibility to set ARCH_FLAGS when building libnas
+
+
diff --git a/editors/ooo-build/files/ooo-build-patch-devel b/editors/ooo-build/files/ooo-build-patch-devel
new file mode 100644
index 000000000000..fa28f6b6238d
--- /dev/null
+++ b/editors/ooo-build/files/ooo-build-patch-devel
@@ -0,0 +1,60 @@
+gnu patch is gpatch for FreeBSD.
+--- patches/apply.pl Tue Nov 1 00:07:02 2005
++++ patches/apply.pl Tue Nov 1 00:07:32 2005
+@@ -473,7 +473,7 @@
+ my $ver_line;
+ my $is_old = 1;
+
+- open ($Patch, "patch --version|") || die "Can't run patch: $!";
++ open ($Patch, "gpatch --version|") || die "Can't run patch: $!";
+ $ver_line = <$Patch>;
+ $ver_line =~ m/\s+(\d+)\.(\d+)\.(\d+)/ || die "Can't get patch version\n";
+ if ($1 >= 2 && $2 >= 5 && $3 >= 9) {
+@@ -597,7 +597,7 @@
+ $applied_patches = $dest_dir.'/applied_patches';
+
+ $opts = join ' ', @arguments;
+- $base_cmd = "patch -l -p0 $opts -d $dest_dir";
++ $base_cmd = "gpatch -l -p0 $opts -d $dest_dir";
+ if (is_old_patch_version()) {
+ $base_cmd = 'sed \'s/^\(@.*\)\r$/\1/\' | ' . $base_cmd;
+ }
+
+--- patches/src680/apply.orig Wed Nov 30 18:02:19 2005
++++ patches/src680/apply Sat Dec 3 20:05:50 2005
+@@ -64,6 +64,8 @@
+ Gentoo64: GentooBase, 64bit
+ # Win32
+ Win32 : Win32Common, NovellOnly, NovellOnlyWin32
++# FreeBSD
++FreeBSD : LinuxCommon, NotDebian
+
+ # -------- [ Tag [ >= <tag> etc. ], ] patch sets --------
+
+@@ -80,7 +82,7 @@
+
+ [ TemporaryHacks == src680-m140 ]
+ # silly snafu.
+-buildfix-svtools-m140.diff
++# buildfix-svtools-m140.diff # not compatible with my checkout(master fixed)
+
+ [ TemporaryHacks ]
+ # adding glib-2.0 and ORBit-2.0 to pkgconfig modules; i#47923
+@@ -338,7 +340,7 @@
+
+ [ Shrink ]
+ # strip 450k of .comment sections - i#57063
+-size-strip.diff
++# size-strip.diff #break the build of FBSD see my comment on #i57063#
+ # save 1.7Mb of (shared) memory for non-asian locales
+ cws-i18nshrink.diff
+
+@@ -587,7 +589,7 @@
+ # Fix missing __cxa_guard_acquire/__cxa_guard_release - #34676 (for FC3)
+ sal-cxa-guard.diff
+ # do not pack any potential .orig files with ppds
+-psprint_config-no-orig.diff
++#psprint_config-no-orig.diff #don't apply for FBSD patch (workaround)
+ # Fix ODK Java bits
+ odk-java-wizpanel.diff
+ # add possibility to set ARCH_FLAGS when building libnas
diff --git a/editors/ooo-build/files/patch-i18npool b/editors/ooo-build/files/patch-i18npool
new file mode 100644
index 000000000000..d411310e9ba3
--- /dev/null
+++ b/editors/ooo-build/files/patch-i18npool
@@ -0,0 +1,8 @@
+--- i18npool/prj/build.lst~ Wed Nov 2 10:54:24 2005
++++ i18npool/prj/build.lst Wed Nov 2 14:41:04 2005
+@@ -1,4 +1,4 @@
+-inp i18npool : bridges sax stoc comphelper tools ICU:icu i18nutil regexp NULL
++inp i18npool : bridges sax stoc comphelper tools icu i18nutil regexp NULL
+ inp i18npool usr1 - all inp_mkout NULL
+ inp i18npool\source\unotypes nmake - all inp_utypes NULL
+ inp i18npool\source\registerservices nmake - all inp_rserv inp_utypes NULL