aboutsummaryrefslogtreecommitdiff
path: root/editors/openoffice-1.1-devel/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'editors/openoffice-1.1-devel/Makefile')
-rw-r--r--editors/openoffice-1.1-devel/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/editors/openoffice-1.1-devel/Makefile b/editors/openoffice-1.1-devel/Makefile
index 8c021e21addf..2508633456ed 100644
--- a/editors/openoffice-1.1-devel/Makefile
+++ b/editors/openoffice-1.1-devel/Makefile
@@ -134,7 +134,7 @@ TCSH?= /bin/tcsh
ZIP?= ${PREFIX}/bin/zip
UNZIP?= ${PREFIX}/bin/unzip
PKGMESSAGE= ${WRKDIR}/pkg-message
-NUMOFPROCESSES?= 8
+NUMOFPROCESSES?= 4
.if !defined(DISPLAY)
DISPLAYHACK=localhost:1001
@@ -207,11 +207,11 @@ do-build:
#
${X11BASE}/bin/Xvfb :1001 -screen 0 800x600x24 > /dev/null 2>&1 & ${ECHO} $$! > ${WRKDIR}/.Xvfb.pid
@sleep 5
- @cd ${WRKSRC} ; DISPLAY=${DISPLAYHACK} ; ${TCSH} -c 'source FreeBSDEnv.Set ; dmake -P${NUMOFPROCESSES}'
+ @cd ${WRKSRC} ; DISPLAY=${DISPLAYHACK} ; ${TCSH} -c 'source FreeBSDEnv.Set ; cd instsetoo ; build.pl -P${NUMOFPROCESSES} --all'
@-${CAT} ${WRKDIR}/.Xvfb.pid | ${XARGS} kill
@${RM} -f ${WRKDIR}/.Xvfb.pid
.else
- @cd ${WRKSRC} ; DISPLAY=${DISPLAY} ; ${TCSH} -c 'source FreeBSDEnv.Set ; dmake -P${NUMOFPROCESSES}'
+ @cd ${WRKSRC} ; DISPLAY=${DISPLAY} ; ${TCSH} -c 'source FreeBSDEnv.Set ; cd instsetoo ; build.pl -P${NUMOFPROCESSES} --all'
.endif
do-install: