aboutsummaryrefslogtreecommitdiff
path: root/editors/openoffice-1.1/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'editors/openoffice-1.1/Makefile')
-rw-r--r--editors/openoffice-1.1/Makefile12
1 files changed, 11 insertions, 1 deletions
diff --git a/editors/openoffice-1.1/Makefile b/editors/openoffice-1.1/Makefile
index 64c08be99f88..6f740924c399 100644
--- a/editors/openoffice-1.1/Makefile
+++ b/editors/openoffice-1.1/Makefile
@@ -8,7 +8,8 @@
PORTNAME= openoffice
PORTVERSION= 644
CATEGORIES+= editors
-MASTER_SITES+= http://ny1.mirror.openoffice.org/developer/%SUBDIR%/ \
+MASTER_SITES+= http://projects.imp.ch/openoffice/%SUBDIR%/ \
+ http://ny1.mirror.openoffice.org/developer/%SUBDIR%/ \
http://ftp.gwdg.de/pub/misc/openoffice/developer/%SUBDIR%/ \
${MASTER_SITE_RINGSERVER:S,developer/%SUBDIR%,misc/openoffice/&,} \
ftp://ftp.cs.man.ac.uk/pub/toby/gpc/:gpc \
@@ -567,4 +568,13 @@ package-rename:
${WRKDIR}/../OOo_${PORTVERSION}_${OPSYS}Intel_install_${LANG_PKGNAME}.tbz2
.endif
+update:
+ @${MAKE} fetch
+ @${MAKE} extract
+ @cd ${WRKSRC}/.. && for dir in *; do \
+ if [ -d $$dir ]; then \
+ cd $$dir; cvs update -d; cd ..; \
+ fi \
+ done
+
.include <bsd.port.post.mk>