aboutsummaryrefslogtreecommitdiff
path: root/editors/openoffice-3-devel/files/Makefile.knobs
diff options
context:
space:
mode:
Diffstat (limited to 'editors/openoffice-3-devel/files/Makefile.knobs')
-rw-r--r--editors/openoffice-3-devel/files/Makefile.knobs17
1 files changed, 9 insertions, 8 deletions
diff --git a/editors/openoffice-3-devel/files/Makefile.knobs b/editors/openoffice-3-devel/files/Makefile.knobs
index 231af9477271..deb2059d1b29 100644
--- a/editors/openoffice-3-devel/files/Makefile.knobs
+++ b/editors/openoffice-3-devel/files/Makefile.knobs
@@ -2,10 +2,11 @@
# Whom: Maho Nakata <maho@FreeBSD.org>
# $FreeBSD$
-.if !defined(WITH_GNUGCJ)
CONFIGURE_ARGS+= --with-jdk-home="${JAVA_HOME}" --with-ant-home="${LOCALBASE}/share/java/apache-ant"
-.else
-CONFIGURE_ARGS+= --with-jdk-home="${LOCALBASE}/lib/jvm/java-gcj41" --with-java=gij --with-ant-home="${WRKDIR}/apache-ant-${ANT_VERSION}"
+
+.if defined(WITH_VBA)
+CONFIGURE_ARGS+= --enable-vba --with-vba-package-format="builtin"
+EXTRA_PATCHES+= ${FILESDIR}/cws-npower7.diff
.endif
.if defined(WITH_KDE)
@@ -92,6 +93,11 @@ pre-fetch:
@${ECHO} "You can compile OOo without gnome VFS support with"
@${ECHO} "make -DWITHOUT_GNOMEVFS"
.endif
+.if !defined(WITH_VBA)
+ @${ECHO}
+ @${ECHO} "You can compile OOo with VBA support with"
+ @${ECHO} "make -DWITH_VBA"
+.endif
.if !defined(WITH_SYSTEM_FREETYPE)
@${ECHO}
@${ECHO} "You can compile OOo with freetype2 from ports with"
@@ -120,11 +126,6 @@ pre-fetch:
@${ECHO} "zh-CN zh-TW zu"
@${ECHO} "Default: en-US"
.endif
-.if !defined(WITH_GNUGCJ)
- @${ECHO}
- @${ECHO} "You can compile OOo with GNU GCJ instead of SUN's JDK with"
- @${ECHO} "make -DWITH_GNUGCJ"
-.endif
.if !defined(WITH_CUPS)
@${ECHO}
@${ECHO} "You can compile OOo with CUPS support with"