aboutsummaryrefslogtreecommitdiff
path: root/editors/openoffice.org-2.0-devel/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'editors/openoffice.org-2.0-devel/Makefile')
-rw-r--r--editors/openoffice.org-2.0-devel/Makefile13
1 files changed, 9 insertions, 4 deletions
diff --git a/editors/openoffice.org-2.0-devel/Makefile b/editors/openoffice.org-2.0-devel/Makefile
index 32cbfe846a3b..e492019e2bb2 100644
--- a/editors/openoffice.org-2.0-devel/Makefile
+++ b/editors/openoffice.org-2.0-devel/Makefile
@@ -58,8 +58,8 @@ IGNORE= Install lang/perl5.8 then try again
CODELINE= 680
RELEASE_NR= 1.9
-MILESTONE= 130
-SNAPDATE= 20050916
+MILESTONE= 134
+SNAPDATE= 20051014
INSTALLATION_BASEDIR= openoffice.org${RELEASE_NR}m${MILESTONE}
EXECBASE= openoffice.org-${RELEASE_NR}m${MILESTONE}
DIST_SUBDIR= openoffice.org2.0
@@ -171,11 +171,11 @@ do-build:
.endif
do-install:
- @cd ${WRKSRC}/instsetoo_native/unxfbsd.pro/OpenOffice/install/${LOCALIZED_LANG}/freebsd-*/ ; ${LS} *.tgz > ${WRKDIR}/INSTALLFILES
+ @cd ${WRKSRC}/instsetoo_native/unxfbsd.pro/OpenOffice/bsd/install/${LOCALIZED_LANG}/freebsd-*/ ; ${LS} *.tgz > ${WRKDIR}/INSTALLFILES
@${RM} -Rf ${WRKDIR}/tmp
@${MKDIR} ${WRKDIR}/tmp
@for i in `${CAT} ${WRKDIR}/INSTALLFILES`; do \
- ${CP} ${WRKSRC}/instsetoo_native/unxfbsd.pro/OpenOffice/install/${LOCALIZED_LANG}/freebsd-*/$$i ${WRKDIR}/tmp ; \
+ ${CP} ${WRKSRC}/instsetoo_native/unxfbsd.pro/OpenOffice/bsd/install/${LOCALIZED_LANG}/freebsd-*/$$i ${WRKDIR}/tmp ; \
cd ${WRKDIR}/tmp ; ${TAR} xfz ${WRKDIR}/tmp/$$i ; \
done
@${MKDIR} ${PREFIX}/${INSTALLATION_BASEDIR}
@@ -200,6 +200,11 @@ post-install:
@${LN} -fs ${PREFIX}/bin/${EXECBASE} ${PREFIX}/bin/${EXECBASE}-simpress
@${LN} -fs ${PREFIX}/bin/${EXECBASE} ${PREFIX}/bin/${EXECBASE}-spadmin
@${LN} -fs ${PREFIX}/bin/${EXECBASE} ${PREFIX}/bin/${EXECBASE}-swriter
+# python post-install script start
+# consult instsetoo_native/inc_openoffice/unix/shellscripts_pyuno.txt
+ @cd ${PREFIX}/${INSTALLATION_BASEDIR}/program ; ${LN} -s python-core-2.3.4 ${PREFIX}/${INSTALLATION_BASEDIR}/program/python-core; ${LN} -s python.sh ${PREFIX}/${INSTALLATION_BASEDIR}/program/python
+ ${CHMOD} +x ${PREFIX}/${INSTALLATION_BASEDIR}/program/python-core-2.3.4/bin/python
+# python post-install script end
@${PRINTF} "bin/openoffice.org\n" > ${TMPPLIST}
@cd ${PREFIX} ; ${FIND} -s bin -type f | ${GREP} ${EXECBASE} >> ${TMPPLIST}
@cd ${PREFIX} ; ${FIND} -s bin -type l | ${GREP} ${EXECBASE} >> ${TMPPLIST}