aboutsummaryrefslogtreecommitdiff
path: root/editors/openoffice.org-3/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'editors/openoffice.org-3/Makefile')
-rw-r--r--editors/openoffice.org-3/Makefile6
1 files changed, 2 insertions, 4 deletions
diff --git a/editors/openoffice.org-3/Makefile b/editors/openoffice.org-3/Makefile
index fa4e3d167ad8..f34e9c250c84 100644
--- a/editors/openoffice.org-3/Makefile
+++ b/editors/openoffice.org-3/Makefile
@@ -255,10 +255,9 @@ post-install:
-e '/^Exec/s/printeradmin/spadmin/' \
${PREFIX}/${INSTALLATION_BASEDIR}/share/xdg/*.desktop
@${RM} ${PREFIX}/${INSTALLATION_BASEDIR}/share/xdg/*.desktop.bak
-.if defined(WITH_KDE)
@${LN} -sf ${PREFIX}/${INSTALLATION_BASEDIR}/share/xdg \
- ${PREFIX}/share/applnk/${EXECBASE}
- @${PRINTF} "share/applnk/${EXECBASE}\n" >> ${TMPPLIST}
+ ${PREFIX}/share/applications/${EXECBASE}
+ @${PRINTF} "share/applications/${EXECBASE}\n" >> ${TMPPLIST}
@for dir in `ls ${ICONS}/hicolor | ${GREP} -v CVS`; do \
for app in base calc draw impress math printeradmin writer; do \
if [ -r ${ICONS}/hicolor/$${dir}/apps/$${app}.png ]; then \
@@ -273,7 +272,6 @@ post-install:
${PRINTF} "share/icons/hicolor/$${dir}/mimetypes/$${file}\n" >> ${TMPPLIST} ; \
done ; \
done
-.endif
@cd ${PREFIX} ; ${FIND} -s bin -type f | ${GREP} ${EXECBASE} >> ${TMPPLIST}
@cd ${PREFIX} ; ${FIND} -s bin -type l | ${GREP} ${EXECBASE} >> ${TMPPLIST}
@cd ${PREFIX} ; ${FIND} -s ${INSTALLATION_BASEDIR} -type f >> ${TMPPLIST}