aboutsummaryrefslogtreecommitdiff
path: root/editors/p5-Vimana
diff options
context:
space:
mode:
Diffstat (limited to 'editors/p5-Vimana')
-rw-r--r--editors/p5-Vimana/Makefile44
-rw-r--r--editors/p5-Vimana/distinfo3
-rw-r--r--editors/p5-Vimana/pkg-descr8
-rw-r--r--editors/p5-Vimana/pkg-plist26
4 files changed, 81 insertions, 0 deletions
diff --git a/editors/p5-Vimana/Makefile b/editors/p5-Vimana/Makefile
new file mode 100644
index 000000000000..19d03f006005
--- /dev/null
+++ b/editors/p5-Vimana/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: p5-Vimana
+# Date created: 2009-08-25
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Vimana
+PORTVERSION= 0.09
+CATEGORIES= editors perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/C/CO/CORNELIUS
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Vim script manager
+
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+BUILD_DEPENDS= vim>=0:${PORTSDIR}/editors/vim \
+ p5-App-CLI>=0.08:${PORTSDIR}/devel/p5-App-CLI \
+ p5-Archive-Any>=0:${PORTSDIR}/archivers/p5-Archive-Any \
+ p5-Cache>=2.04:${PORTSDIR}/devel/p5-Cache \
+ p5-File-Copy-Recursive>=0.38:${PORTSDIR}/devel/p5-File-Copy-Recursive \
+ p5-File-Find-Rule>=0.30:${PORTSDIR}/devel/p5-File-Find-Rule \
+ p5-File-Path>=2.07:${PORTSDIR}/devel/p5-File-Path \
+ p5-File-Type>=0:${PORTSDIR}/devel/p5-File-Type \
+ p5-File-Which>=0:${PORTSDIR}/sysutils/p5-File-Which \
+ p5-URI>=1.37:${PORTSDIR}/net/p5-URI \
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
+ p5-Exporter-Lite>=0:${PORTSDIR}/devel/p5-Exporter-Lite
+
+PERL_CONFIGURE= yes
+
+MAN1= vimana.1
+MAN3= Vimana.3 \
+ Vimana::AutoInstall.3 \
+ Vimana::Command::Install.3 \
+ Vimana::Index.3 \
+ Vimana::Logger.3 \
+ Vimana::Manual.3 \
+ Vimana::PackageFile.3 \
+ Vimana::Util.3
+
+.include <bsd.port.mk>
diff --git a/editors/p5-Vimana/distinfo b/editors/p5-Vimana/distinfo
new file mode 100644
index 000000000000..1d5200035165
--- /dev/null
+++ b/editors/p5-Vimana/distinfo
@@ -0,0 +1,3 @@
+MD5 (Vimana-0.09.tar.gz) = d6d3ecd1715fab03cea28404e84e338d
+SHA256 (Vimana-0.09.tar.gz) = 0340e47cef495d0f3314eb08ba75fa832cdfc2fadcaaccab9c1e5a89c70c823a
+SIZE (Vimana-0.09.tar.gz) = 35406
diff --git a/editors/p5-Vimana/pkg-descr b/editors/p5-Vimana/pkg-descr
new file mode 100644
index 000000000000..7d1dc66283a7
--- /dev/null
+++ b/editors/p5-Vimana/pkg-descr
@@ -0,0 +1,8 @@
+Vimana is an easy to use system for searching, downloading, and
+installing vim scripts.
+
+Vimana provides a command-line interface much like the aptitude
+program on Debian Linux, for you to search, download, install, and
+upgrade scripts from http://www.vim.org/ (vimonline site).
+
+WWW: http://search.cpan.org/dist/Vimana/
diff --git a/editors/p5-Vimana/pkg-plist b/editors/p5-Vimana/pkg-plist
new file mode 100644
index 000000000000..d9996c06e9ef
--- /dev/null
+++ b/editors/p5-Vimana/pkg-plist
@@ -0,0 +1,26 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Vimana/.packlist
+%%SITE_PERL%%/Vimana.pm
+%%SITE_PERL%%/Vimana/AutoInstall.pm
+%%SITE_PERL%%/Vimana/Command.pm
+%%SITE_PERL%%/Vimana/Command/Download.pm
+%%SITE_PERL%%/Vimana/Command/Info.pm
+%%SITE_PERL%%/Vimana/Command/Install.pm
+%%SITE_PERL%%/Vimana/Command/Search.pm
+%%SITE_PERL%%/Vimana/Command/Update.pm
+%%SITE_PERL%%/Vimana/Command/Upgrade.pm
+%%SITE_PERL%%/Vimana/Index.pm
+%%SITE_PERL%%/Vimana/Logger.pm
+%%SITE_PERL%%/Vimana/Manual.pm
+%%SITE_PERL%%/Vimana/PackageFile.pm
+%%SITE_PERL%%/Vimana/PortInstall.pm
+%%SITE_PERL%%/Vimana/Util.pm
+%%SITE_PERL%%/Vimana/VimOnline.pm
+%%SITE_PERL%%/Vimana/VimOnline/ScriptPage.pm
+%%SITE_PERL%%/Vimana/VimOnline/Search.pm
+%%SITE_PERL%%/Vimana/VimballInstall.pm
+bin/vimana
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Vimana
+@dirrm %%SITE_PERL%%/Vimana/VimOnline
+@dirrm %%SITE_PERL%%/Vimana/Command
+@dirrm %%SITE_PERL%%/Vimana