aboutsummaryrefslogtreecommitdiff
path: root/editors/pdfedit/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'editors/pdfedit/Makefile')
-rw-r--r--editors/pdfedit/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/editors/pdfedit/Makefile b/editors/pdfedit/Makefile
new file mode 100644
index 000000000000..3b1e07e46509
--- /dev/null
+++ b/editors/pdfedit/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: pdfedit
+# Date created: 2007-12-20
+# Whom: alepulver
+#
+# $FreeBSD$
+#
+
+PORTNAME= pdfedit
+PORTVERSION= 0.3.2
+CATEGORIES= editors
+MASTER_SITES= SF
+
+MAINTAINER= alepulver@FreeBSD.org
+COMMENT= Free editor for manipulating PDF documents (QT3 GUI and CLI)
+
+BUILD_DEPENDS= qmake:${PORTSDIR}/devel/qmake
+LIB_DEPENDS= boost_filesystem.4:${PORTSDIR}/devel/boost \
+ t1.5:${PORTSDIR}/devel/t1lib
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_QT_VER= 3
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib" \
+ QMAKESPEC="${LOCALBASE}/share/qt/mkspecs/freebsd-g++"
+MAKE_ENV= ${CONFIGURE_ENV} QTDIR="${X11BASE}"
+CFLAGS+= -I${LOCALBASE}/include
+
+MAN1= pdfedit.1
+
+.if defined(NOPORTDOCS)
+post-patch:
+ @${REINPLACE_CMD} -e 's|^all: src doc|all: src|' ${WRKSRC}/Makefile.in
+.endif
+
+post-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/gui/${PORTNAME} ${PREFIX}/bin
+
+.include <bsd.port.mk>