aboutsummaryrefslogtreecommitdiff
path: root/editors/sam
diff options
context:
space:
mode:
Diffstat (limited to 'editors/sam')
-rw-r--r--editors/sam/Makefile4
-rw-r--r--editors/sam/files/patch-aa4
-rw-r--r--editors/sam/files/patch-ab2
-rw-r--r--editors/sam/files/patch-ac4
4 files changed, 7 insertions, 7 deletions
diff --git a/editors/sam/Makefile b/editors/sam/Makefile
index 20fdd5e1c24e..4ade2a6e335e 100644
--- a/editors/sam/Makefile
+++ b/editors/sam/Makefile
@@ -7,7 +7,7 @@
PORTNAME= sam
PORTVERSION= 4.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= editors plan9
MASTER_SITES= ftp://ftp.cs.usyd.edu.au/matty/unicode/
DISTNAME= ${PORTNAME}
@@ -19,12 +19,12 @@ COMMENT= A unix version of Rob Pike's editor for plan9
DEPRECATED= distfile and homepage disappeared
EXPIRATION_DATE= 2007-01-04
+USE_XORG= x11 xt ice sm
EXTRACT_CMD= ${GZCAT}
EXTRACT_BEFORE_ARGS= # empty
EXTRACT_AFTER_ARGS= | ${SH}
NO_WRKSUBDIR= yes
-USE_X_PREFIX= yes
MAN1= sam.1
MAN3= add.3 balloc.3 bitblt.3 cachechars.3 event.3 frame.3 \
diff --git a/editors/sam/files/patch-aa b/editors/sam/files/patch-aa
index 63af3ca481bd..c3c485a72e86 100644
--- a/editors/sam/files/patch-aa
+++ b/editors/sam/files/patch-aa
@@ -26,11 +26,11 @@
! OS=-DBSDi
# add -Iincludedir for any include directories that need to be searched
-! INCS=-I../include -I${X11BASE}/include
+! INCS=-I../include -I${LOCALBASE}/include
# set this if your X libraries are in different locations
# or if you need extra libraries to load with X11 applications
-! XLIBS=-lXt -lX11 -L${X11BASE}/lib
+! XLIBS=-lXt -lX11 -L${LOCALBASE}/lib
# add name of library orderer - use ":" if none
! RANLIB=ranlib
diff --git a/editors/sam/files/patch-ab b/editors/sam/files/patch-ab
index b17dc608431b..7bf0cb3a26e3 100644
--- a/editors/sam/files/patch-ab
+++ b/editors/sam/files/patch-ab
@@ -32,7 +32,7 @@
# add -Iincludedir for any include directories that need to be searched
# for posix header files (for UMIPS, add -I/usr/include/posix)
-! INCS=-I../include -I${X11BASE}/include
+! INCS=-I../include -I${LOCALBASE}/include
# add name of library orderer - use ":" if none exists
! RANLIB=ranlib
diff --git a/editors/sam/files/patch-ac b/editors/sam/files/patch-ac
index dca9bc5c5134..79495057a29d 100644
--- a/editors/sam/files/patch-ac
+++ b/editors/sam/files/patch-ac
@@ -35,7 +35,7 @@
# add -Iincludedir for any include directories that need to be searched
# for posix header files (for UMIPS, add -I/usr/include/posix)
-! INCS=-I../include -I${X11BASE}/include
+! INCS=-I../include -I${LOCALBASE}/include
# SAMTERM contains the name of the file containing the samterm
# executable. SAMTERMDIR is the directory where it is installed.
@@ -44,7 +44,7 @@
# set this if your X libraries are in different locations
# or if you need extra libraries to load with X11 applications
-! XLIBS=-lXt -lX11 -lSM -lICE -L${X11BASE}/lib
+! XLIBS=-lXt -lX11 -lSM -lICE -L${LOCALBASE}/lib
! CFLAGS+=$(OS) $(INCS) -D_LIBXG_EXTENSION