aboutsummaryrefslogtreecommitdiff
path: root/editors/semi-xemacs21-mule-current
diff options
context:
space:
mode:
Diffstat (limited to 'editors/semi-xemacs21-mule-current')
-rw-r--r--editors/semi-xemacs21-mule-current/Makefile20
-rw-r--r--editors/semi-xemacs21-mule-current/pkg-descr2
2 files changed, 8 insertions, 14 deletions
diff --git a/editors/semi-xemacs21-mule-current/Makefile b/editors/semi-xemacs21-mule-current/Makefile
index 02da033742b5..9d6e934c19a6 100644
--- a/editors/semi-xemacs21-mule-current/Makefile
+++ b/editors/semi-xemacs21-mule-current/Makefile
@@ -13,28 +13,22 @@ PORTCLASS= slave
MASTERDIR= ${.CURDIR}/../../editors/semi-emacs-current
# emacs port setup
-EMACS_NAME= xemacs
-EMACS_PORT= xemacs21-mule
-EMACS_VER= 21.1.10
-EMACS_CMD= ${PREFIX}/bin/${EMACS_PORT}
-EMACS_PACKAGESDIR= lib/${EMACS_NAME}/site-packages
+EMACS_PORT_NAME= xemacs21-mule
+EMACS_PACKAGESDIR= ${EMACS_LIBDIR}/site-packages
# packages-subdirectories which this port requires
EMACS_PACKAGES_SUBDIRS= info lisp man pkginfo
+SCRIPTS_ENV= EMACS_PACKAGESDIR=${EMACS_PACKAGESDIR}
+PLIST_SUB= EMACS_PACKAGESDIR=${EMACS_PACKAGESDIR}
+
# how to make and install
ALL_TARGET= package
INSTALL_TARGET= install-package
-# RUN_DEPENDS port name's suffix is '-common'.
-HAS_COMMON_PORT= YES
-
-# whether emacs has mule feature
-HAS_MULE= YES
-
# whether building info files by emacs or makeinfo
BUILD_INFO_BY_EMACS= YES
# texinfo packages
-BUILD_DEPENDS+= ${PREFIX}/${EMACS_PACKAGESDIR}/../xemacs-packages/lisp/texinfo/texinfo.el:${PORTSDIR}/editors/xemacs-sumo-packages
+BUILD_DEPENDS+= ${LOCALBASE}/${EMACS_PACKAGESDIR}/../xemacs-packages/lisp/texinfo/texinfo.el:${PORTSDIR}/editors/xemacs-sumo-packages
# use pkg/* files in ${.CURDIR}
PKGDIR= ${.CURDIR}/pkg
@@ -57,7 +51,7 @@ SEMIDOCDIR= ${EMACS_PACKAGESDIR}/lisp/semi
xemacs-package: install
@${RM} -f ${.CURDIR}/${XEMACS_PKG_TARBALL}
- @(cd ${PREFIX}/${EMACS_PACKAGESDIR} ;\
+ @(cd ${LOCALBASE}/${EMACS_PACKAGESDIR} ;\
${TAR} -zcf ${.CURDIR}/${XEMACS_PKG_TARBALL} ${XEMACS_PKG_CONTENTS} ;\
)
diff --git a/editors/semi-xemacs21-mule-current/pkg-descr b/editors/semi-xemacs21-mule-current/pkg-descr
index e2ac016e0a3d..a02894c10f25 100644
--- a/editors/semi-xemacs21-mule-current/pkg-descr
+++ b/editors/semi-xemacs21-mule-current/pkg-descr
@@ -20,6 +20,6 @@ SEMI, Library of MIME feature for GNU Emacs for xemacs21-mule.
MUAs. They are released as separated packages.
SEMI is installed the following directory tree:
- ${PREFIX}/lib/xemacs/site-packages/lisp/semi/ --- SEMI
+ ${LOCALBASE}/lib/xemacs/site-packages/lisp/semi/ --- SEMI
--- Porting by shige <shige@FreeBSD.ORG>