aboutsummaryrefslogtreecommitdiff
path: root/editors/tea/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'editors/tea/Makefile')
-rw-r--r--editors/tea/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/editors/tea/Makefile b/editors/tea/Makefile
index c23af49d860e..5b585c4015a9 100644
--- a/editors/tea/Makefile
+++ b/editors/tea/Makefile
@@ -6,9 +6,10 @@
#
PORTNAME= tea
-DISTVERSION= 13.3
+DISTVERSION= 14.2.4
CATEGORIES= editors
-MASTER_SITES= http://tea.linux.kiev.ua/
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= tea-editor
MAINTAINER= danfe@FreeBSD.org
COMMENT= A simple and powerful GTK+ text editor
@@ -22,8 +23,8 @@ USE_GNOME= gtk20
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-OPTIONS= TEA_ONLY "Build original GTK-only version" on \
- ASPELL "Build with GNU aspell support" on
+OPTIONS= TEA_ONLY "Build original GTK-only version" on \
+ ASPELL "Build with GNU aspell support" on
.include <bsd.port.pre.mk>
@@ -40,5 +41,7 @@ LIB_DEPENDS+= aspell:${PORTSDIR}/textproc/aspell
post-patch:
@${REINPLACE_CMD} -e 's|/tea/doc/|/doc/tea/|' \
${WRKSRC}/src/tea_defs.h
+ @${REINPLACE_CMD} -e '4373d; 4376,4379d' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e '568d' ${WRKSRC}/Makefile.in
.include <bsd.port.post.mk>