aboutsummaryrefslogtreecommitdiff
path: root/editors/texmacs/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'editors/texmacs/Makefile')
-rw-r--r--editors/texmacs/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/editors/texmacs/Makefile b/editors/texmacs/Makefile
index b30d43e07a23..d0a4ea943880 100644
--- a/editors/texmacs/Makefile
+++ b/editors/texmacs/Makefile
@@ -30,8 +30,9 @@ GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-CONFIGURE_ARGS= --disable-fastalloc --enable-optimize="${CXXFLAGS}" \
+CONFIGURE_ARGS= --enable-optimize="${CXXFLAGS}" \
--with-iconv="${LOCALBASE}"
+
MAKE_ARGS= CP="${CP} -R -f"
ALL_TARGET= ${PORTNAME:U}
@@ -43,6 +44,12 @@ LIB_DEPENDS+= Imlib2.3:${PORTSDIR}/graphics/imlib2
CONFIGURE_ARGS+= --with-imlib2
.endif
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 600000
+CONFIGURE_ARGS+=--disable-fastalloc
+.endif
+
post-patch:
@${GREP} -lR "#!/bin/bash" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e \
's|#!/bin/bash|#!/bin/sh|g'
@@ -53,4 +60,4 @@ post-install:
${CHOWN} -R ${LIBOWN}:${LIBGRP} ${PREFIX}/libexec/TeXmacs
${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${PREFIX}/share/TeXmacs
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>