aboutsummaryrefslogtreecommitdiff
path: root/editors/texmacs/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'editors/texmacs/Makefile')
-rw-r--r--editors/texmacs/Makefile54
1 files changed, 40 insertions, 14 deletions
diff --git a/editors/texmacs/Makefile b/editors/texmacs/Makefile
index 6fcd447f4d56..10739c870ef0 100644
--- a/editors/texmacs/Makefile
+++ b/editors/texmacs/Makefile
@@ -6,10 +6,9 @@
#
PORTNAME= texmacs
-PORTVERSION= 1.0.7.10
-PORTREVISION= 1
+PORTVERSION= 1.0.7.13
CATEGORIES= editors print
-MASTER_SITES= ftp://ftp.texmacs.org/pub/TeXmacs/targz/ \
+MASTER_SITES= http://www.texmacs.org/Download/ftp/tmftp/source/ \
http://www.predatorlabs.net/dl/
DISTNAME= TeXmacs-${PORTVERSION}-src
@@ -17,22 +16,18 @@ MAINTAINER= rfarmer@predatorlabs.net
COMMENT= A free WYSIWYG scientific text editor
BUILD_DEPENDS= tex:${PORTSDIR}/print/teTeX-base
-LIB_DEPENDS= guile.21:${PORTSDIR}/lang/guile \
- freetype.9:${PORTSDIR}/print/freetype2
+LIB_DEPENDS= guile.21:${PORTSDIR}/lang/guile
RUN_DEPENDS= tex:${PORTSDIR}/print/teTeX-base
MAKE_JOBS_SAFE= yes
USE_PYTHON= yes
-USE_ICONV= yes
+
USE_GMAKE= yes
-USE_GHOSTSCRIPT= yes
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ARGS= --enable-optimize="${CXXFLAGS}" \
- --with-iconv="${LOCALBASE}"
-
+CONFIGURE_ARGS= --enable-optimize="${CXXFLAGS}"
MAKE_ARGS= CP="${CP} -R -f"
ALL_TARGET= ${PORTNAME:U}
@@ -41,9 +36,12 @@ DATADIR= ${PREFIX}/share/TeXmacs
MAN1= texmacs.1 fig2ps.1
MANCOMPRESSED= yes
-OPTIONS= IMLIB2 "Use imlib2" ON \
+OPTIONS= FREETYPE "FreeType support" ON \
+ GHOSTSCRIPT "Ghostscript support" ON \
+ ICONV "Iconv support" ON \
+ IMLIB2 "Use imlib2" ON \
PDF "Experimental PDF renderer" OFF \
- QT4 "Experimental QT4 GUI" OFF
+ QT4 "QT4 GUI" ON
DESKTOP_ENTRIES= "TeXmacs" "${COMMENT}" \
"${DATADIR}/misc/pixmaps/TeXmacs.xpm" "texmacs" \
@@ -51,9 +49,32 @@ DESKTOP_ENTRIES= "TeXmacs" "${COMMENT}" \
.include <bsd.port.options.mk>
+.if !defined(WITHOUT_FREETYPE)
+LIB_DEPENDS+= freetype.9:${PORTSDIR}/print/freetype2
+CONFIGURE_ARGS+= --with-freetype=linked
+.else
+CONFIGURE_ARGS+= --without-freetype
+.endif
+
+.if !defined(WITHOUT_GHOSTSCRIPT)
+USE_GHOSTSCRIPT= yes
+CONFIGURE_ARGS+= --with-gs=yes
+.else
+CONFIGURE_ARGS+= --without-gs
+.endif
+
+.if !defined(WITHOUT_ICONV)
+USE_ICONV= yes
+CONFIGURE_ARGS+= --with-iconv="${LOCALBASE}"
+.else
+CONFIGURE_ARGS+= --without-iconv
+.endif
+
.if !defined(WITHOUT_IMLIB2)
USE_EFL= imlib2
CONFIGURE_ARGS+= --with-imlib2
+.else
+CONFIGURE_ARGS+= --without-imlib
.endif
.if !defined(WITHOUT_PDF)
@@ -61,9 +82,11 @@ CONFIGURE_ARGS+= --enable-pdf-renderer
.endif
.if !defined(WITHOUT_QT4)
-CONFIGURE_ARGS+= --enable-qt
USE_QT_VER= 4
-QT_COMPONENTS= gui moc_build qmake_build uic_build
+QT_COMPONENTS= gui moc_build qmake_build rcc uic_build
+CONFIGURE_ARGS+= --with-qt --enable-qtpipes
+.else
+CONFIGURE_ARGS+= --disable-qt
.endif
.include <bsd.port.pre.mk>
@@ -74,6 +97,9 @@ post-patch:
@${FIND} ${WRKSRC} -name \*.bak -delete
@${REINPLACE_CMD} -e 's|ICONV_LDFLAGS/-liconv|ICONV_LDFLAGS|' \
${WRKSRC}/configure
+ #fix for namespace clash with Qt3
+ @${REINPLACE_CMD} -e 's|qdrawutil.h|qt4/Qt/qdrawutil.h|' \
+ ${WRKSRC}/src/Plugins/Qt/QTMStyle.cpp
post-install:
${CHOWN} -R ${LIBOWN}:${LIBGRP} ${PREFIX}/libexec/TeXmacs