aboutsummaryrefslogtreecommitdiff
path: root/editors/tpad/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'editors/tpad/Makefile')
-rw-r--r--editors/tpad/Makefile23
1 files changed, 18 insertions, 5 deletions
diff --git a/editors/tpad/Makefile b/editors/tpad/Makefile
index 4712fd2d74f2..0a8941e51727 100644
--- a/editors/tpad/Makefile
+++ b/editors/tpad/Makefile
@@ -6,13 +6,10 @@
#
PORTNAME= tpad
-PORTVERSION= 1.0
+PORTVERSION= 1.1
CATEGORIES= editors tcl84 tk84
MASTER_SITES= http://monitor.deis.unical.it/ant/tpad/ \
http://queen.rett.polimi.it/~ant/tcl/script/
-DISTNAME= ${PORTNAME}-${PORTVERSION}.tcl
-EXTRACT_SUFX=
-EXTRACT_ONLY=
MAINTAINER= ant@monitor.deis.unical.it
COMMENT= Win95/98 (TM) Notepad clone written in Tcl/Tk
@@ -20,8 +17,24 @@ COMMENT= Win95/98 (TM) Notepad clone written in Tcl/Tk
RUN_DEPENDS= wish8.4:${PORTSDIR}/x11-toolkits/tk84
NO_BUILD= yes
+PKGMESSAGE= ${WRKDIR}/MESSAGE
+
+PORTDOCS= ChangeLog conf.html index.html intro.html keys.html \
+ log.html mouse.html todo tpad.html
do-install:
- ${INSTALL_SCRIPT} ${DISTDIR}/${DISTFILES} ${PREFIX}/bin/tpad
+ ${INSTALL_SCRIPT} ${WRKDIR}/bin/tpad ${PREFIX}/bin/tpad
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for docfile in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKDIR}/share/doc/tpad/${docfile} ${DOCSDIR}
+.endfor
+.endif
+ ${INSTALL_DATA} ${WRKDIR}/etc/tpad.conf \
+ ${PREFIX}/etc/tpad.conf.sample
+ @${SED} -e 's,%%PREFIX%%,${PREFIX},g' ${PKGDIR}/pkg-message > ${PKGMESSAGE}
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>