aboutsummaryrefslogtreecommitdiff
path: root/editors/vanubi
diff options
context:
space:
mode:
Diffstat (limited to 'editors/vanubi')
-rw-r--r--editors/vanubi/Makefile33
-rw-r--r--editors/vanubi/distinfo2
-rw-r--r--editors/vanubi/files/patch-configure.ac11
-rw-r--r--editors/vanubi/files/patch-gui_Makefile.am11
-rw-r--r--editors/vanubi/files/patch-gui_shellbar.vala17
-rw-r--r--editors/vanubi/pkg-descr5
-rw-r--r--editors/vanubi/pkg-plist17
7 files changed, 96 insertions, 0 deletions
diff --git a/editors/vanubi/Makefile b/editors/vanubi/Makefile
new file mode 100644
index 000000000000..bfe8ade6a9d6
--- /dev/null
+++ b/editors/vanubi/Makefile
@@ -0,0 +1,33 @@
+# Created by: Olivier Duchateau
+# $FreeBSD$
+
+PORTNAME= vanubi
+PORTVERSION= 0.0.16
+DISTVERSIONPREFIX= v
+CATEGORIES= editors
+
+MAINTAINER= olivierd@FreeBSD.org
+COMMENT= Programming editor written in Vala
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BUILD_DEPENDS= valac:${PORTSDIR}/lang/vala
+LIB_DEPENDS= libexecinfo.so:${PORTSDIR}/devel/libexecinfo
+
+GH_TAGNAME= eedac1d
+
+USE_GITHUB= yes
+USES= autoreconf desktop-file-utils gmake libtool pkgconfig
+GNU_CONFIGURE= yes
+USE_GNOME= glib20 gtk30 gtksourceview3 libwnck3 vte3
+USE_LDCONFIG= yes
+INSTALL_TARGET= install-strip
+
+CONFIGURE_ARGS=--without-asciidoc --disable-static
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|vte-2.90|vte-2.91|' \
+ ${WRKSRC}/configure.ac
+
+.include <bsd.port.mk>
diff --git a/editors/vanubi/distinfo b/editors/vanubi/distinfo
new file mode 100644
index 000000000000..5db4dbbe213c
--- /dev/null
+++ b/editors/vanubi/distinfo
@@ -0,0 +1,2 @@
+SHA256 (vanubi-vanubi-v0.0.16-eedac1d_GH0.tar.gz) = 20ef1d71ec62416c2e048bc829f546672c4ae7e4be8556114fd40a19eb924978
+SIZE (vanubi-vanubi-v0.0.16-eedac1d_GH0.tar.gz) = 709627
diff --git a/editors/vanubi/files/patch-configure.ac b/editors/vanubi/files/patch-configure.ac
new file mode 100644
index 000000000000..2cc0c5fcc35b
--- /dev/null
+++ b/editors/vanubi/files/patch-configure.ac
@@ -0,0 +1,11 @@
+--- configure.ac.orig 2014-12-09 10:52:31 UTC
++++ configure.ac
+@@ -71,7 +71,7 @@ LIBVANUBI_VALAFLAGS="$LIBVANUBI_VALAFLAG
+ LIBVANUBI_CFLAGS="$LIBVANUBI_CFLAGS -w"
+ LIBVANUBI_LIBS="$LIBVANUBI_LIBS"
+
+-VALA_CHECK_MODULES(VANUBI, [gtk+-3.0 >= 3.6 gio-unix-2.0 gtksourceview-3.0 vte-2.90 gdk-x11-3.0 libwnck-3.0])
++VALA_CHECK_MODULES(VANUBI, [gtk+-3.0 gio-unix-2.0 gtksourceview-3.0 vte-2.90 gdk-x11-3.0 libwnck-3.0])
+ dnl We ignore GTK_3_10_*
+ PKG_CHECK_MODULES(GTK_3_10, [gtk+-3.0 >= 3.10],
+ [VANUBI_VALAFLAGS="$VANUBI_VALAFLAGS -D GTK_3_10"],
diff --git a/editors/vanubi/files/patch-gui_Makefile.am b/editors/vanubi/files/patch-gui_Makefile.am
new file mode 100644
index 000000000000..8ce4fd511f71
--- /dev/null
+++ b/editors/vanubi/files/patch-gui_Makefile.am
@@ -0,0 +1,11 @@
+--- gui/Makefile.am.orig 2014-12-09 10:52:31 UTC
++++ gui/Makefile.am
+@@ -50,6 +50,8 @@ vanubi_SOURCES = \
+ vanubi_LDADD = \
+ ../libvanubi/libvanubi@PACKAGE_SUFFIX@.la \
+ $(VANUBI_LIBS) \
++ -lexecinfo \
++ -lX11 \
+ $(NULL)
+
+ EXTRA_DIST = $(vanubi_VALASOURCES)
diff --git a/editors/vanubi/files/patch-gui_shellbar.vala b/editors/vanubi/files/patch-gui_shellbar.vala
new file mode 100644
index 000000000000..6d6bde6f454e
--- /dev/null
+++ b/editors/vanubi/files/patch-gui_shellbar.vala
@@ -0,0 +1,17 @@
+Add support of vte-2.91 instead of vte-2.90
+
+--- gui/shellbar.vala.orig 2014-12-09 10:52:31 UTC
++++ gui/shellbar.vala
+@@ -146,10 +146,10 @@ namespace Vanubi.UI {
+ }
+
+ Pid pid;
+- term.fork_command_full (PtyFlags.DEFAULT, workdir, {shell}, null, SpawnFlags.SEARCH_PATH, null, out pid);
++ term.spawn_sync (PtyFlags.DEFAULT, workdir, {shell}, null, SpawnFlags.SEARCH_PATH, null, out pid);
+ term.set_data ("pid", pid);
+ pty_cancellable = new Cancellable ();
+- read_sh.begin (term.pty_object.fd, pty_cancellable);
++ read_sh.begin (term.get_pty ().fd, pty_cancellable);
+
+ mouse_match (term, """^.+error:""");
+ mouse_match (term, """^.+warning:""");
diff --git a/editors/vanubi/pkg-descr b/editors/vanubi/pkg-descr
new file mode 100644
index 000000000000..15b818163132
--- /dev/null
+++ b/editors/vanubi/pkg-descr
@@ -0,0 +1,5 @@
+Vanubi is an Emacs-like editor implemented in Vala. It is designed to be
+simple, complete, keyboard based, and implement only what users really
+use and expect.
+
+WWW: http://vanubi.github.io/vanubi/
diff --git a/editors/vanubi/pkg-plist b/editors/vanubi/pkg-plist
new file mode 100644
index 000000000000..3421e9e53426
--- /dev/null
+++ b/editors/vanubi/pkg-plist
@@ -0,0 +1,17 @@
+bin/vanubi
+lib/libvanubi-0.1.so
+lib/libvanubi-0.1.so.0
+lib/libvanubi-0.1.so.0.0.0
+share/applications/vanubi.desktop
+%%DATADIR%%/css/tango.css
+%%DATADIR%%/css/zen.css
+%%DATADIR%%/languages/asciidoc.lang
+%%DATADIR%%/languages/asm-intel.lang
+%%DATADIR%%/languages/generic_comment.lang
+%%DATADIR%%/languages/i386asm.lang
+%%DATADIR%%/languages/nix.lang
+%%DATADIR%%/languages/rpmspec.lang
+%%DATADIR%%/logo/vanubi.png
+%%DATADIR%%/styles/tango.xml
+%%DATADIR%%/styles/zen-grep.xml
+%%DATADIR%%/styles/zen.xml