aboutsummaryrefslogtreecommitdiff
path: root/editors/xed/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'editors/xed/Makefile')
-rw-r--r--editors/xed/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/editors/xed/Makefile b/editors/xed/Makefile
index 320d3ba18503..ebf7b3f955a9 100644
--- a/editors/xed/Makefile
+++ b/editors/xed/Makefile
@@ -3,19 +3,24 @@
PORTNAME= xed
PORTVERSION= 1.3
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= editors
-MASTER_SITES= ${MASTER_SITE_XCONTRIB}
-MASTER_SITE_SUBDIR= editors
+MASTER_SITES= XCONTRIB/editors
DISTNAME= ${PORTNAME}${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Text editor for X
+LICENSE= MIT
+
USES= imake tar:Z
USE_XORG= xaw
+MAKE_ARGS= BINDIR=${PREFIX}/bin \
+ LIBDIR=${PREFIX}/lib/X11 \
+ MANPATH=${PREFIX}/man
pre-build:
@${FIND} ${WRKSRC} -type f | ${XARGS} ${REINPLACE_CMD} -e \
's|extern char \*malloc();|/\* extern char \*malloc(); \*/|g'
+
.include <bsd.port.mk>