aboutsummaryrefslogtreecommitdiff
path: root/editors/xemacs-devel-mule/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'editors/xemacs-devel-mule/Makefile')
-rw-r--r--editors/xemacs-devel-mule/Makefile12
1 files changed, 10 insertions, 2 deletions
diff --git a/editors/xemacs-devel-mule/Makefile b/editors/xemacs-devel-mule/Makefile
index 2b2cb56629b9..c6217f79e1ee 100644
--- a/editors/xemacs-devel-mule/Makefile
+++ b/editors/xemacs-devel-mule/Makefile
@@ -64,7 +64,6 @@ CONFIGURE_ARGS= --enable-mule \
--enable-sound=native \
--with-site-lisp \
--with-pop \
- --with-ldap=no \
--with-infopath=${LOCALBASE}/lib/xemacs/info:${LOCALBASE}/info:${X11BASE}/info:/usr/info:${LOCALBASE}/lib/texmf/doc/info:/usr/lib/texmf/doc:/usr/share/info \
--enable-clash-detection \
--enable-database=berkdb \
@@ -162,7 +161,6 @@ CONFIGURE_ARGS+=--with-athena=xaw
.if exists(${LOCALBASE}/include/libpq-fe.h)
WITH_PGSQL= yes
.endif
-
.if defined(WITH_PGSQL)
USE_PGSQL= yes
PLIST_SUB+= WITH_PGSQL=""
@@ -170,6 +168,16 @@ PLIST_SUB+= WITH_PGSQL=""
PLIST_SUB+= WITH_PGSQL="@comment "
.endif
+.if exists(${LOCALBASE}/include/ldap.h)
+WITH_LDAP= yes
+.endif
+.if defined(WITH_LDAP)
+USE_OPENLDAP= yes
+PLIST_SUB+= WITH_LDAP=""
+.else
+PLIST_SUB+= WITH_LDAP="@comment "
+.endif
+
BINNAMEEXT= -mule
.if defined(CANNA) && defined(FREEWNN)
CONFIGURE_ARGS+= --with-canna --with-wnn --with-wnn6=no