aboutsummaryrefslogtreecommitdiff
path: root/editors/xemacs/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'editors/xemacs/Makefile')
-rw-r--r--editors/xemacs/Makefile53
1 files changed, 24 insertions, 29 deletions
diff --git a/editors/xemacs/Makefile b/editors/xemacs/Makefile
index 5568c8a0eab9..2b771670d4ee 100644
--- a/editors/xemacs/Makefile
+++ b/editors/xemacs/Makefile
@@ -1,30 +1,30 @@
# New ports collection makefile for: X-Emacs
-# Date created: 24 Apr 1999
-# Whom: Michael Elbel (me@FreeBSD.org)
+# Date created: 25 Oct 2001
+# Whom: Gary Jennejohn (gj@FreeBSD.org)
#
# $FreeBSD$
#
-PORTNAME= xemacs
+PORTNAME= xemacs-devel
PORTVERSION= ${XEMACS_VER}
CATEGORIES+= editors
MASTER_SITES= ${MASTER_SITE_XEMACS}
MASTER_SITE_SUBDIR= xemacs-${XEMACS_REL}
+DISTNAME= xemacs-${XEMACS_VER}
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${DISTNAME}-elc${EXTRACT_SUFX} ${DISTNAME}-info${EXTRACT_SUFX}
DIST_SUBDIR= xemacs
-MAINTAINER?= gj@FreeBSD.org
+MAINTAINER= gj@FreeBSD.org
RUN_DEPENDS+= ${LOCALBASE}/lib/xemacs/xemacs-packages/etc/enriched.doc:${PORTSDIR}/editors/xemacs-packages
LIB_DEPENDS+= jpeg.9:${PORTSDIR}/graphics/jpeg \
png.5:${PORTSDIR}/graphics/png \
tiff.4:${PORTSDIR}/graphics/tiff
-XEMACS_REL= 21.1
-XEMACS_VER= 21.1.14
+XEMACS_REL= 21.4
+XEMACS_VER= 21.4.4
XEMACS_ARCH= ${CONFIGURE_TARGET}
-SLAVEDIRS+= editors/xemacs21-mule
USE_XLIB= yes
USE_XPM= yes
STRIP=
@@ -32,31 +32,25 @@ USE_AUTOCONF= yes
CONFIGURE_TARGET=${MACHINE_ARCH}--freebsd
CONFIGURE_ARGS?=--with-clash-detection \
- --lockdir=/var/run/emacs/lock \
--with-sound=native \
- --with-session=yes \
--site-includes=${LOCALBASE}/include \
--site-libraries=${LOCALBASE}/lib \
- --gung-ho=yes \
--with-png=yes \
--with-tiff=yes \
--with-site-lisp \
--with-database=berkdb \
- ${WITH_XFACE} ${WITH_DIALOGS} ${WITH_OFFIX}
+ ${WITH_XFACE} ${WITH_DIALOGS} ${WITH_OFFIX} ${WITH_GTK}
MAKE_ARGS= prefix=${PREFIX}
-.if !defined(MULE_SLAVE)
MAN1= ctags.1 etags.1 gnuattach.1 gnuclient.1 gnudoit.1 \
gnuserv.1 xemacs.1
-.endif
-.if !defined(MULE_PORT)
ALL_TARGET= all dist
-.endif
PLIST_SUB= XEMACS_VER=${XEMACS_VER} XEMACS_ARCH=${XEMACS_ARCH}
-.if !defined(MULE_PORT)
pre-fetch:
- @${ECHO_MSG} "If you want the MULE features, please use the xemacs-mule port"
+.if !defined(WANT_GTK)
+ @${ECHO_MSG} "If you want to use GTK, please set the environment variable WANT_GTK and recompile."
+.endif
.if defined(HAVE_MOTIF)
.if !defined(MOTIF_STATIC)
@${ECHO_MSG} ""
@@ -65,13 +59,19 @@ pre-fetch:
@${ECHO_MSG} "In this case, set the environment variable MOTIF_STATIC and recompile, "
@${ECHO_MSG} "which will force the use of athena widgets for dialogs."
.endif
-.endif
# hack to avoid shipping binaries linked with Motif
.if defined(MOTIF_STATIC)
WITH_DIALOGS= --with-dialogs=athena
.endif
+.if defined(WANT_GTK)
+WITH_GTK= --with-gtk=yes \
+ --with-xpm=no
+USE_GTK= yes
+USE_XPM= no
+.endif
+
# Drop faces (libcompface) and offix (libDnd) if building package,
# autodetect otherwise
.if defined(PACKAGE_BUILDING)
@@ -88,24 +88,19 @@ pre-configure::
.endfor
post-install::
-.if !defined(MULE_COMMON)
- ${LN} -sf xemacs-${XEMACS_VER} ${PREFIX}/bin/xemacs21${BINNAMEEXT}
-.for file in b2m ctags etags gnuclient xemacs-${XEMACS_VER}
+.for file in b2m ctags ellcc etags gnuclient xemacs-${XEMACS_VER}
strip ${PREFIX}/bin/${file}
.endfor
-.endif
-.if !defined(MULE_SLAVE)
-# ``make install'' does not set the permissions like pkg_add does.
- ${MKDIR} /var/run/emacs/lock
- ${CHMOD} 1777 /var/run/emacs/lock
# For some reason install no longer makes ${PREFIX}/lib/xemacs/site-lisp.
# Do what PLIST does for pkg_add.
${MKDIR} ${PREFIX}/lib/xemacs/site-lisp
${CHMOD} 755 ${PREFIX}/lib/xemacs/site-lisp
${RM} -f ${PREFIX}/bin/send-pr
-# install xemacs21.sh into ${PREFIX}/etc/rc.d
- @if [ ! -d ${PREFIX}/etc/rc.d ]; then ${MKDIR} ${PREFIX}/etc/rc.d; fi
- ${INSTALL_SCRIPT} ${FILESDIR}/xemacs21.sh ${PREFIX}/etc/rc.d
+.if defined(WANT_GTK)
+ @${ECHO_MSG} "Please be aware that GTK support is buggy. Do not report bugs to"
+ @${ECHO_MSG} "the maintainer."
+ @${ECHO_MSG} "Please also be aware that the package's name was automagically changed"
+ @${ECHO_MSG} "to ${PORTNAME}${PKGNAMESUFFIX}-${XEMACS_VER}."
.endif
.include <bsd.port.mk>