aboutsummaryrefslogtreecommitdiff
path: root/editors/zoinks/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'editors/zoinks/Makefile')
-rw-r--r--editors/zoinks/Makefile41
1 files changed, 0 insertions, 41 deletions
diff --git a/editors/zoinks/Makefile b/editors/zoinks/Makefile
deleted file mode 100644
index d3d29c3c0f07..000000000000
--- a/editors/zoinks/Makefile
+++ /dev/null
@@ -1,41 +0,0 @@
-# Created by: Mike Lockwood <mike@mikelockwood.com>
-# $FreeBSD$
-
-PORTNAME= zoinks
-PORTVERSION= 0.4.1
-PORTREVISION= 3
-CATEGORIES= editors
-MASTER_SITES= http://zoinks.mikelockwood.com/download/
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= X11 programmer's editor and development environment
-
-LICENSE= GPLv2+
-LICENSE_FILE= ${WRKSRC}/COPYING
-
-BROKEN= unfetchable
-DEPRECATED= Unfetchable, unmaintained
-EXPIRATION_DATE= 2019-10-16
-
-USES= compiler
-USE_XORG= x11 xext xpm
-GNU_CONFIGURE= yes
-
-CPPFLAGS+= -I${LOCALBASE}/include
-CXXFLAGS+= ${CXXFLAGS_${CHOSEN_COMPILER_TYPE}}
-CXXFLAGS_clang= -Wno-c++11-narrowing
-LDFLAGS+= -L${LOCALBASE}/lib
-
-OPTIONS_DEFINE= NLS
-OPTIONS_SUB= yes
-
-NLS_USES= gettext
-NLS_CONFIGURE_ENABLE= nls
-
-post-patch:
- @${REINPLACE_CMD} -e \
- 's|^MY_CXXFLAGS|#&|' ${WRKSRC}/configure
- @${FIND} ${WRKSRC} -name *.xpm | ${XARGS} ${REINPLACE_CMD} -e \
- 's|^"|(char *)"|g'
-
-.include <bsd.port.mk>