aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
Diffstat (limited to 'editors')
-rw-r--r--editors/neovim/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/editors/neovim/Makefile b/editors/neovim/Makefile
index 98c8f4a1e523..c71eded1cac7 100644
--- a/editors/neovim/Makefile
+++ b/editors/neovim/Makefile
@@ -34,10 +34,13 @@ CMAKE_ARGS= -DLUA_PRG:FILEPATH="${LUA_CMD}" \
-DCMAKE_INSTALL_MANDIR:PATH="${MANPREFIX}/man" \
-DDEPS_PREFIX:PATH="${LOCALBASE}"
-OPTIONS_DEFINE= NLS
+OPTIONS_DEFINE= NLS PYNVIM
OPTIONS_SUB= yes
NLS_CMAKE_BOOL= ENABLE_LIBINTL
NLS_USES= gettext
+PYNVIM_DESC= Enable support for plugins written in python
+PYNVIM_USES= python:run
+PYNVIM_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pynvim>=0.3.0:editors/py-pynvim
post-patch:
@${REINPLACE_CMD} -e \