aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
Diffstat (limited to 'editors')
-rw-r--r--editors/color-mate/Makefile8
-rw-r--r--editors/fte/Makefile9
-rw-r--r--editors/p5-Vimana/Makefile9
-rw-r--r--editors/zile/Makefile3
4 files changed, 10 insertions, 19 deletions
diff --git a/editors/color-mate/Makefile b/editors/color-mate/Makefile
index 7aac8b52cd7e..a5da69f29e34 100644
--- a/editors/color-mate/Makefile
+++ b/editors/color-mate/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: color-mate for emacs
-# Date created: 99/09/29
-# Whom: Satoshi Taoka <taoka@FreeBSD.org>
-#
+# Created by: Satoshi Taoka <taoka@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= color-mate
PORTVERSION= 10.6.4
@@ -14,7 +10,7 @@ MASTER_SITES= http://www.netlab.is.tsukuba.ac.jp/~yokota/archive/
MAINTAINER= sarumaru@jp.FreeBSD.org
COMMENT= Color customizing module for Emacsen
-USE_PERL5= yes
+USES= perl5
EMACSDIR= ${PREFIX}/share/emacs/site-lisp
ELISPDIR= ${EMACSDIR}/color-mate
diff --git a/editors/fte/Makefile b/editors/fte/Makefile
index c89ceb79287c..4b9cf249e1d1 100644
--- a/editors/fte/Makefile
+++ b/editors/fte/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: fte
-# Date created: 8 May 2000
-# Whom: gelf
-#
+# Created by: gelf
# $FreeBSD$
-#
PORTNAME= fte
PORTVERSION= 20051115
@@ -21,7 +17,8 @@ WRKSRC= ${WRKDIR}/fte
USE_XORG= x11 xpm
USE_ZIP= yes
-USE_PERL5_BUILD= yes
+USES= perl5
+USE_PERL5= build
post-patch:
@${REINPLACE_CMD} -e 's,^PREFIX=,PREFIX?=,' \
diff --git a/editors/p5-Vimana/Makefile b/editors/p5-Vimana/Makefile
index 3a91a69c9700..f5cb7446ee97 100644
--- a/editors/p5-Vimana/Makefile
+++ b/editors/p5-Vimana/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Vimana
-# Date created: 2009-08-25
-# Whom: Gea-Suan Lin <gslin@gslin.org>
-#
+# Created by: Gea-Suan Lin <gslin@gslin.org>
# $FreeBSD$
-#
PORTNAME= Vimana
PORTVERSION= 2010.09303
@@ -34,7 +30,8 @@ RUN_DEPENDS= vim>=0:${PORTSDIR}/editors/vim \
p5-Mouse>=0:${PORTSDIR}/devel/p5-Mouse \
p5-PathTools>=0:${PORTSDIR}/devel/p5-PathTools
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN1= vimana.1 vim_record.1
MAN3= Vimana.3 \
diff --git a/editors/zile/Makefile b/editors/zile/Makefile
index e1dd7ccf8d80..ed80254b7384 100644
--- a/editors/zile/Makefile
+++ b/editors/zile/Makefile
@@ -13,7 +13,8 @@ LIB_DEPENDS= gc:${PORTSDIR}/devel/boehm-gc
BUILD_DEPENDS= ${LOCALBASE}/bin/help2man:${PORTSDIR}/misc/help2man
USE_GMAKE= yes
-USE_PERL5_BUILD=yes
+USES= perl5
+USE_PERL5= build
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --without-included-regex