aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
Diffstat (limited to 'editors')
-rw-r--r--editors/openoffice-3-devel/Makefile12
-rw-r--r--editors/openoffice-3-devel/distinfo6
-rw-r--r--editors/openoffice-3-devel/files/patch-serf11
3 files changed, 21 insertions, 8 deletions
diff --git a/editors/openoffice-3-devel/Makefile b/editors/openoffice-3-devel/Makefile
index f0ccc330bbe7..cd0f56d7fcf6 100644
--- a/editors/openoffice-3-devel/Makefile
+++ b/editors/openoffice-3-devel/Makefile
@@ -7,11 +7,12 @@
PORTNAME= apache-openoffice
PORTVERSION= 3.4.${SVNREVISION}
+PORTEPCH= 1
CATEGORIES= editors java
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= maho/openoffice
-DISTFILES+= ${OOOSRC} unowinreg.dll
-EXTRACT_ONLY= ${OOOSRC}
+DISTFILES+= ${OOOSRC} ${EXTSRC} unowinreg.dll
+EXTRACT_ONLY= ${OOOSRC} ${EXTSRC}
#de facto maintainer is maho@FreeBSD.org
#Frequent Patch submitters should optionally sign Apache iCLA
@@ -32,8 +33,6 @@ USE_BZIP2= yes
WITHOUT_CPU_CFLAGS= true
MAKE_JOBS_SAFE= yes
-MANUAL_PACKAGE_BUILD= distfile exceeds pointyhat filesize limit
-
.include <bsd.port.pre.mk>
USE_JAVA= yes
@@ -51,9 +50,10 @@ FREEBSD_ENV_SET= FreeBSDAMDEnv.Set.sh
FREEBSD_ENV_SET= FreeBSDX86Env.Set.sh
.endif
-OOOSRC?= ApacheOpenOffice.r${SVNREVISION}${EXTRACT_SUFX}
+OOOSRC= ApacheOpenOffice.r${SVNREVISION}${EXTRACT_SUFX}
+EXTSRC= ApacheOpenOffice.ext_sources.r${SVNREVISION}${EXTRACT_SUFX}
OOODIR= openoffice.org3
-SVNREVISION= 1240439
+SVNREVISION= 1242624
INSTALLATION_BASEDIR?= openoffice-r${SVNREVISION}
EXECBASE?= openoffice-r${SVNREVISION}
DIST_SUBDIR= openoffice
diff --git a/editors/openoffice-3-devel/distinfo b/editors/openoffice-3-devel/distinfo
index ed87ae608f1b..43e759c5cc46 100644
--- a/editors/openoffice-3-devel/distinfo
+++ b/editors/openoffice-3-devel/distinfo
@@ -1,4 +1,6 @@
-SHA256 (openoffice/ApacheOpenOffice.r1240439.tar.bz2) = 14571e881d6082b328d34d4ec837ef186e4fc48583c20129f3d9a44295bf1b54
-SIZE (openoffice/ApacheOpenOffice.r1240439.tar.bz2) = 463572621
+SHA256 (openoffice/ApacheOpenOffice.r1242624.tar.bz2) = 0500ee4db71cd4d047d0722011d67c13b5d7ef8199dc32ff38fc251dad32443e
+SIZE (openoffice/ApacheOpenOffice.r1242624.tar.bz2) = 250748120
+SHA256 (openoffice/ApacheOpenOffice.ext_sources.r1242624.tar.bz2) = 5c5639bcff30ec8e86e001de54056265b3e6004f70074d04604b614ca2017f41
+SIZE (openoffice/ApacheOpenOffice.ext_sources.r1242624.tar.bz2) = 214762706
SHA256 (openoffice/unowinreg.dll) = f563e522922133db9340b0306711c2d8767cc3481dd9e7d9b0d059906d12653c
SIZE (openoffice/unowinreg.dll) = 6144
diff --git a/editors/openoffice-3-devel/files/patch-serf b/editors/openoffice-3-devel/files/patch-serf
new file mode 100644
index 000000000000..7e9aad41f18b
--- /dev/null
+++ b/editors/openoffice-3-devel/files/patch-serf
@@ -0,0 +1,11 @@
+--- ../ext_libraries/serf/makefile.mk~ 2012-02-10 09:54:52.000000000 +0900
++++ ../ext_libraries/serf/makefile.mk 2012-02-10 14:21:47.000000000 +0900
+@@ -51,7 +51,7 @@
+
+ .ELSE
+
+-.IF "$(OS)"=="MACOSX"
++.IF "$(OS)"=="MACOSX" || "$(OS)"=="FREEBSD"
+ # Do not link against expat. It is not necessary (apr-util is already linked against it)
+ # and does not work (we use a different expat library schema.)
+ PATCH_FILES=$(TARFILE_NAME).mac.patch