aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
Diffstat (limited to 'editors')
-rw-r--r--editors/abiword/Makefile18
-rw-r--r--editors/gedit-plugins/Makefile7
-rw-r--r--editors/gedit-plugins/distinfo6
-rw-r--r--editors/gedit-plugins/pkg-plist1
-rw-r--r--editors/gedit/Makefile11
-rw-r--r--editors/gedit/distinfo6
-rw-r--r--editors/gedit/files/patch-plugins_externaltools_data_Makefile.in11
-rw-r--r--editors/gedit/pkg-plist73
-rw-r--r--editors/ghex/Makefile4
9 files changed, 83 insertions, 54 deletions
diff --git a/editors/abiword/Makefile b/editors/abiword/Makefile
index b0611377ab37..fb3d0ee2f8fc 100644
--- a/editors/abiword/Makefile
+++ b/editors/abiword/Makefile
@@ -3,12 +3,12 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/editors/abiword/Makefile,v 1.8 2007/07/24 04:25:21 mezz Exp $
+# $MCom: ports/editors/abiword/Makefile,v 1.11 2008/08/19 00:45:06 marcus Exp $
#
PORTNAME= abiword
PORTVERSION= 2.6.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= editors
MASTER_SITES= http://www.abisource.com/downloads/%SUBDIR%/${PORTVERSION}/source/
MASTER_SITE_SUBDIR= abiword
@@ -66,14 +66,14 @@ PLIST_SUB+= DICT:="@comment "
#CONFIGURE_ARGS+= --disable-gnomeui
#.endif
-.if (defined(WITH_GUCHARMAP) || \
- exists(${LOCALBASE}/libdata/pkgconfig/gucharmap.pc)) && \
- !defined(WITHOUT_GUCHARMAP)
-LIB_DEPENDS+= gucharmap.6:${PORTSDIR}/deskutils/gucharmap
-CONFIGURE_ARGS+= --enable-gucharmap
-.else
+#.if (defined(WITH_GUCHARMAP) || \
+# exists(${LOCALBASE}/libdata/pkgconfig/gucharmap.pc)) && \
+# !defined(WITHOUT_GUCHARMAP)
+#LIB_DEPENDS+= gucharmap.6:${PORTSDIR}/deskutils/gucharmap
+#CONFIGURE_ARGS+= --enable-gucharmap
+#.else
CONFIGURE_ARGS+= --disable-gucharmap
-.endif
+#.endif
pre-everything::
@${ECHO_MSG} ""
diff --git a/editors/gedit-plugins/Makefile b/editors/gedit-plugins/Makefile
index 5c8789e5047e..4dddde49f8e1 100644
--- a/editors/gedit-plugins/Makefile
+++ b/editors/gedit-plugins/Makefile
@@ -3,12 +3,11 @@
# Whom: Adam Weinberger <adamw@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/editors/gedit-plugins/Makefile,v 1.28 2008/03/17 11:25:37 ahze Exp $
+# $MCom: ports/editors/gedit-plugins/Makefile,v 1.33 2008/10/26 20:28:27 marcus Exp $
#
PORTNAME= gedit-plugins
-PORTVERSION= 2.22.2
-PORTREVISION= 1
+PORTVERSION= 2.22.5
CATEGORIES= editors gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -26,7 +25,7 @@ USE_BZIP2= yes
USE_GMAKE= yes
USE_GETTEXT= yes
USE_AUTOTOOLS= libtool:15
-USE_GNOME= gnomehack gnomeprefix gnometarget intlhack
+USE_GNOME= gnomehack gnomeprefix intlhack
WANT_GNOME= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/editors/gedit-plugins/distinfo b/editors/gedit-plugins/distinfo
index 0e8e1a3f1eeb..875e28337cd6 100644
--- a/editors/gedit-plugins/distinfo
+++ b/editors/gedit-plugins/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/gedit-plugins-2.22.2.tar.bz2) = 556d4171db9a5a44fdc18f403cea5fdd
-SHA256 (gnome2/gedit-plugins-2.22.2.tar.bz2) = 9b445d10130b8f8f05c8a74a2b4f079cba1627a437ea65688cf623f757d48cfe
-SIZE (gnome2/gedit-plugins-2.22.2.tar.bz2) = 584763
+MD5 (gnome2/gedit-plugins-2.22.5.tar.bz2) = c2104d56b7aa78e14395648f8e235306
+SHA256 (gnome2/gedit-plugins-2.22.5.tar.bz2) = 98cd453525bcb53e725f8e49d5fa387019331e7df2d37101519d177141fbced9
+SIZE (gnome2/gedit-plugins-2.22.5.tar.bz2) = 592942
diff --git a/editors/gedit-plugins/pkg-plist b/editors/gedit-plugins/pkg-plist
index 61032d546627..97d3b375a387 100644
--- a/editors/gedit-plugins/pkg-plist
+++ b/editors/gedit-plugins/pkg-plist
@@ -88,7 +88,6 @@ share/locale/nb/LC_MESSAGES/gedit-plugins.mo
share/locale/ne/LC_MESSAGES/gedit-plugins.mo
share/locale/nl/LC_MESSAGES/gedit-plugins.mo
share/locale/nn/LC_MESSAGES/gedit-plugins.mo
-share/locale/no/LC_MESSAGES/gedit-plugins.mo
share/locale/oc/LC_MESSAGES/gedit-plugins.mo
share/locale/or/LC_MESSAGES/gedit-plugins.mo
share/locale/pa/LC_MESSAGES/gedit-plugins.mo
diff --git a/editors/gedit/Makefile b/editors/gedit/Makefile
index 2bca46670bba..fce39b346c96 100644
--- a/editors/gedit/Makefile
+++ b/editors/gedit/Makefile
@@ -3,15 +3,13 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/editors/gedit/Makefile,v 1.79 2008/03/15 19:59:30 ahze Exp $
+# $MCom: ports/editors/gedit/Makefile,v 1.91 2008/11/25 00:59:25 marcus Exp $
#
PORTNAME= gedit
-PORTVERSION= 2.22.3
-PORTREVISION= 1
+PORTVERSION= 2.24.2
CATEGORIES= editors gnome
-MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
+MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
@@ -21,13 +19,14 @@ BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:${PORTSDIR}/misc/iso-
LIB_DEPENDS= enchant.1:${PORTSDIR}/textproc/enchant
RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:${PORTSDIR}/misc/iso-codes
+USE_XORG= sm
USE_BZIP2= yes
USE_GETTEXT= yes
INSTALLS_OMF= yes
USE_LDCONFIG= yes
USE_GMAKE= yes
USE_AUTOTOOLS= libtool:15
-USE_GNOME= gnomeprefix gnomehack intlhack libgnomeui gtksourceview2 \
+USE_GNOME= gnomeprefix gnomehack intlhack gconf2 gtksourceview2 \
desktopfileutils gnomedocutils ltasneededhack
WANT_GNOME= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
diff --git a/editors/gedit/distinfo b/editors/gedit/distinfo
index e8334d677534..278869441025 100644
--- a/editors/gedit/distinfo
+++ b/editors/gedit/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/gedit-2.22.3.tar.bz2) = 9af45548bf8f2c335906c95877df4699
-SHA256 (gnome2/gedit-2.22.3.tar.bz2) = 1c9a97e5665bad9bc5c128a6dcc1be37683b619ff7255efad8f282b2184b8576
-SIZE (gnome2/gedit-2.22.3.tar.bz2) = 3884436
+MD5 (gnome2/gedit-2.24.2.tar.bz2) = 04bcf226edc5de3a4ac759e97e0e2e6e
+SHA256 (gnome2/gedit-2.24.2.tar.bz2) = 2efe1aa0b44caec9b29e2cf40222d27a18ae32e98f00bd70b2c056602940d203
+SIZE (gnome2/gedit-2.24.2.tar.bz2) = 4089534
diff --git a/editors/gedit/files/patch-plugins_externaltools_data_Makefile.in b/editors/gedit/files/patch-plugins_externaltools_data_Makefile.in
deleted file mode 100644
index aa069fd241ca..000000000000
--- a/editors/gedit/files/patch-plugins_externaltools_data_Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- plugins/externaltools/data/Makefile.in.orig Thu Jan 11 00:53:33 2007
-+++ plugins/externaltools/data/Makefile.in Thu Jan 11 00:53:41 2007
-@@ -471,7 +471,7 @@
- # (.desktop), which happens to be translated using intltool.
- $(tools_SCRIPTS): %: %.tool.in %.desktop $(TOOL_MERGE)
- perl $(TOOL_MERGE) -o $@ $< $(word 2,$^)
-- chmod --reference=$< $@
-+ chmod 0755 $@
- # Tell versions [3.59,3.63) of GNU make to not export all variables.
- # Otherwise a system limit (for SysV at least) may be exceeded.
- .NOEXPORT:
diff --git a/editors/gedit/pkg-plist b/editors/gedit/pkg-plist
index 59241235449a..4648fe458b3a 100644
--- a/editors/gedit/pkg-plist
+++ b/editors/gedit/pkg-plist
@@ -45,7 +45,8 @@ lib/gedit-2/plugins/docinfo.gedit-plugin
%%PYTHON%%lib/gedit-2/plugins/externaltools/outputpanel.py
%%PYTHON%%lib/gedit-2/plugins/externaltools/outputpanel.pyc
%%PYTHON%%lib/gedit-2/plugins/externaltools/outputpanel.pyo
-%%PYTHON%%lib/gedit-2/plugins/externaltools/tools.glade
+%%PYTHON%%lib/gedit-2/plugins/externaltools/outputpanel.ui
+%%PYTHON%%lib/gedit-2/plugins/externaltools/tools.ui
lib/gedit-2/plugins/filebrowser.gedit-plugin
lib/gedit-2/plugins/indent.gedit-plugin
lib/gedit-2/plugins/libchangecase.a
@@ -130,7 +131,7 @@ lib/gedit-2/plugins/sample.gedit-plugin
%%PYTHON%%lib/gedit-2/plugins/snippets/__init__.py
%%PYTHON%%lib/gedit-2/plugins/snippets/__init__.pyc
%%PYTHON%%lib/gedit-2/plugins/snippets/__init__.pyo
-%%PYTHON%%lib/gedit-2/plugins/snippets/snippets.glade
+%%PYTHON%%lib/gedit-2/plugins/snippets/snippets.ui
lib/gedit-2/plugins/sort.gedit-plugin
lib/gedit-2/plugins/spell.gedit-plugin
lib/gedit-2/plugins/taglist.gedit-plugin
@@ -171,19 +172,13 @@ share/applications/gedit.desktop
%%DOCSDIR%%/right.png
%%DOCSDIR%%/style.css
%%DOCSDIR%%/up.png
-share/gedit-2/glade/docinfo.glade2
-share/gedit-2/glade/gedit-encodings-dialog.glade
-share/gedit-2/glade/gedit-open-location-dialog.glade
-share/gedit-2/glade/gedit-preferences-dialog.glade
-share/gedit-2/glade/gedit-print-preferences.glade
-share/gedit-2/glade/gedit-search-dialog.glade
-share/gedit-2/glade/languages-dialog.glade2
-share/gedit-2/glade/sort.glade2
-share/gedit-2/glade/spell-checker.glade2
-share/gedit-2/glade/time.glade2
share/gedit-2/icons/gedit-plugin.png
share/gedit-2/logo/gedit-logo.png
+@exec mkdir -p %D/share/gedit-2/plugins/changecase
+share/gedit-2/plugins/docinfo/docinfo.ui
share/gedit-2/plugins/filebrowser/gedit-file-browser-widget-ui.xml
+@exec mkdir -p %D/share/gedit-2/plugins/indent
+@exec mkdir -p %D/share/gedit-2/plugins/sample
%%PYTHON%%share/gedit-2/plugins/snippets/c++.xml
%%PYTHON%%share/gedit-2/plugins/snippets/c.xml
%%PYTHON%%share/gedit-2/plugins/snippets/css.xml
@@ -204,6 +199,10 @@ share/gedit-2/plugins/filebrowser/gedit-file-browser-widget-ui.xml
%%PYTHON%%share/gedit-2/plugins/snippets/snippets.xml
%%PYTHON%%share/gedit-2/plugins/snippets/tcl.xml
%%PYTHON%%share/gedit-2/plugins/snippets/xml.xml
+share/gedit-2/plugins/sort/sort.ui
+share/gedit-2/plugins/spell/languages-dialog.ui
+share/gedit-2/plugins/spell/spell-checker.ui
+share/gedit-2/plugins/time/time.ui
%%PYTHON%%share/gedit-2/plugins/tools/build
%%PYTHON%%share/gedit-2/plugins/tools/open-terminal-here
%%PYTHON%%share/gedit-2/plugins/tools/remove-trailing-spaces
@@ -212,6 +211,11 @@ share/gedit-2/taglist/HTML.tags.gz
share/gedit-2/taglist/Latex.tags.gz
share/gedit-2/taglist/XSLT.tags.gz
share/gedit-2/taglist/XUL.tags.gz
+share/gedit-2/ui/gedit-encodings-dialog.ui
+share/gedit-2/ui/gedit-open-location-dialog.ui
+share/gedit-2/ui/gedit-preferences-dialog.ui
+share/gedit-2/ui/gedit-print-preferences.ui
+share/gedit-2/ui/gedit-search-dialog.ui
share/gedit-2/ui/gedit-ui.xml
share/gnome/help/gedit/C/figures/gedit_format_bold.png
share/gnome/help/gedit/C/figures/gedit_format_italic.png
@@ -229,6 +233,14 @@ share/gnome/help/gedit/bg/figures/gedit_recent_files_menu_icon.png
share/gnome/help/gedit/bg/figures/gedit_window.png
share/gnome/help/gedit/bg/gedit.xml
share/gnome/help/gedit/bg/legal.xml
+share/gnome/help/gedit/da/figures/gedit_format_bold.png
+share/gnome/help/gedit/da/figures/gedit_format_italic.png
+share/gnome/help/gedit/da/figures/gedit_format_strikethrough.png
+share/gnome/help/gedit/da/figures/gedit_format_underline.png
+share/gnome/help/gedit/da/figures/gedit_recent_files_menu_icon.png
+share/gnome/help/gedit/da/figures/gedit_window.png
+share/gnome/help/gedit/da/gedit.xml
+share/gnome/help/gedit/da/legal.xml
share/gnome/help/gedit/de/figures/gedit_format_bold.png
share/gnome/help/gedit/de/figures/gedit_format_italic.png
share/gnome/help/gedit/de/figures/gedit_format_strikethrough.png
@@ -249,6 +261,14 @@ share/gnome/help/gedit/eu/figures/gedit_recent_files_menu_icon.png
share/gnome/help/gedit/eu/figures/gedit_window.png
share/gnome/help/gedit/eu/gedit.xml
share/gnome/help/gedit/eu/legal.xml
+share/gnome/help/gedit/fi/figures/gedit_format_bold.png
+share/gnome/help/gedit/fi/figures/gedit_format_italic.png
+share/gnome/help/gedit/fi/figures/gedit_format_strikethrough.png
+share/gnome/help/gedit/fi/figures/gedit_format_underline.png
+share/gnome/help/gedit/fi/figures/gedit_recent_files_menu_icon.png
+share/gnome/help/gedit/fi/figures/gedit_window.png
+share/gnome/help/gedit/fi/gedit.xml
+share/gnome/help/gedit/fi/legal.xml
share/gnome/help/gedit/fr/figures/gedit_format_bold.png
share/gnome/help/gedit/fr/figures/gedit_format_italic.png
share/gnome/help/gedit/fr/figures/gedit_format_strikethrough.png
@@ -399,8 +419,10 @@ share/locale/ka/LC_MESSAGES/gedit.mo
share/locale/kn/LC_MESSAGES/gedit.mo
share/locale/ko/LC_MESSAGES/gedit.mo
share/locale/ku/LC_MESSAGES/gedit.mo
+share/locale/la/LC_MESSAGES/gedit.mo
share/locale/lt/LC_MESSAGES/gedit.mo
share/locale/lv/LC_MESSAGES/gedit.mo
+share/locale/mai/LC_MESSAGES/gedit.mo
share/locale/mg/LC_MESSAGES/gedit.mo
share/locale/mi/LC_MESSAGES/gedit.mo
share/locale/mk/LC_MESSAGES/gedit.mo
@@ -416,6 +438,7 @@ share/locale/oc/LC_MESSAGES/gedit.mo
share/locale/or/LC_MESSAGES/gedit.mo
share/locale/pa/LC_MESSAGES/gedit.mo
share/locale/pl/LC_MESSAGES/gedit.mo
+share/locale/ps/LC_MESSAGES/gedit.mo
share/locale/pt/LC_MESSAGES/gedit.mo
share/locale/pt_BR/LC_MESSAGES/gedit.mo
share/locale/ro/LC_MESSAGES/gedit.mo
@@ -426,7 +449,7 @@ share/locale/sk/LC_MESSAGES/gedit.mo
share/locale/sl/LC_MESSAGES/gedit.mo
share/locale/sq/LC_MESSAGES/gedit.mo
share/locale/sr/LC_MESSAGES/gedit.mo
-share/locale/sr@Latn/LC_MESSAGES/gedit.mo
+share/locale/sr@latin/LC_MESSAGES/gedit.mo
share/locale/sv/LC_MESSAGES/gedit.mo
share/locale/ta/LC_MESSAGES/gedit.mo
share/locale/te/LC_MESSAGES/gedit.mo
@@ -442,9 +465,11 @@ share/locale/zh_HK/LC_MESSAGES/gedit.mo
share/locale/zh_TW/LC_MESSAGES/gedit.mo
share/omf/gedit/gedit-C.omf
share/omf/gedit/gedit-bg.omf
+share/omf/gedit/gedit-da.omf
share/omf/gedit/gedit-de.omf
share/omf/gedit/gedit-es.omf
share/omf/gedit/gedit-eu.omf
+share/omf/gedit/gedit-fi.omf
share/omf/gedit/gedit-fr.omf
share/omf/gedit/gedit-hu.omf
share/omf/gedit/gedit-it.omf
@@ -488,12 +513,16 @@ share/omf/gedit/gedit-zh_TW.omf
@dirrm share/gnome/help/gedit/hu
@dirrm share/gnome/help/gedit/fr/figures
@dirrm share/gnome/help/gedit/fr
+@dirrm share/gnome/help/gedit/fi/figures
+@dirrm share/gnome/help/gedit/fi
@dirrm share/gnome/help/gedit/eu/figures
@dirrm share/gnome/help/gedit/eu
@dirrm share/gnome/help/gedit/es/figures
@dirrm share/gnome/help/gedit/es
@dirrm share/gnome/help/gedit/de/figures
@dirrm share/gnome/help/gedit/de
+@dirrm share/gnome/help/gedit/da/figures
+@dirrm share/gnome/help/gedit/da
@dirrm share/gnome/help/gedit/bg/figures
@dirrm share/gnome/help/gedit/bg
@dirrm share/gnome/help/gedit/C/figures
@@ -502,15 +531,22 @@ share/omf/gedit/gedit-zh_TW.omf
@dirrm share/gedit-2/ui
@dirrm share/gedit-2/taglist
%%PYTHON%%@dirrm share/gedit-2/plugins/tools
+@dirrm share/gedit-2/plugins/time
+@dirrm share/gedit-2/plugins/spell
+@dirrm share/gedit-2/plugins/sort
%%PYTHON%%@dirrm share/gedit-2/plugins/snippets/lang
%%PYTHON%%@dirrm share/gedit-2/plugins/snippets
+@dirrm share/gedit-2/plugins/sample
+@dirrm share/gedit-2/plugins/indent
@dirrm share/gedit-2/plugins/filebrowser
+@dirrm share/gedit-2/plugins/docinfo
+@dirrm share/gedit-2/plugins/changecase
@dirrm share/gedit-2/plugins
@dirrm share/gedit-2/logo
@dirrm share/gedit-2/icons
-@dirrm share/gedit-2/glade
@dirrm share/gedit-2
@dirrm %%DOCSDIR%%
+@dirrmtry share/applications
@dirrmtry libexec/gedit-2
%%PYTHON%%@dirrm lib/gedit-2/plugins/snippets
%%PYTHON%%@dirrm lib/gedit-2/plugins/pythonconsole
@@ -521,17 +557,20 @@ share/omf/gedit/gedit-zh_TW.omf
@dirrm include/gedit-%%VERSION%%
@exec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
@unexec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
-@dirrmtry share/applications
@dirrmtry share/locale/zh_HK/LC_MESSAGES
@dirrmtry share/locale/zh_HK
@dirrmtry share/locale/xh/LC_MESSAGES
@dirrmtry share/locale/xh
@dirrmtry share/locale/te/LC_MESSAGES
@dirrmtry share/locale/te
+@dirrmtry share/locale/sr@latin/LC_MESSAGES
+@dirrmtry share/locale/sr@latin
@dirrmtry share/locale/si/LC_MESSAGES
@dirrmtry share/locale/si
@dirrmtry share/locale/rw/LC_MESSAGES
@dirrmtry share/locale/rw
+@dirrmtry share/locale/ps/LC_MESSAGES
+@dirrmtry share/locale/ps
@dirrmtry share/locale/oc/LC_MESSAGES
@dirrmtry share/locale/oc
@dirrmtry share/locale/mr/LC_MESSAGES
@@ -540,6 +579,10 @@ share/omf/gedit/gedit-zh_TW.omf
@dirrmtry share/locale/mi
@dirrmtry share/locale/mg/LC_MESSAGES
@dirrmtry share/locale/mg
+@dirrmtry share/locale/mai/LC_MESSAGES
+@dirrmtry share/locale/mai
+@dirrmtry share/locale/la/LC_MESSAGES
+@dirrmtry share/locale/la
@dirrmtry share/locale/ku/LC_MESSAGES
@dirrmtry share/locale/ku
@dirrmtry share/locale/hy/LC_MESSAGES
diff --git a/editors/ghex/Makefile b/editors/ghex/Makefile
index d56e68c86b19..9f37f883e2d5 100644
--- a/editors/ghex/Makefile
+++ b/editors/ghex/Makefile
@@ -3,7 +3,7 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/editors/ghex/Makefile,v 1.11 2008/02/27 04:39:06 mezz Exp $
+# $MCom: ports/editors/ghex/Makefile,v 1.13 2008/08/23 18:22:59 mezz Exp $
#
PORTNAME= ghex
@@ -18,7 +18,7 @@ COMMENT= GNOME 2 hex editor
USE_BZIP2= yes
USE_GMAKE= yes
-USE_GNOME= gnomeprefix gnomehack intlhack gail libgnomeprintui libgnomeui \
+USE_GNOME= gnomeprefix gnomehack intlhack libgnomeprintui libgnomeui \
gnomedocutils
USE_GETTEXT= yes
GNU_CONFIGURE= yes