aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
Diffstat (limited to 'editors')
-rw-r--r--editors/pdfedit/Makefile5
-rw-r--r--editors/tea/Makefile2
2 files changed, 5 insertions, 2 deletions
diff --git a/editors/pdfedit/Makefile b/editors/pdfedit/Makefile
index f519edfda018..18265cc60783 100644
--- a/editors/pdfedit/Makefile
+++ b/editors/pdfedit/Makefile
@@ -12,6 +12,9 @@ COMMENT= PDF document manipulating library
LICENSE= GPLv2
+BROKEN_powerpc64= fails to configure: error: Could not link against boost_program_options
+BROKEN_sparc64= fails to configure: error: Could not link against boost_program_options
+
LIB_DEPENDS= libboost_filesystem.so:devel/boost-libs \
libfreetype.so:print/freetype2 \
libpng.so:graphics/png \
@@ -34,8 +37,6 @@ PORTDOCS= Changelog README AUTHORS
OPTIONS_DEFINE= DOCS
-BROKEN_sparc64= Fails to configure: error: Could not link against boost_program_options
-
post-extract:
${INSTALL_DATA} ${WRKSRC}/doc/AUTHORS ${WRKSRC}
diff --git a/editors/tea/Makefile b/editors/tea/Makefile
index 5dc558d52c71..41a1acdc1033 100644
--- a/editors/tea/Makefile
+++ b/editors/tea/Makefile
@@ -11,6 +11,8 @@ COMMENT= Simple and powerful Qt-based text editor
LICENSE= GPLv3
+BROKEN_powerpc64= fails to link: spellchecker.o:(.text+0xd2c): undefined reference to Hunspell::remove(std::string const&)
+
OPTIONS_SINGLE= TOOLKITS
OPTIONS_SINGLE_TOOLKITS= QT4 QT5
OPTIONS_DEFINE= DOCS