aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
Diffstat (limited to 'editors')
-rw-r--r--editors/Makefile1
-rw-r--r--editors/qemacs/Makefile82
-rw-r--r--editors/qemacs/distinfo3
-rw-r--r--editors/qemacs/files/patch-charset.c11
-rw-r--r--editors/qemacs/files/patch-configure11
-rw-r--r--editors/qemacs/files/patch-qe.h22
-rw-r--r--editors/qemacs/files/patch-tty.c11
-rw-r--r--editors/qemacs/files/patch-unicode_join.c10
-rw-r--r--editors/qemacs/files/patch-x11.c11
-rw-r--r--editors/qemacs/pkg-descr23
10 files changed, 0 insertions, 185 deletions
diff --git a/editors/Makefile b/editors/Makefile
index b06b0bda46e3..e202778702d2 100644
--- a/editors/Makefile
+++ b/editors/Makefile
@@ -179,7 +179,6 @@
SUBDIR += psgml
SUBDIR += puff
SUBDIR += py-room
- SUBDIR += qemacs
SUBDIR += richtext
SUBDIR += rospell
SUBDIR += rox-edit
diff --git a/editors/qemacs/Makefile b/editors/qemacs/Makefile
deleted file mode 100644
index 04511d6e63e7..000000000000
--- a/editors/qemacs/Makefile
+++ /dev/null
@@ -1,82 +0,0 @@
-# New ports collection makefile for: qemacs
-# Date created: 27 January 2003
-# Whom: Brad Davis <so14k@so14k.com> et al
-#
-# $FreeBSD$
-#
-
-PORTNAME= qemacs
-PORTVERSION= 0.3.1
-PORTREVISION= 3
-CATEGORIES= editors
-MASTER_SITES= http://fabrice.bellard.free.fr/qemacs/
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Quick Emacs - a very small but powerful UNIX editor
-
-USE_GMAKE= yes
-HAS_CONFIGURE= yes
-CONFIGURE_ARGS= --prefix="${PREFIX}" --make="${GMAKE}" --cc="${CC}" \
- --extra-cflags="${CFLAGS}" --extra-ldflags="${LDFLAGS}"
-USE_GCC= 3.4
-
-DEPRECATED= depends on old version of GCC, no maintainer, not used by any other port, dead upstream
-EXPIRATION_DATE=2009-10-26
-
-DATADIR= ${PREFIX}/share/qe
-
-MAN1= qe.1
-MLINKS= qe.1 qemacs.1
-PORTDOCS= qe-doc.html
-PLIST_FILES= bin/html2png bin/qe bin/qemacs \
- %%DATADIR%%/kmaps %%DATADIR%%/ligatures
-PLIST_DIRS= %%DATADIR%%
-
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "amd64"
-IGNORE= crashes on startup
-.endif
-
-.if defined(WITHOUT_PNG)
-CONFIGURE_ARGS+= --disable-png
-.else
-LIB_DEPENDS+= png.5:${PORTSDIR}/graphics/png
-CFLAGS+= `libpng-config --I_opts`
-LDFLAGS= `libpng-config --L_opts`
-.endif
-
-.if defined(WITHOUT_X11)
-PKGNAMESUFFIX= -nox11
-CONFIGURE_ARGS+= --disable-x11
-.else
-USE_XORG= x11 xv xext
-CFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-.endif
-
-post-patch:
- @${FIND} ${WRKSRC} -name "Makefile" | ${XARGS} ${REINPLACE_CMD} -e \
- 's|-Wall -g|-Wall|g ; \
- s|-m.*386||g ; \
- s|-ldl||g ; \
- s|-L/usr/X11R6/lib||g ; \
- s|make -C|$$(MAKE) -C|g ; \
- s|HOST_CC|CC|g'
- @${REINPLACE_CMD} -e 's|/usr/share/doc/qemacs/|${DOCSDIR}/|g ; \
- s|README.gz|qe-doc.html|g' ${WRKSRC}/qe.1
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/html2png ${PREFIX}/bin
- ${INSTALL_PROGRAM} ${WRKSRC}/qe ${PREFIX}/bin
- ${LN} -sf qe ${PREFIX}/bin/qemacs
- ${INSTALL_MAN} ${WRKSRC}/qe.1 ${MANPREFIX}/man/man1
- @${MKDIR} ${DATADIR}
- ${INSTALL_DATA} ${WRKSRC}/kmaps ${DATADIR}
- ${INSTALL_DATA} ${WRKSRC}/ligatures ${DATADIR}
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/qe-doc.html ${DOCSDIR}
-.endif
-
-.include <bsd.port.post.mk>
diff --git a/editors/qemacs/distinfo b/editors/qemacs/distinfo
deleted file mode 100644
index 9ec3b68298cc..000000000000
--- a/editors/qemacs/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 (qemacs-0.3.1.tar.gz) = 74d85dee9861d494bf1f9c53bbc85298
-SHA256 (qemacs-0.3.1.tar.gz) = a3db57e09729d8c83be5ff9ab028ece173d8f5f10aaf61ca41f88aecb64996c7
-SIZE (qemacs-0.3.1.tar.gz) = 809124
diff --git a/editors/qemacs/files/patch-charset.c b/editors/qemacs/files/patch-charset.c
deleted file mode 100644
index d8796d70e349..000000000000
--- a/editors/qemacs/files/patch-charset.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- charset.c.orig Tue Apr 22 07:01:42 2003
-+++ charset.c Thu Jan 18 13:56:10 2007
-@@ -20,7 +20,7 @@
-
- QECharset *first_charset = NULL;
-
--extern QECharset charset_7bit;
-+static QECharset charset_7bit;
-
- /* specific tables */
- static unsigned short table_idem[256];
diff --git a/editors/qemacs/files/patch-configure b/editors/qemacs/files/patch-configure
deleted file mode 100644
index 6a141f1d05d9..000000000000
--- a/editors/qemacs/files/patch-configure
+++ /dev/null
@@ -1,11 +0,0 @@
---- configure.orig Tue Apr 22 07:01:43 2003
-+++ configure Thu Jan 18 12:39:56 2007
-@@ -311,7 +311,7 @@
- head $source_path/VERSION >>config.mak
- echo "" >>config.mak
- echo -n "#define QE_VERSION \"" >> $TMPH
--head $source_path/VERSION >> $TMPH
-+echo -n `head $source_path/VERSION` >> $TMPH
- echo "\"" >> $TMPH
- if test "$network" = "yes" ; then
- echo "#define CONFIG_NETWORK 1" >> $TMPH
diff --git a/editors/qemacs/files/patch-qe.h b/editors/qemacs/files/patch-qe.h
deleted file mode 100644
index 3756ddf0de61..000000000000
--- a/editors/qemacs/files/patch-qe.h
+++ /dev/null
@@ -1,22 +0,0 @@
---- qe.h.orig 2003-04-22 00:01:42.000000000 +0200
-+++ qe.h 2005-06-07 16:02:27.000000000 +0200
-@@ -576,10 +576,18 @@
-
- /* make sure that the keyword is not disabled by glibc (TINYC case) */
- #undef __attribute__
--
-+#if __GNUC__ < 3 || (__GNUC__ == 3 && __GNUC_MINOR__ < 3)
- /* same method as the linux kernel... */
- #define __init_call __attribute__ ((unused,__section__ (".initcall.init")))
- #define __exit_call __attribute__ ((unused,__section__ (".exitcall.exit")))
-+#else
-+#undef __attribute_used__
-+#define __attribute_used__ __attribute__((__used__))
-+#define __init_call __attribute_used__ __attribute__((__section__ (".initcall.init")))
-+#define __exit_call __attribute_used__ __attribute__((__section__ (".exitcall.exit")))
-+
-+#endif
-+
-
- #define qe_module_init(fn) \
- static int (*__initcall_##fn)(void) __init_call = fn
diff --git a/editors/qemacs/files/patch-tty.c b/editors/qemacs/files/patch-tty.c
deleted file mode 100644
index 36726f020dd5..000000000000
--- a/editors/qemacs/files/patch-tty.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- tty.c.orig Tue Apr 22 07:01:42 2003
-+++ tty.c Thu Jan 18 13:56:41 2007
-@@ -70,7 +70,7 @@
- return 1;
- }
-
--extern QEDisplay tty_dpy;
-+static QEDisplay tty_dpy;
-
- static int term_init(QEditScreen *s, int w, int h)
- {
diff --git a/editors/qemacs/files/patch-unicode_join.c b/editors/qemacs/files/patch-unicode_join.c
deleted file mode 100644
index 69e27ec48a55..000000000000
--- a/editors/qemacs/files/patch-unicode_join.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- unicode_join.c.orig Sat Aug 21 20:08:14 2004
-+++ unicode_join.c Sat Aug 21 20:08:27 2004
-@@ -182,6 +182,7 @@
- *q++ = l1;
- i++;
- found:
-+ break;
- }
- }
- return q - buf_out;
diff --git a/editors/qemacs/files/patch-x11.c b/editors/qemacs/files/patch-x11.c
deleted file mode 100644
index 2e0654fbf9be..000000000000
--- a/editors/qemacs/files/patch-x11.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- x11.c.orig Tue Apr 22 07:01:42 2003
-+++ x11.c Thu Jan 18 13:57:10 2007
-@@ -76,7 +76,7 @@
- static CSSRect update_rects[UPDATE_MAX_REGIONS];
- #endif
-
--extern QEDisplay x11_dpy;
-+static QEDisplay x11_dpy;
- static int visual_depth;
-
- static int force_tty = 0;
diff --git a/editors/qemacs/pkg-descr b/editors/qemacs/pkg-descr
deleted file mode 100644
index 15b12eebf878..000000000000
--- a/editors/qemacs/pkg-descr
+++ /dev/null
@@ -1,23 +0,0 @@
-QEmacs has features other big editors lack:
-* Full screen editor with an Emacs look and feel with all Emacs common
- features: multi-buffer, multi-window, command mode, universal argument,
- keyboard macros, config file with C like syntax, minibuffer with
- completion and history.
-* Can edit files of hundreds of Megabytes without being slow by using a
- highly optimized internal representation and by mmaping the file.
-* Full UTF8 support, including bidirectional editing respecting the Unicode
- bidi algorithm. Arabic and Indic scripts handling (in progress).
-* C mode: coloring with immediate update. Emacs like auto-indent.
-* Shell mode: colorized VT100 emulation so that your shell work exactly as
- you expect. Compile mode with next/prev error.
-* Input methods for most languages, including Chinese (input methods come
- from the Yudit editor).
-* Hexadecimal editing mode with insertion and block commands. Unicode hexa
- editing of UTF8 files also supported.
-* Works on any VT100 terminals without termcap. UTF8 VT100 support included
- with double width glyphs.
-* X11 support. Support multiple proportionnal fonts at the same time (as
- XEmacs). X Input methods supported. Xft extension supported for anti
- aliased font display.
-
-WWW: http://fabrice.bellard.free.fr/qemacs/