aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
Diffstat (limited to 'editors')
-rw-r--r--editors/gedit-plugins/Makefile10
-rw-r--r--editors/gedit-plugins/distinfo6
-rw-r--r--editors/gedit-plugins/pkg-plist5
-rw-r--r--editors/gedit/Makefile11
-rw-r--r--editors/gedit/distinfo6
-rw-r--r--editors/gedit/files/patch-docs_reference_Makefile.in13
-rw-r--r--editors/gedit/pkg-plist35
-rw-r--r--editors/ghex/Makefile4
-rw-r--r--editors/ghex/distinfo6
-rw-r--r--editors/ghex/pkg-plist2
10 files changed, 71 insertions, 27 deletions
diff --git a/editors/gedit-plugins/Makefile b/editors/gedit-plugins/Makefile
index f3b9067d69f9..a3c17dcf6afe 100644
--- a/editors/gedit-plugins/Makefile
+++ b/editors/gedit-plugins/Makefile
@@ -3,14 +3,14 @@
# Whom: Adam Weinberger <adamw@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/editors/gedit-plugins/Makefile,v 1.24 2007/09/30 17:15:47 mezz Exp $
+# $MCom: ports/editors/gedit-plugins/Makefile,v 1.28 2008/03/17 11:25:37 ahze Exp $
#
PORTNAME= gedit-plugins
-PORTVERSION= 2.20.0
+PORTVERSION= 2.22.0
+PORTREVISION= 2
CATEGORIES= editors gnome
-MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
+MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
@@ -26,7 +26,7 @@ USE_BZIP2= yes
USE_XLIB= yes
USE_GMAKE= yes
USE_GETTEXT= yes
-GNU_CONFIGURE= yes
+USE_AUTOTOOLS= libtool:15
USE_GNOME= gnomehack gnomeprefix gnometarget intlhack
WANT_GNOME= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
diff --git a/editors/gedit-plugins/distinfo b/editors/gedit-plugins/distinfo
index cecfe8cb1c1b..a4f24cd8bb3c 100644
--- a/editors/gedit-plugins/distinfo
+++ b/editors/gedit-plugins/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/gedit-plugins-2.20.0.tar.bz2) = ec5be3d10ca4da4b33effad207ef35e9
-SHA256 (gnome2/gedit-plugins-2.20.0.tar.bz2) = 35786e5969340f1028522bc4026cce20fcc62bfc69d9eb9ef094fbc745e4e884
-SIZE (gnome2/gedit-plugins-2.20.0.tar.bz2) = 555944
+MD5 (gnome2/gedit-plugins-2.22.0.tar.bz2) = 8ca32c74dbc23a3fc456dadc258e1215
+SHA256 (gnome2/gedit-plugins-2.22.0.tar.bz2) = 44a7cf6aa9d1f4c31478ed8f75000723b4bfc2a5ff0e45bea10ea0d66392768e
+SIZE (gnome2/gedit-plugins-2.22.0.tar.bz2) = 587272
diff --git a/editors/gedit-plugins/pkg-plist b/editors/gedit-plugins/pkg-plist
index c6abbc83d0aa..61032d546627 100644
--- a/editors/gedit-plugins/pkg-plist
+++ b/editors/gedit-plugins/pkg-plist
@@ -23,8 +23,10 @@ lib/gedit-2/plugins/gpdefs.pyo
%%PYTHON%%lib/gedit-2/plugins/joinlines.py
%%PYTHON%%lib/gedit-2/plugins/joinlines.pyc
%%PYTHON%%lib/gedit-2/plugins/joinlines.pyo
+lib/gedit-2/plugins/libcharmap.a
lib/gedit-2/plugins/libcharmap.la
lib/gedit-2/plugins/libcharmap.so
+lib/gedit-2/plugins/libshowtabbar.a
lib/gedit-2/plugins/libshowtabbar.la
lib/gedit-2/plugins/libshowtabbar.so
%%PYTHON%%lib/gedit-2/plugins/sessionsaver.gedit-plugin
@@ -50,6 +52,7 @@ lib/gedit-2/plugins/showtabbar.gedit-plugin
share/locale/ar/LC_MESSAGES/gedit-plugins.mo
share/locale/az/LC_MESSAGES/gedit-plugins.mo
share/locale/be/LC_MESSAGES/gedit-plugins.mo
+share/locale/be@latin/LC_MESSAGES/gedit-plugins.mo
share/locale/bg/LC_MESSAGES/gedit-plugins.mo
share/locale/ca/LC_MESSAGES/gedit-plugins.mo
share/locale/cs/LC_MESSAGES/gedit-plugins.mo
@@ -119,3 +122,5 @@ share/locale/zh_TW/LC_MESSAGES/gedit-plugins.mo
@dirrmtry share/locale/oc
@dirrmtry share/locale/dz/LC_MESSAGES
@dirrmtry share/locale/dz
+@dirrmtry share/locale/be@latin/LC_MESSAGES
+@dirrmtry share/locale/be@latin
diff --git a/editors/gedit/Makefile b/editors/gedit/Makefile
index 371ac2c9ae33..5c667f3c783f 100644
--- a/editors/gedit/Makefile
+++ b/editors/gedit/Makefile
@@ -3,11 +3,12 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports-stable/editors/gedit/Makefile,v 1.9 2007/12/02 02:00:32 marcus Exp $
+# $MCom: ports/editors/gedit/Makefile,v 1.79 2008/03/15 19:59:30 ahze Exp $
#
PORTNAME= gedit
-PORTVERSION= 2.20.4
+PORTVERSION= 2.22.0
+PORTREVISION= 1
CATEGORIES= editors gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
@@ -26,9 +27,9 @@ USE_XLIB= yes
INSTALLS_OMF= yes
USE_LDCONFIG= yes
USE_GMAKE= yes
-GNU_CONFIGURE= yes
-USE_GNOME= gnomeprefix gnomehack intlhack \
- libgnomeprintui libgnomeui eel2 gtksourceview2 desktopfileutils
+USE_AUTOTOOLS= libtool:15
+USE_GNOME= gnomeprefix gnomehack intlhack libgnomeui gtksourceview2 \
+ desktopfileutils gnomedocutils ltasneededhack
WANT_GNOME= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/editors/gedit/distinfo b/editors/gedit/distinfo
index d596819d3b96..471a4ab18cca 100644
--- a/editors/gedit/distinfo
+++ b/editors/gedit/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/gedit-2.20.4.tar.bz2) = 6c7d74f9b4339c9ec9e81f6ea3eb19c9
-SHA256 (gnome2/gedit-2.20.4.tar.bz2) = 695b70582734b3ba04e0d76970bf1dd722a22ef027f8a749ec3fb05e40e83121
-SIZE (gnome2/gedit-2.20.4.tar.bz2) = 3809006
+MD5 (gnome2/gedit-2.22.0.tar.bz2) = ce2e485d7639ed09a3e3b5a791df805a
+SHA256 (gnome2/gedit-2.22.0.tar.bz2) = ffad28c732e1a9b250d6d3c5b92a252b6ac87741e4d1fd9daba9940fde399e2e
+SIZE (gnome2/gedit-2.22.0.tar.bz2) = 3883104
diff --git a/editors/gedit/files/patch-docs_reference_Makefile.in b/editors/gedit/files/patch-docs_reference_Makefile.in
new file mode 100644
index 000000000000..c2d56a9553bc
--- /dev/null
+++ b/editors/gedit/files/patch-docs_reference_Makefile.in
@@ -0,0 +1,13 @@
+--- docs/reference/Makefile.in.orig 2007-12-21 11:30:30.000000000 +0100
++++ docs/reference/Makefile.in 2007-12-21 11:55:58.000000000 +0100
+@@ -690,8 +690,8 @@
+ done; \
+ echo '-- Installing $(srcdir)/html/index.sgml' ; \
+ $(INSTALL_DATA) $(srcdir)/html/index.sgml $(DESTDIR)$(TARGET_DIR) || :; \
+- which gtkdoc-rebase >/dev/null && \
+- gtkdoc-rebase --relative --dest-dir=$(DESTDIR) --html-dir=$(DESTDIR)$(TARGET_DIR) ; \
++# which gtkdoc-rebase >/dev/null && \
++# gtkdoc-rebase --relative --dest-dir=$(DESTDIR) --html-dir=$(DESTDIR)$(TARGET_DIR) ; \
+ fi
+
+ uninstall-local:
diff --git a/editors/gedit/pkg-plist b/editors/gedit/pkg-plist
index 31b00b2ab69f..59241235449a 100644
--- a/editors/gedit/pkg-plist
+++ b/editors/gedit/pkg-plist
@@ -21,7 +21,6 @@ include/gedit-%%VERSION%%/gedit/gedit-tab.h
include/gedit-%%VERSION%%/gedit/gedit-utils.h
include/gedit-%%VERSION%%/gedit/gedit-view.h
include/gedit-%%VERSION%%/gedit/gedit-window.h
-lib/gedit-2/gedit-bugreport.sh
lib/gedit-2/plugins/changecase.gedit-plugin
lib/gedit-2/plugins/docinfo.gedit-plugin
%%PYTHON%%lib/gedit-2/plugins/externaltools.gedit-plugin
@@ -49,24 +48,34 @@ lib/gedit-2/plugins/docinfo.gedit-plugin
%%PYTHON%%lib/gedit-2/plugins/externaltools/tools.glade
lib/gedit-2/plugins/filebrowser.gedit-plugin
lib/gedit-2/plugins/indent.gedit-plugin
+lib/gedit-2/plugins/libchangecase.a
lib/gedit-2/plugins/libchangecase.la
lib/gedit-2/plugins/libchangecase.so
+lib/gedit-2/plugins/libdocinfo.a
lib/gedit-2/plugins/libdocinfo.la
lib/gedit-2/plugins/libdocinfo.so
+lib/gedit-2/plugins/libfilebrowser.a
lib/gedit-2/plugins/libfilebrowser.la
lib/gedit-2/plugins/libfilebrowser.so
+lib/gedit-2/plugins/libindent.a
lib/gedit-2/plugins/libindent.la
lib/gedit-2/plugins/libindent.so
+lib/gedit-2/plugins/libmodelines.a
lib/gedit-2/plugins/libmodelines.la
lib/gedit-2/plugins/libmodelines.so
+lib/gedit-2/plugins/libsample.a
lib/gedit-2/plugins/libsample.la
lib/gedit-2/plugins/libsample.so
+lib/gedit-2/plugins/libsort.a
lib/gedit-2/plugins/libsort.la
lib/gedit-2/plugins/libsort.so
+lib/gedit-2/plugins/libspell.a
lib/gedit-2/plugins/libspell.la
lib/gedit-2/plugins/libspell.so
+lib/gedit-2/plugins/libtaglist.a
lib/gedit-2/plugins/libtaglist.la
lib/gedit-2/plugins/libtaglist.so
+lib/gedit-2/plugins/libtime.a
lib/gedit-2/plugins/libtime.la
lib/gedit-2/plugins/libtime.so
lib/gedit-2/plugins/modelines.gedit-plugin
@@ -127,6 +136,7 @@ lib/gedit-2/plugins/spell.gedit-plugin
lib/gedit-2/plugins/taglist.gedit-plugin
lib/gedit-2/plugins/time.gedit-plugin
libdata/pkgconfig/gedit-%%VERSION%%.pc
+libexec/gedit-2/gedit-bugreport.sh
share/applications/gedit.desktop
%%DOCSDIR%%/GeditApp.html
%%DOCSDIR%%/GeditDocument.html
@@ -136,14 +146,14 @@ share/applications/gedit.desktop
%%DOCSDIR%%/GeditNotebook.html
%%DOCSDIR%%/GeditPanel.html
%%DOCSDIR%%/GeditPlugin.html
-%%DOCSDIR%%/GeditPrintJob.html
-%%DOCSDIR%%/GeditPrintJobPreview.html
%%DOCSDIR%%/GeditProgressMessageArea.html
%%DOCSDIR%%/GeditStatusbar.html
%%DOCSDIR%%/GeditTab.html
%%DOCSDIR%%/GeditView.html
%%DOCSDIR%%/GeditWindow.html
%%DOCSDIR%%/ch01.html
+%%DOCSDIR%%/gedit-GeditPrintJob.html
+%%DOCSDIR%%/gedit-GeditPrintJobPreview.html
%%DOCSDIR%%/gedit-gedit-convert.html
%%DOCSDIR%%/gedit-gedit-debug.html
%%DOCSDIR%%/gedit-gedit-encodings.html
@@ -164,8 +174,8 @@ share/applications/gedit.desktop
share/gedit-2/glade/docinfo.glade2
share/gedit-2/glade/gedit-encodings-dialog.glade
share/gedit-2/glade/gedit-open-location-dialog.glade
-share/gedit-2/glade/gedit-page-setup-dialog.glade
share/gedit-2/glade/gedit-preferences-dialog.glade
+share/gedit-2/glade/gedit-print-preferences.glade
share/gedit-2/glade/gedit-search-dialog.glade
share/gedit-2/glade/languages-dialog.glade2
share/gedit-2/glade/sort.glade2
@@ -287,6 +297,14 @@ share/gnome/help/gedit/oc/figures/gedit_recent_files_menu_icon.png
share/gnome/help/gedit/oc/figures/gedit_window.png
share/gnome/help/gedit/oc/gedit.xml
share/gnome/help/gedit/oc/legal.xml
+share/gnome/help/gedit/pt_BR/figures/gedit_format_bold.png
+share/gnome/help/gedit/pt_BR/figures/gedit_format_italic.png
+share/gnome/help/gedit/pt_BR/figures/gedit_format_strikethrough.png
+share/gnome/help/gedit/pt_BR/figures/gedit_format_underline.png
+share/gnome/help/gedit/pt_BR/figures/gedit_recent_files_menu_icon.png
+share/gnome/help/gedit/pt_BR/figures/gedit_window.png
+share/gnome/help/gedit/pt_BR/gedit.xml
+share/gnome/help/gedit/pt_BR/legal.xml
share/gnome/help/gedit/ro/figures/gedit_window.png
share/gnome/help/gedit/ro/gedit.xml
share/gnome/help/gedit/ro/legal.xml
@@ -341,6 +359,7 @@ share/gnome/help/gedit/zh_TW/legal.xml
share/locale/af/LC_MESSAGES/gedit.mo
share/locale/am/LC_MESSAGES/gedit.mo
share/locale/ar/LC_MESSAGES/gedit.mo
+share/locale/as/LC_MESSAGES/gedit.mo
share/locale/az/LC_MESSAGES/gedit.mo
share/locale/be/LC_MESSAGES/gedit.mo
share/locale/be@latin/LC_MESSAGES/gedit.mo
@@ -432,6 +451,7 @@ share/omf/gedit/gedit-it.omf
share/omf/gedit/gedit-ja.omf
share/omf/gedit/gedit-ko.omf
share/omf/gedit/gedit-oc.omf
+share/omf/gedit/gedit-pt_BR.omf
share/omf/gedit/gedit-ro.omf
share/omf/gedit/gedit-ru.omf
share/omf/gedit/gedit-sv.omf
@@ -454,6 +474,8 @@ share/omf/gedit/gedit-zh_TW.omf
@dirrm share/gnome/help/gedit/ru
@dirrm share/gnome/help/gedit/ro/figures
@dirrm share/gnome/help/gedit/ro
+@dirrm share/gnome/help/gedit/pt_BR/figures
+@dirrm share/gnome/help/gedit/pt_BR
@dirrm share/gnome/help/gedit/oc/figures
@dirrm share/gnome/help/gedit/oc
@dirrm share/gnome/help/gedit/ko/figures
@@ -489,6 +511,7 @@ share/omf/gedit/gedit-zh_TW.omf
@dirrm share/gedit-2/glade
@dirrm share/gedit-2
@dirrm %%DOCSDIR%%
+@dirrmtry libexec/gedit-2
%%PYTHON%%@dirrm lib/gedit-2/plugins/snippets
%%PYTHON%%@dirrm lib/gedit-2/plugins/pythonconsole
%%PYTHON%%@dirrm lib/gedit-2/plugins/externaltools
@@ -498,6 +521,7 @@ share/omf/gedit/gedit-zh_TW.omf
@dirrm include/gedit-%%VERSION%%
@exec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
@unexec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
+@dirrmtry share/applications
@dirrmtry share/locale/zh_HK/LC_MESSAGES
@dirrmtry share/locale/zh_HK
@dirrmtry share/locale/xh/LC_MESSAGES
@@ -526,4 +550,5 @@ share/omf/gedit/gedit-zh_TW.omf
@dirrmtry share/locale/bn_IN
@dirrmtry share/locale/be@latin/LC_MESSAGES
@dirrmtry share/locale/be@latin
-@dirrmtry share/applications
+@dirrmtry share/locale/as/LC_MESSAGES
+@dirrmtry share/locale/as
diff --git a/editors/ghex/Makefile b/editors/ghex/Makefile
index e15ad106c7b5..13a4bb2ef24b 100644
--- a/editors/ghex/Makefile
+++ b/editors/ghex/Makefile
@@ -3,11 +3,11 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/editors/ghex/Makefile,v 1.7 2007/10/11 04:06:59 mezz Exp $
+# $MCom: ports/editors/ghex/Makefile,v 1.11 2008/02/27 04:39:06 mezz Exp $
#
PORTNAME= ghex
-PORTVERSION= 2.20.1
+PORTVERSION= 2.21.92
CATEGORIES= editors gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
diff --git a/editors/ghex/distinfo b/editors/ghex/distinfo
index 316df752d7b2..cb53064e12c6 100644
--- a/editors/ghex/distinfo
+++ b/editors/ghex/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/ghex-2.20.1.tar.bz2) = c14943b79caed9b3c5362075d3f278cc
-SHA256 (gnome2/ghex-2.20.1.tar.bz2) = 088a082d0ece4a24481e4aa58d59afe3d3ed84cc38e1ad559a4eab4fafafa042
-SIZE (gnome2/ghex-2.20.1.tar.bz2) = 1249331
+MD5 (gnome2/ghex-2.21.92.tar.bz2) = e90c603fc89b0baa545d43db0579e9a2
+SHA256 (gnome2/ghex-2.21.92.tar.bz2) = 25b8f6a8e2a68a190440d26ea9dd1f7dd8b2bdcab7a2d58de0a921821b7b165e
+SIZE (gnome2/ghex-2.21.92.tar.bz2) = 1251021
diff --git a/editors/ghex/pkg-plist b/editors/ghex/pkg-plist
index 32ba00a3c52b..9f4edc750e44 100644
--- a/editors/ghex/pkg-plist
+++ b/editors/ghex/pkg-plist
@@ -126,10 +126,10 @@ share/locale/zh_TW/LC_MESSAGES/ghex-2.0.mo
@dirrm share/gnome/help/ghex2/C
@dirrm share/gnome/help/ghex2
@dirrm include/gtkhex
+@dirrmtry share/applications
@dirrmtry share/locale/rw/LC_MESSAGES
@dirrmtry share/locale/rw
@dirrmtry share/locale/oc/LC_MESSAGES
@dirrmtry share/locale/oc
@dirrmtry share/locale/dz/LC_MESSAGES
@dirrmtry share/locale/dz
-@dirrmtry share/applications