aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
Diffstat (limited to 'editors')
-rw-r--r--editors/hexedit/Makefile2
-rw-r--r--editors/hexedit/distinfo6
-rw-r--r--editors/hexedit/files/patch-search.c21
3 files changed, 4 insertions, 25 deletions
diff --git a/editors/hexedit/Makefile b/editors/hexedit/Makefile
index bb95e5858db0..880f798237d9 100644
--- a/editors/hexedit/Makefile
+++ b/editors/hexedit/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= hexedit
-PORTVERSION= 1.4.2
+PORTVERSION= 1.5
CATEGORIES= editors
MAINTAINER= sunpoet@FreeBSD.org
diff --git a/editors/hexedit/distinfo b/editors/hexedit/distinfo
index 89376ed50668..98dd7cf50b4a 100644
--- a/editors/hexedit/distinfo
+++ b/editors/hexedit/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1505487237
-SHA256 (pixel-hexedit-1.4.2_GH0.tar.gz) = c81ffb36af9243aefc0887e33dd8e41c4b22d091f1f27d413cbda443b0440d66
-SIZE (pixel-hexedit-1.4.2_GH0.tar.gz) = 30179
+TIMESTAMP = 1598777614
+SHA256 (pixel-hexedit-1.5_GH0.tar.gz) = 27a2349f659e995d7731ad672450f61a2e950330049a6fb59b77490c5e0015ac
+SIZE (pixel-hexedit-1.5_GH0.tar.gz) = 30544
diff --git a/editors/hexedit/files/patch-search.c b/editors/hexedit/files/patch-search.c
deleted file mode 100644
index 177daa1ac004..000000000000
--- a/editors/hexedit/files/patch-search.c
+++ /dev/null
@@ -1,21 +0,0 @@
---- search.c.orig 2008-11-07 15:50:57 UTC
-+++ search.c
-@@ -30,6 +30,18 @@ static int searchA(char **string, int *s
- if (!ask_about_save_and_redisplay()) return FALSE;
- if (!displayMessageAndGetString(msg, last, tmp, tmp_size)) return FALSE;
-
-+ if( hexOrAscii ) {
-+ char* cp = tmp;
-+ char* cp2 = tmp;
-+ char c;
-+ while( (c = *cp++) ) {
-+ if( isspace( c ) )
-+ continue;
-+ *cp2++ = c;
-+ }
-+ *cp2 = '\0';
-+ }
-+
- *sizea = strlen(tmp);
- if (hexOrAscii) if (!hexStringToBinString(tmp, sizea)) return FALSE;
-