aboutsummaryrefslogtreecommitdiff
path: root/emulators/bochs/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'emulators/bochs/Makefile')
-rw-r--r--emulators/bochs/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/emulators/bochs/Makefile b/emulators/bochs/Makefile
index 8c39507b1f1a..779c3d60e01c 100644
--- a/emulators/bochs/Makefile
+++ b/emulators/bochs/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= bochs
-PORTVERSION= 2.2.6
+PORTVERSION= 2.3
PORTEPOCH= 2
CATEGORIES= emulators
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
@@ -129,6 +129,7 @@ post-patch:
s|bios/VGABIOS|${DATADIR}/VGABIOS|; \
' ${WRKSRC}/.bochsrc
@${REINPLACE_CMD} -E ' \
+ s|install_share install_doc|install_share|; \
s|(^sharedir.+=).+|\1 ${DATADIR}|; \
s|(^docdir.+=).+|\1 ${DOCSDIR}|; \
' ${WRKSRC}/Makefile.in
@@ -141,6 +142,10 @@ post-patch:
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/CHANGES ${DOCSDIR}/CHANGES
+ @${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}/README
+ @${INSTALL_DATA} ${WRKSRC}/TODO ${DOCSDIR}/TODO
+ @${INSTALL_DATA} ${WRKSRC}/.bochsrc ${DOCSDIR}/bochsrc-sample.txt
@${INSTALL_DATA} ${WRKSRC}/docs-html/*.txt ${DOCSDIR}
@${MKDIR} ${DOCSDIR}/html
@${INSTALL_DATA} ${WRKSRC}/docs-html/*.html ${DOCSDIR}/html