aboutsummaryrefslogtreecommitdiff
path: root/emulators/citra/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'emulators/citra/Makefile')
-rw-r--r--emulators/citra/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/emulators/citra/Makefile b/emulators/citra/Makefile
index 81640316c2dd..4982654322aa 100644
--- a/emulators/citra/Makefile
+++ b/emulators/citra/Makefile
@@ -2,6 +2,10 @@ PORTNAME= citra
PORTVERSION= s20211218
PORTREVISION?= 0
CATEGORIES= emulators
+MASTER_SITES= https://api.citra-emu.org/gamedb/?dummy=/:gamedb \
+ LOCAL/jbeich:gamedb
+DISTFILES= ${PORTNAME}/compatibility_list.json:gamedb
+EXTRACT_ONLY= ${DISTFILES:N*\:gamedb:C/\:.*//}
MAINTAINER= jbeich@FreeBSD.org
COMMENT= Nintendo 3DS emulator/debugger
@@ -89,4 +93,8 @@ post-patch:
-e 's/@GIT_DESC@/${GH_TAGNAME}/' \
${WRKSRC}/src/common/scm_rev.cpp.in
+post-configure:
+ @${CP} ${DISTFILES:M*\:gamedb:C/\:.*//:S,^,${_DISTDIR},} \
+ ${BUILD_WRKSRC}/dist/compatibility_list/
+
.include <bsd.port.mk>