aboutsummaryrefslogtreecommitdiff
path: root/emulators/dynagui/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'emulators/dynagui/Makefile')
-rw-r--r--emulators/dynagui/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/emulators/dynagui/Makefile b/emulators/dynagui/Makefile
new file mode 100644
index 000000000000..4ab53d14e77c
--- /dev/null
+++ b/emulators/dynagui/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: dynagui
+# Date created: 5 February 2009
+# Whom: Andrew Greenwood
+#
+# $FreeBSD$
+#
+
+PORTNAME= dynagui
+PORTVERSION= 0.4
+CATEGORIES= emulators
+MASTER_SITES= SF
+DIST_SUBDIR= dynagui
+
+MAINTAINER= greenwood.andy@gmail.com
+COMMENT= GUI frontend to the dynamips router simulator
+
+BUILD_DEPENDS= dynagen:${PORTSDIR}/emulators/dynagen-devel
+
+USE_PYTHON= 2.5+
+USE_PYDISTUTILS= yes
+IMGDIR= ${PREFIX}/share/${PORTNAME}/img
+
+post-install:
+ ${MKDIR} ${IMGDIR}
+ ${INSTALL_DATA} ${WRKSRC}/img/* ${IMGDIR}
+ ${CHMOD} 755 ${PYTHON_SITELIBDIR}/dynagui.py
+ ${LN} -sf ${PYTHON_SITELIBDIR}/dynagui.py ${PREFIX}/bin/dynagui.py
+
+.include <bsd.port.mk>