aboutsummaryrefslogtreecommitdiff
path: root/emulators/frodo/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'emulators/frodo/Makefile')
-rw-r--r--emulators/frodo/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/emulators/frodo/Makefile b/emulators/frodo/Makefile
index 5c1263b50905..8b034744bbfe 100644
--- a/emulators/frodo/Makefile
+++ b/emulators/frodo/Makefile
@@ -23,7 +23,9 @@ WRKSRC= ${WRKDIR}/Frodo/Src
ROM= 1541 Basic Char Kernal
post-patch:
- @${PERL} -pi -e "s|%%LOCALBASE%%|${LOCALBASE}|g" ${WRKDIR}/Frodo/TkGui.tcl
+ @${MV} ${WRKDIR}/Frodo/TkGui.tcl ${WRKDIR}/Frodo/TkGui.tcl.sed
+ ${SED} -e "s|%%LOCALBASE%%|${LOCALBASE}|g" \
+ ${WRKDIR}/Frodo/TkGui.tcl.sed > ${WRKDIR}/Frodo/TkGui.tcl
do-configure:
@(cd ${WRKSRC}; ${SH} ./configure)