aboutsummaryrefslogtreecommitdiff
path: root/emulators/fuse-utils/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'emulators/fuse-utils/Makefile')
-rw-r--r--emulators/fuse-utils/Makefile19
1 files changed, 11 insertions, 8 deletions
diff --git a/emulators/fuse-utils/Makefile b/emulators/fuse-utils/Makefile
index 2effc45ea52c..cef964f269a6 100644
--- a/emulators/fuse-utils/Makefile
+++ b/emulators/fuse-utils/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= fuse-utils
-PORTVERSION= 0.10.0.1
+PORTVERSION= 1.0.0
CATEGORIES= emulators
MASTER_SITES= SF/fuse-emulator/${PORTNAME}/${PORTVERSION}
@@ -16,16 +16,21 @@ COMMENT= Utilities from the Free Unix Spectrum Emulator
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= spectrum.7:${PORTSDIR}/emulators/libspectrum
-
-OPTIONS= AUDIOFILE "Build audio <-> tape utilities" on
+MAKE_JOBS_SAFE= yes
+LIB_DEPENDS= spectrum.8:${PORTSDIR}/emulators/libspectrum
GNU_CONFIGURE= yes
-
-.include <bsd.port.pre.mk>
+CONFIGURE_ARGS= --with-libspectrum-prefix=${LOCALBASE} \
+ --with-local-prefix=${LOCALBASE}
MAN1= createhdf.1 fuse-utils.1 listbasic.1 raw2hdf.1 rzxcheck.1 rzxdump.1 rzxtool.1 scl2trd.1 snap2tzx.1 snapconv.1 tapeconv.1 tzxlist.1 profile2map.1
+.include <bsd.port.options.mk>
+
+OPTIONS= AUDIOFILE "Build audio <-> tape utilities" on
+
+.include <bsd.port.pre.mk>
+
.if !defined(WITHOUT_AUDIOFILE)
LIB_DEPENDS+= audiofile.0:${PORTSDIR}/audio/libaudiofile
PLIST_SUB= AUDIOFILE=""
@@ -35,8 +40,6 @@ CONFIGURE_ARGS+=--without-audiofile
PLIST_SUB= AUDIOFILE="@comment "
.endif
-MAKE_JOBS_SAFE= yes
-
.if !defined(NOPORTDOCS)
post-install:
@${MKDIR} ${DOCSDIR}